Author Topic: Avast counting wrong the number of signatures in database?  (Read 14686 times)

0 Members and 1 Guest are viewing this topic.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6927
Re: Avast counting wrong the number of signatures in database?
« Reply #15 on: April 15, 2005, 03:46:31 PM »
Spyros - what's the color quality value in your Desktop Properties under Settings tab ? Of course, I mean on Windows 2000 system...
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #16 on: April 15, 2005, 03:55:23 PM »
The screenshot doesn't really show the dialog :)
Can you please try to find other occurrences (of the group line crossing the text) in the program? I have seen it in the settings of logging sensitivity, for example. Does it appear only in Simple User Interface with skins, or Simple User Interface without skins... or even Enhanced User Interface?
Thanks.


OK, here we go...
Diagonal lines show up on some (not all) windows especially in the settings.
You are right about logging + I found another one. SUI or EUI doesn't seem to make a difference. Here are some screenshots.

One...

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #17 on: April 15, 2005, 03:56:17 PM »
Two..

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #18 on: April 15, 2005, 03:57:35 PM »
Three...

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #19 on: April 15, 2005, 03:59:45 PM »
Spyros - what's the color quality value in your Desktop Properties under Settings tab ? Of course, I mean on Windows 2000 system...
Natural colors (32 bit) --> If translated correctly from Greek  ;)

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #20 on: April 15, 2005, 04:04:33 PM »
In other avast-windows everything is normal

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6927
Re: Avast counting wrong the number of signatures in database?
« Reply #21 on: April 15, 2005, 04:05:21 PM »
Hmmmm... I knew you wouldn't use anything below 32-bit  ;D

Windows 2000 definitly reads those graphic information in a different way...
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6927
Re: Avast counting wrong the number of signatures in database?
« Reply #22 on: April 15, 2005, 04:06:15 PM »
Two..

Spot that on your screenshot number two... word OPTION on the left and words LOGGING LEVEL on the right... same thing on first screenshot...  ??? I think Alwil guys could find out something from these screenshots now... they have to take a deeper look inside the code where are all those information stored, and they may find some differences in between those two texts (option and Logging level)...
« Last Edit: April 15, 2005, 04:08:39 PM by S.Z.Craftec »
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #23 on: April 15, 2005, 04:07:51 PM »
Two..

Spot that on your screenshot number two... word OPTION on the left and words LOGGING LEVEL on the right...
The same goes in "One". Again, both are different.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11867
    • AVAST Software
Re: Avast counting wrong the number of signatures in database?
« Reply #24 on: April 15, 2005, 04:18:06 PM »
You are right about logging + I found another one. SUI or EUI doesn't seem to make a difference.

Does it mean that the bad drawing is present both in Simple and Enhanced User Interface?

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #25 on: April 15, 2005, 04:23:18 PM »
You are right about logging + I found another one. SUI or EUI doesn't seem to make a difference.

Does it mean that the bad drawing is present both in Simple and Enhanced User Interface?


Igor, I just discovered something interesting. When (in simple UI) "Enable skins for Simple UI" is not checked (no skins) the problems exist. With skins, there is no problem.

« Last Edit: April 15, 2005, 04:37:22 PM by Spyros »

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #26 on: April 15, 2005, 04:38:00 PM »
The problem exists in Enhanched User interface.

So, it is:
Simple UI + skins = no problem
Simple UI + no skins = problem
Enhanched UI = problem

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11867
    • AVAST Software
Re: Avast counting wrong the number of signatures in database?
« Reply #27 on: April 18, 2005, 01:26:18 PM »
Spyros, could you make one experiment, please?
Delete the file <avast4>\Images\background.bmp and then start Enhanced UI and check the dialogs - is the problem still present, or is it gone?

Spyros

  • Guest
Re: Avast counting wrong the number of signatures in database?
« Reply #28 on: April 18, 2005, 01:37:04 PM »
Spyros, could you make one experiment, please?
Delete the file <avast4>\Images\background.bmp and then start Enhanced UI and check the dialogs - is the problem still present, or is it gone?


This one solved all of the above problems in both simple & enhanched UI  :D Thanks Igor!
But won't an update/repair of avast put the .bmp back?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11867
    • AVAST Software
Re: Avast counting wrong the number of signatures in database?
« Reply #29 on: April 18, 2005, 02:15:01 PM »
Yes, it will, that was just an experiment. We'll try to do something about it.