Author Topic: Can't install Avast: There was an error while completing the setup process  (Read 5584 times)

0 Members and 1 Guest are viewing this topic.

AbyssRain

  • Guest
Hello, I'm new to the forums so if there's anything I'm doing wrong or missing, please help me out.

So a few weeks ago I uninstalled Avast due to some issues I was having starting up my computer. Only recently did I remember to reinstall it.

I download the setup and chose express install, after maybe 70% of the installation was done, it stopped at the aswsp.sys file and began to uninstall all the files.
I've been looking around for days. I've tried rebooting and trying again. Uninstalling in safe mode and again. Turning off my firewall and again. I ran tons of scans with Malware Bytes, ClamWin and a few others. The only program I have running while installing is TuneUp Utilities.


Operating system: Windows 7 ver 6.1, buil 7601, sp 1.0

Where it starts to uninstall, the log says:
Extract: tried to extract '(path)\aswsp.sys' from pkg 'ais_res' but failed miserably. error code 0x20000011
Uninstalling aswTdi.sys
Stopping aswTdi.sys

If you need any additional info, just ask.

Aventador

  • Guest
So if you uninstalled Avast what were you using after that? Nothing?

wyrmrider

  • Guest
what other avs were installed or came with your computer?
use their uninstallers and avasts uninstaller then reboot and reinstall avast

AbyssRain

  • Guest
I wasn't using any AVs, as I had forgotten that I'd gotten rid of Avast. I'm quite sure I've uninstalled all other AVs (or more like I never installed any) I have read many suggestions about this but I don't believe this is the issue :P

wyrmrider

  • Guest
maybe one of the mods will chime in
did you run the avast uninstaller?
safe mode?

Aventador

  • Guest
Uninstall Avast using the Avast Uninstaller. Then download a fresh copy of Avast.

http://www.avast.com/uninstall-utility

AbyssRain

  • Guest
Uninstall Avast using the Avast Uninstaller. Then download a fresh copy of Avast.

http://www.avast.com/uninstall-utility

I would like to point out I've already said that I tried to uninstall :P
Yes, I used the uninstaller in safe mode