Author Topic: Take a backup! (Rooted)  (Read 1325 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Take a backup! (Rooted)
« on: January 11, 2015, 06:29:29 PM »

This is my first time posting, although I am using Avast Anti-Theft for quite a while. I haven't found any bug with the app, and I am grateful for that! I have one question though. This is the only app that I am unable to backup using Titanium backup! I have tried creating custom .zips, I have tried the backup options from inside the app, but after every ROM flash I have to re-enter all my account details. UPDATE.ZIP works, and the app gets installed in /system/priv-app, but the app settings can't be flashed (even if I use the Hard reset protection UPDATE.ZIP).

My specs:
Nexus 5 32GB
Lollipop 5.0.2 SimpleAOSP ROM
Rooted/Unlocked bootloader etc

What exactly does the app check when it looks for the settings file? Why can't a simple copy/paste work? Is it looking for an Android ID (or whatever else is changing between flashes)?

Any suggestion is welcome. I am sick of re-entering my details after every flash :)


  • Guest
Re: Take a backup! (Rooted)
« Reply #1 on: January 16, 2015, 03:52:53 PM »
Please, any Avast Android Developer, give me a hand on this! :)

These are the messages:

(I removed the key in case it is security related)

What can I change so that I don't get this message? Is the settings file encrypted with some key that changes during flashes? I tried to open the .enc file on my PC with Notepad++ but it was semi gibberish (all I could read was about a preferences.xml file).

Please please please :)