Author Topic: No Icon = No Protection?  (Read 11955 times)

0 Members and 1 Guest are viewing this topic.

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9401
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: No Icon = No Protection?
« Reply #15 on: May 01, 2005, 01:07:11 PM »
Mail scanner and Web Shield are optional,others are not.
But it's very strange. If processes are running,including ashDisp.exe you should get warning. ashDisp.exe is a visualizations module that shows all warning messages,tray icons and so on.
Visit my webpage Angry Sheep Blog

Tori

  • Guest
Re: No Icon = No Protection?
« Reply #16 on: May 01, 2005, 01:18:31 PM »
Not quite sure how I attach a picture (what to put inside the tags), but it says that the following are all running:
avast! IAVS4 Control Service
avast! Antivirus
avast! Mail scanner
avast! Web scanner

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9401
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: No Icon = No Protection?
« Reply #17 on: May 01, 2005, 01:25:07 PM »
Open you avast! installation folder (usually C:\Program Files\Alwil Software\Avast4)
and run ashLogV.exe

Select "Error" subsection on the left,right-click on the field on the right and select "Export current list"
Repeat this process for "Warning" subsection.

Attach both files here or just copy&paste its content here.
Visit my webpage Angry Sheep Blog

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: No Icon = No Protection?
« Reply #18 on: May 01, 2005, 02:52:02 PM »
Not quite sure how I attach a picture (what to put inside the tags)

http://forum.avast.com/index.php?topic=8982.0  ;)
The best things in life are free.

Tori

  • Guest
Re: No Icon = No Protection?
« Reply #19 on: May 02, 2005, 02:17:17 PM »
Note that ashdisp is NOT one of the running processes. Should it be? Is that the issue? Here are the logs...



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: No Icon = No Protection?
« Reply #20 on: May 02, 2005, 02:43:12 PM »
Note that ashdisp is NOT one of the running processes.
ashdisp.exe is the 'icon' on the system tray...
Using AEC (click 'Control' in my signature) you can bring it back  :)
The best things in life are free.

Tori

  • Guest
Re: No Icon = No Protection?
« Reply #21 on: May 02, 2005, 03:15:35 PM »
I must be dense, coz I can't see where in AEC to bring it back ???

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: No Icon = No Protection?
« Reply #22 on: May 02, 2005, 03:39:55 PM »
I must be dense, coz I can't see where in AEC to bring it back ???
Run it, choose avast Tweaker, and the first option there 'Show tray icon'...
In fact there were a second possibility in the past that was 'Restart avast! protection' but new version of AEC does not support it anymore.
The best things in life are free.

Tori

  • Guest
Re: No Icon = No Protection?
« Reply #23 on: May 02, 2005, 04:00:53 PM »
Ah, you've sent me there before, and nothing has changed! That option is ticked; in fact only the two 'suppress' and the 'web shield' options aren't ticked. I seem to be going around in circles here! Did the error / warning logs contain no clues to you more informed people?

anbu

  • Guest
Re: No Icon = No Protection?
« Reply #24 on: May 02, 2005, 04:12:37 PM »
create a shortcut of ashdisp.exe found in C:\program files\alwil software\avast4\
place it in startup folder in start menu and reboot .

Tori

  • Guest
Re: No Icon = No Protection?
« Reply #25 on: May 02, 2005, 04:33:26 PM »
Excellent! Perhaps that was all it needed - DOH! Thank you very much everyone for your assistance!

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9401
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: No Icon = No Protection?
« Reply #26 on: May 02, 2005, 05:29:47 PM »
You apperantly erased startup entry of avast!. At least thats what i can assume from Warning log (some serious infestation you had).
Visit my webpage Angry Sheep Blog

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: No Icon = No Protection?
« Reply #27 on: May 02, 2005, 07:24:39 PM »
You apperantly erased startup entry of avast!. At least thats what i can assume from Warning log (some serious infestation you had).
RejZor, this will be a pity... The old versions of AEC could 'bring the icon' back and this can't.
Maybe you (and I) could reconsider the opinion on removing this feature from AEC.  :-\
The best things in life are free.

Online DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86657
  • No support PMs thanks
Re: No Icon = No Protection?
« Reply #28 on: May 02, 2005, 07:29:57 PM »
Are you by any chance using spysweeper?
If so, use the restore/recover or whatever it may be called to restore the deleted registry entry and update your definitions file for spysweeper.

There have been numerous occasions that it has reported incorrectly (false positive) the avast ashDisp.exe which is the icon you see on your system tray.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security