Author Topic: local mail server  (Read 3762 times)

0 Members and 1 Guest are viewing this topic.

gerfried

  • Guest
local mail server
« on: September 28, 2003, 08:58:00 AM »
Hi,

I have my own local mail server running. When running the SMTP/POP/IMAP-Protection with standard settings,
my mail server is disabled.
Please tell me how to configure avast! to work in this configuration?  ???
It would be cool to have avast scan all my ingoing mails before the mail server gets its hand on it, how can I acieve this? ::)

thx in advance
gerfried

PS: I'm using avast personal edition.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:local mail server
« Reply #1 on: September 28, 2003, 09:47:08 AM »
It's no wonder that it doesn't work. The reason is that avast has its own SMTP/POP3/IMAP4 listener as well, so these two compete for the same port numbers (and only one of the can be satisfied). To resolve this, you have to set up either avast or the other mailserver to listen on alternate port numbers. See the avast help (section called Manual setting of mail protection) for more info on how to do this in avast, or refer to the following thread: http://www.avast.com/forum/index.php?board=2;action=display;threadid=593;start=msg2857

Hope this helps,
Vlk
If at first you don't succeed, then skydiving's not for you.

gerfried

  • Guest
Re:local mail server
« Reply #2 on: September 28, 2003, 10:28:44 PM »
Hi Vlk,
this is, what I suspected.
I have my mailserver running. I would like to have avast running BEFORE my mail server software (BTW: its msgcore).

I'm not sure, how to configure avast.
smtplisten should be localhost:25, I'm quite sure.
setting the defaultsmtpserver to localhost:8025 does not really work, but should this be the configuration?
I do have troubles setting the smtp-in-port for msgcore.

but this should be the correct way, right?
gerfried