Author Topic: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt  (Read 6215 times)

0 Members and 1 Guest are viewing this topic.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #15 on: September 19, 2013, 03:08:49 PM »
Have you deleted the network card from device manager, then rebooted and allowed windows to reinstall it

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #16 on: September 19, 2013, 07:56:09 PM »
OK.  Done that.  As before, my network icon has a red cross through it and hovering over it says "not connected - no network connections are available"

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #17 on: September 19, 2013, 08:33:17 PM »
Could you right click the network adapter and let me know the make and model please

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #18 on: September 19, 2013, 08:50:08 PM »
Realtek PCIe GBE Family Controller

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #19 on: September 19, 2013, 09:11:29 PM »
Is this a desktop or laptop ?  What is the make and model

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #20 on: September 19, 2013, 09:32:19 PM »
Its a desktop and it was built by PCSpecialist.co.uk.  Pretty much custom built from a series of options choices.

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #21 on: September 19, 2013, 09:45:17 PM »
hi Crackity Jones,

I think what essexboy is looking for is hardware configurations, esp. since custom-built and not your standard OEM product.  Motherboard info, integrated NIC card used or add-in slot, etc.,.  Once he has that info, should be better able to assist you.

You can always use Belarc Advisor to get the exact configuration info for your system.  No need to post entire html document, just post what you think is needed.
« Last Edit: September 19, 2013, 09:47:40 PM by mchain »
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #22 on: September 19, 2013, 11:00:39 PM »
OK - sorry.

Motherboard: Gigabyte Technology Co., Ltd. P55M-UD2
NIC: as mentioned is Realtek PCIe GBE Family Controller and integrated
OS: Windows 7 Ultimate (x64) Service Pack 1 (build 7601)

Anything else you need to know, let me know as I've run the Belarc Advisor now

Periodically Network and Sharing Center changes to "Identifying" and then reverts back to "Not Connected - No Connections are available"

I've tried a different network cable, even though there was no problem before the Avast update hung the PC and the problems started but the same result.

I've downloaded the most recent driver for the Realtek, but no change.

If I run the Windows Network Diagnostics Troubleshooter it says"Plug an Ethernet cable into this computer"  Obviously, one is already plugged in.

I've run ipconfig /all and that seems to confirm the above - sometimes it says "Media disconnected" another time it gives a result.


Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #23 on: September 19, 2013, 11:05:33 PM »
Could you do the following please

1.To open a command prompt, click Start and then type CMD in the Search programs and files.
2.Right-click CMD.exe icon in Programs and choose Run as administrator.
3.When the User Account Control box pop up, click Yes.
4.At the command prompt, copy and paste (or type) the following command and then press ENTER:

netsh int ip reset c:\resetlog.txt

Reboot and then try again using the trouble shooter

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #24 on: September 20, 2013, 01:00:56 AM »
No change, I'm afraid.

Offline Crackity Jones

  • Newbie
  • *
  • Posts: 14
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #25 on: September 20, 2013, 03:40:20 PM »
OK - I'm now back up and online as evidenced by the fact that I'm posting this from the PC that had all of the problems.  The solution proved a lot simpler.  Here's what I did:

1. Powered down the PC.
2. Removed the power cable and ethernet cable.
3. Wait 20 seconds.
4. Re-insert power cable.
5. When PC fully booted, re-insert ethernet cable.

Hey Presto, connection detected and back online.

Many, many thanks to essexboy for all your help and patience.

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40627
  • Dragons by Sasha
    • Malware fixes
Re: Windows 7 Ultimate 64 bit won't boot due to aswVmm.sys missing or corrupt
« Reply #26 on: September 20, 2013, 03:55:32 PM »
Glad to hear you found a solution, computers are sometimes just plain contrary :)