Author Topic: Scan Localhost  (Read 2976 times)

0 Members and 1 Guest are viewing this topic.

Abstract40

  • Guest
Scan Localhost
« on: October 06, 2013, 08:33:26 PM »
Hi All,

My email client is connecting through a ssh tunnel to the email server.
The ssh tunnel is forwarding all the pop/smtp requests from the localhost to the email server.

When I used Avast Internet Security 4 I was able to set an option in the Mail Shield to listen to the localhost.
In the Avast Internet Security 5 I can't find this option any longer. I did see some suggestions to set IgnoreLocalhost=0 in avast4.ini.
So I hope it also work for avast5.ini and I did set the following:

Code: [Select]
[EmailShield]
ScanLinks=1
IgnoreLocalhost=0

[MailScanner]
IgnoreLocalhost=0

It looks like it didn't help anything. Does anyone know how I can make Avast Internet Security 5 scan my retrieved emails on the localhost?

Thanks

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6710
  • Trust only what you test yourself!
Re: Scan Localhost
« Reply #1 on: October 06, 2013, 08:54:36 PM »
What are you using as an email client?  ???
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Abstract40

  • Guest
Re: Scan Localhost
« Reply #2 on: October 06, 2013, 09:39:53 PM »
Im using The Bat version 5.4

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37152
  • Not a avast user
Re: Scan Localhost
« Reply #3 on: October 06, 2013, 10:16:43 PM »
Quote
In the Avast Internet Security 5 I can't find this option any longer
why avast 5 ?


Abstract40

  • Guest
Re: Scan Localhost
« Reply #4 on: October 06, 2013, 11:45:57 PM »
Sorry I though it was five because of the avast5.ini file.
Checking the version I see I have version 8.0.1497.

Abstract40

  • Guest
Re: Scan Localhost
« Reply #5 on: October 13, 2013, 04:33:25 PM »
Does anyone has an answer for this?

In the older versions of Avast there was this configuration option which helped me solving this problem:


In the new version this configuration options have been removed. I did add the following lines to avast5.ini
without much success. Avast keeps refusing to scan my incoming mail from the localhost port 110.

[EmailShield]
ScanLinks=1
IgnoreLocalhost=0
[MailScanner]
IgnoreLocalhost=0

Abstract40

  • Guest
Re: Scan Localhost
« Reply #6 on: November 09, 2013, 03:08:34 PM »
For everyone who is struggling with the same problem. The solution is relatively easy.
Open the file: C:\Users\All Users\AVAST Software\Avast\EmailShield.ini

Change the setting IgnoreLocalhost=1 to IgnoreLocalhost=0
Restart the pc and it all works again