Author Topic: How do I configure SMTP alerts?  (Read 13880 times)

0 Members and 1 Guest are viewing this topic.

Offline Bascule

  • Newbie
  • *
  • Posts: 19
  • I'm a llama!
How do I configure SMTP alerts?
« on: May 21, 2005, 12:32:53 AM »
I may be being daft here but I can't figure out how to get the SMTP alerts working. What's the syntax for the line I enter into the "Net alert address" dialog box? I keep getting "Unknown error - the alert cannot be sent"

 ???

Any help would be gratefully received.

Thanks,
Andy

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84929
  • No support PMs thanks
Re: How do I configure SMTP alerts?
« Reply #1 on: May 21, 2005, 12:45:47 AM »
Extract from avast help file:
Quote
"Alerts" Page

avast! is able to send a warning message about a virus occurrence. This feature is useful for network administrators who will be notified about the presence of a virus on any computer they administrate, so that they can react quickly.

The alert can be sent using the following means:

SMTP. The alert will be sent as an e-mail, using the SMTP protocol. It is necessary to define the SMTP Server, i.e. the mail server the messages will be sent through (e.g. smtp.company.com or 192.168.1.1). Additionally, you have to specify the port that will be used (the standard value is 25). Finally, enter the sender address ("From", i.e. the user address).
MAPI. The alert will be sent as an e-mail, using the MAPI protocol. Enter the MAPI profile name, together with the corresponding password to use.
WinPopup. The alert will be sent using the net send command. Enter the IP address or the network name of the computer to send the warning to.
ICQ. The alert will be sent as an ICQ message. Enter the UIN of the ICQ client to send to warning to.
Windows Messenger. The alert will be sent as a message of the Windows Messenger program. Enter the e-mail address that the alert recipient uses to login to the Windows Messenger service.
Add. After pressing the button, you will select the protocol to use (SMTP/MAPI/ICQ...). Additionally, you can enter the corresponding settings (see above).
Remove. Removes selected address.
Edit. Modifies selected address.
Test. A test message is sent to the selected address.
Test all. A test message is sent to all the addresses on the list.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84929
  • No support PMs thanks
Re: How do I configure SMTP alerts?
« Reply #2 on: May 21, 2005, 12:59:05 AM »
Where it says this "using the SMTP protocol, it is necessary to define the SMTP server, Did you set-up the SMTP account to use to send the email?

I would say probably not, below the alerts icon you will see an icon for SMTP, you must set-up that first.

Then the "Net alert address" is the email address you want the email sent to.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline mIk4Avast

  • Newbie
  • *
  • Posts: 2
Re: How do I configure SMTP alerts?
« Reply #3 on: October 07, 2005, 04:53:44 AM »
It would be nice to have clear instructions on this fairly simple task.  I'll do the best I can to explain the process.

First, right click on the Avast icon (the blue ball with an “a” on it) and select Program Settings.  Next, highlight SMTP on the left side of the window to expose the SMTP options.  (You can get the information needed here from your email accounts settings.)  The Server address should be something similar to “mail.ispcompany.com”.  The Port is usually 25.  The From Address will be your email address, something like "emailname@ispcompany.com".  If your mail server requires authentication, enter the user name and password you use to connect (authenticate to be allowed to use there service).  You now have an account set up to be used to send email alerts. 
Now, in the left hand side of the window, highlight the "Alerts" icon.  On the right side of the window click “Add” and select “SMTP”.  In the “Type net alert address…" type your email account (name@ispcompany.net).   Click "OK" and then click “Test”.  If you see “The alert was successfully sent” message, you are good to go.

I really hope this helps someone.

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84929
  • No support PMs thanks
Re: How do I configure SMTP alerts?
« Reply #4 on: October 07, 2005, 02:57:24 PM »
Extract from avast! help file:
Quote
"SMTP" Page

On this page, you can specify your SMTP server parameters. avast! uses these settings to send e-mail messages, especially when:

Sending warning messages when a virus has been found.
Sending files from the Chest to ALWIL Software.
Sending avast! crash reports to ALWIL Software.
You should enter the following information:

Server address - the address of the outgoing e-mail server (e.g. smtp.server.com or 192.168.1.25).
Port - the port number (the default is 25).
From address - address of the sender ("From").
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline pabloexactas

  • Newbie
  • *
  • Posts: 4
Re: How do I configure SMTP alerts?
« Reply #5 on: March 30, 2007, 05:50:38 AM »
Hello, sorry but my english is poor. Well, i have a problem with "avast Home last version" smtp alert... i configure the smtp settings and i add my email in the menu alert --> smtp... i test and it send the message to my email, i check the mail and i receive the mail that said "virus alert".....at this poitn all right but i scan files that had viruses and i dont receive the email to my account. I can receive the test but not the alert message(from virus alerts on access protection)... i don`t know what to do...please help me.

Note: if i use MAPI i receive the email to my account, but i don`t want to use it because it open outlook's windows and its sucks.....and i configure en Avast the MAPI settings --> profile, password and it pide the password of the outlook's account, i dont like it... i want to use SMTP sending protocol.

Bueno si hablan en castellano, les comento mi problema. El tema es que configure para recibir un mail de alerta por si encuentra algun virus.... hago la prueba y me dice que mando el mail satisfactoriamente, chequeo el mail y alli esta el mensaje... el problema es cuando deberia mandarme un mail cuando encuentra un archivo infectado(no en el test), puedo llagar a ver que aparece el icono en la barra de windows que dice escaneando el mensaje de salida y nada mas. Chequeo el mail y nunca llega!... reviso el archivo .log de ashMail y encuentro que dice que el smtp esta limpio(sin virus), es decir, lo envia,.....no puedo explicar que sucede.

Comentario: si hago que mande por MAPI me llega pero no quiero que use una cuenta de outlook ni que abra una ventana para esto.

Thanks! Saludos,
PabloExactas.

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84929
  • No support PMs thanks
Re: How do I configure SMTP alerts?
« Reply #6 on: March 30, 2007, 03:35:38 PM »
It sounds like you set it up OK to be able to Test it. I don't see why it is able to send using MAPI and not SMTP. Nor can I see why it should be able to pass the test yet fail to send in the same way for the real alert notification.

I tried also, the SMTP test, it fired off with no issues other than my firewall alerted (first time use permissions) once accepted an email was sent directly. I now checked a known virus and avast alerted but it also failed to send using SMTP. The interesting thing is that the test doesn't have any interaction with OE my default email client and doesn't appear in the Sent Items folder.

So I added an email address to the MAPI section and did a check, avast alerted and an email alert was generated that worked, with very limited success, which wouldn't have worked in the real world if it was unattended. An alert popped-up asking if it was OK to send an email using OE and all this did was place an email in the Outbox waiting to be sent.

This is an old Topic almost two years old and things have obviously changed since then, you no longer have to input the SMTP user name and password as I believe this is taken from your  email client's default account settings.

So I couldn't get it to work on SMTP either, hopefully one of the avast team will pick up on this.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.3.2459 (build 21.3.6164.561) UI 1.0.609/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline pabloexactas

  • Newbie
  • *
  • Posts: 4
Re: How do I configure SMTP alerts?
« Reply #7 on: March 30, 2007, 03:55:33 PM »
Well, it's the machine of my cousin and he is 8 years old, so i want send the alert by smtp service, the problem with OE its the windows that appear to notify permission to send message(i use OE from WinXP SP2) and i configure the MAPI setting on avast and it open a windows for choose a profile(and i configure!), its strange but also its working bad....i dont use another firewall like windows xp have.


I dont know what to use... i tried with yahoo, hotmail and i dont receive the alert mail(when it send, appear the scanning outgoing message icon but not another message box) , i dont explain why send the test mail but not the real alert ::)......and the log file its ok about the outgoing message.


So I couldn't get it to work on SMTP either, hopefully one of the avast team will pick up on this.


I hope

Thanks,
PabloExactas.






« Last Edit: March 30, 2007, 04:22:59 PM by pabloexactas »

Offline mwilg

  • Newbie
  • *
  • Posts: 12
Re: How do I configure SMTP alerts?
« Reply #8 on: July 18, 2007, 07:17:40 PM »
Hopefully someone'll see this even though it's been since Mar for the previous post.
I have never been able to get this thing to work, even though I now have the Pro edition installed.
I really appreciate the instructions from mIk4Avast, I would not have understood the need to use the 'Add' function since it appears to already be there.
Anyway, still after having done all that, I now get an error saying 'An existing connection was forcibly closed by the remote host'
Good grief...now what!!?  :'(