Author Topic: [9.0.2006] Win 8 reports Avast is off and cant monitor it in Action Center  (Read 3760 times)

0 Members and 1 Guest are viewing this topic.

SilverCloud2003

  • Guest
Just updated and rebooted.  Action Center reports both Avast and WD are off (Avast is on and reports all is good) and gives a button to view antivirus options.  Hitting that button gives me the attached dialog that Windows cant monitor Avast if turned on.  Same thing for anti-malware protection.

This a bug or compatibility issue?

pjb11

  • Guest
I have had this issue as well. Happened in the beta's frequently and on odd occasion during RC1 and RC2 but not RC3.
Last correspondence a while back, when this happened in V8 was devs were looking into it..

This not only happens in W8*64 but also 8.1*64

Hopefully the devs are continuing to work out why this happens.

SilverCloud2003

  • Guest
I have had this issue as well. Happened in the beta's frequently and on odd occasion during RC1 and RC2 but not RC3.
Last correspondence a while back, when this happened in V8 was devs were looking into it..

This not only happens in W8*64 but also 8.1*64

Hopefully the devs are continuing to work out why this happens.

Im running w8 x64....guess Im stuck waiting for a fix....

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
It usually takes one or two more reboots to fix that... I know, it's strange, but I have seen it too many times to not believe it.
The Windows Action Center seems to be somehow caching the information.

Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
If it doesn't catch up after three or four boots you will need to re-register a dll

This is a security centre problem not Avasts :)

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31079
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Reset the security center:
1. Go to control panel and open Administrative tools.
2. Click on services.
3. Go down to Windows Management Instrumentation.
4. Stop this service. Stop Security Center service too. Set them to Automatically start.
5. Exit out of this area, to your desktop.
6. Right click Start, and choose Explore.
7. Go to c:\windows\system32\wbem\repository. Delete this subdirectory ONLY. Leave the others there.
8. Exit back to your desktop and reboot your computer (you might need to boot twice).

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Hi Eddy windows 8 works slightly different to other versions of windows

Start an elevated command prompt and run the following commands with a reboot between each

regsvr32 /u WMIUTILS.DLL
Reboot
regsvr32 WMIUTILS.DLL
Reboot

SilverCloud2003

  • Guest
It usually takes one or two more reboots to fix that... I know, it's strange, but I have seen it too many times to not believe it.
The Windows Action Center seems to be somehow caching the information.

Cheers
Vlk

Took 5 restarts in my case...all is well in the Action Center now.

Next challenge:  Why I cant move or copy files to my phone (SGS3) with Avast active...