Author Topic: Avast is Killing my P.C.! help please.  (Read 3829 times)

0 Members and 1 Guest are viewing this topic.

Offline Sn00pY

  • Newbie
  • *
  • Posts: 6
Avast is Killing my P.C.! help please.
« on: October 21, 2013, 04:36:47 PM »
hi all, i got a few problems with the recent avast update, to 2014.

problem 1. my windows 7 now reports that, i no longer have an antivirus and / or that my current anti-virus software is offline.
problem 2. scanning my pc (quick scan or full scan) cause BSoD
problem 3. my Anti-Malware software is detecting the Avast folder (installation dir) as containing malicous content and keeps getting deleted.
problem 4. Avast reports "everything is good", when i disable all my other security features (anti-malware n such), but when i start my anti-malware software, it deleted avast. forcefully.
problem 5. teamviewer software is detected as a "MyDoom" Trojan (although, several other anti-viruses do not report such a thing, nor do i have any of the normally generated files, by said trojan) when downloaded from the offical site.
problem 6. my firewall reports Avast attempting to IP Spoof my network, and attempting to send packages of all my ports to a remote host.
problem 7. Avast Causes 60% of my software to crash. (games, browser, steam, windows update, etc)

*please note ; avast was downloaded from Avast.com and all patches / software updates where downloaded via the update feature*

any one got any suggestions. how to fix these problems?

or can suggest a better None B*** S*** anti-virus that doesn't come packed with.. this horse manure.

Thank you

Sn00pY

Offline Eddy

  • Avast Evangelist
  • Serious Graphoman
  • ***
  • Posts: 15398
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast is Killing my P.C.! help please.
« Reply #1 on: October 21, 2013, 04:45:21 PM »
1)
It is a known bug in the windows security center. Often 1 or 2 reboots solve it. If not, reset the security center.

2)
What is the exact message on the bsod?

3)
Looks like you are using a non trusted and/or crappy malware scanner. What is the name of it?

4)
See 3)

5, 6, 7)
They all can be caused by malware. Please follow the instructions as mentioned here: http://forum.avast.com/index.php?topic=53253.0

Offline Sn00pY

  • Newbie
  • *
  • Posts: 6
Re: Avast is Killing my P.C.! help please.
« Reply #2 on: October 26, 2013, 12:19:32 PM »
hi, sorry for the delay, works been keeping me busy.

2. the BSOD, is an access violation, to read only memory.
3. i use Malwarebytes' Anti-Malware

Offline Arnold72

  • Poster
  • *
  • Posts: 493
  • RIP.Jay "padre" Miner.(May 31, 1932 – June 20, 19
Re: Avast is Killing my P.C.! help please.
« Reply #3 on: October 26, 2013, 12:42:15 PM »
1)
It is a known bug in the windows security center. Often 1 or 2 reboots solve it. If not, reset the security center.

2)
What is the exact message on the bsod?

3)
Looks like you are using a non trusted and/or crappy malware scanner. What is the name of it?

4)
See 3)

5, 6, 7)
They all can be caused by malware. Please follow the instructions as mentioned here: http://forum.avast.com/index.php?topic=53253.0

Im sorry but i disagree with your statement that its a known bug in security center.
If so then everyone would be experiencing this,but not everyone is and that includes me.
Avast Free V9.0.2006.||Comodo Firewall 6.3||Sandboxie.||SUA.||Firefox Web Browser.

doktornotor

  • Guest
Re: Avast is Killing my P.C.! help please.
« Reply #4 on: October 26, 2013, 01:01:01 PM »
Im sorry but i disagree with your statement that its a known bug in security center.
If so then everyone would be experiencing this,but not everyone is and that includes me.
.
You can disagree all you want, a quick Google check tells pretty quickly that this WMI repository thing has been broken from the very first time it's been introduced in XP and never fixed properly, up to and including Windows 8.1. It's simply extremely unreliable and flaky, error prone, extremely easy to corrupt and in general sucks goats nuts and causes completely useless noise from users. Relying on whatever it tells you is extremely foolish.

All that infamous Action Center does there is to run a WMI query like “select * from AntiVirusProduct” on the root/SecurityCenter2 namespace and return OK or not depending on values of productUpToDate, onAccessScanningEnabled etc. that the query returned. Sure like hell, any native diagnostics coming with security products is magnitudes of order more reliable than this.
« Last Edit: October 26, 2013, 01:03:54 PM by doktornotor »

Offline Eddy

  • Avast Evangelist
  • Serious Graphoman
  • ***
  • Posts: 15398
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast is Killing my P.C.! help please.
« Reply #5 on: October 26, 2013, 01:01:51 PM »
Arnold, a bug doesn't mean that everyone experience it. Each system is unique. Different hardware, different software, different settings etc. etc.

Snoopy, let us start with checking unusual/unwanted things.
Please follow these instructions: http://forum.avast.com/index.php?topic=53253.0

Offline Arnold72

  • Poster
  • *
  • Posts: 493
  • RIP.Jay "padre" Miner.(May 31, 1932 – June 20, 19
Re: Avast is Killing my P.C.! help please.
« Reply #6 on: October 26, 2013, 01:12:58 PM »
Sorry but those replies simply are not good enough.
Answer me this...

Avast and other security products have been running with the security center just fine in the past and yet suddenly we are supposed to believe that the security center as if by magic has now suddenly become corrupt.

Is it not the basic job of security companies to ensure that their products can harmonize with basic windows components.
The security center in windows 7 has not changed since its conception and avast has run without issues in this capacity.

And yet now avast 9 does not run with security center for whatever odd reason so where do you think the problem lays.?
Its obvious the new version is to blame and should be corrected forthwith.

Thanks.
Avast Free V9.0.2006.||Comodo Firewall 6.3||Sandboxie.||SUA.||Firefox Web Browser.

doktornotor

  • Guest
Re: Avast is Killing my P.C.! help please.
« Reply #7 on: October 26, 2013, 01:16:28 PM »
Answer me this...
Avast and other security products have been running with the security center just fine in the past and yet suddenly we are supposed to believe that the security center as if by magic has now suddenly become corrupt.

Please. Do the suggested Google research at least. This is the most notorious issue affecting EVERY single security product from EVERY single security vendor out there. Have yet to see a firewall/antivirus/antimalware that did not trigger hundreds and hundreds of similar threads. You claim is completely false even when it comes to avast, just search this forum. This issue existed long long long before 2014 version. And again, absolutely not Avast-products specific, at all. There is even a multitude of third-party tools that attempt to fix the WMI repo to some degree, existing simply since the official MS ways to achieve this often fail.

The issue often occuring on product updates/upgrades is merely a symptom of the sucky implementention/design of the WMI thing. Blatant coding bugs aside, any fixes the vendors do in this area are sort of black magic, merely hoping to make the security/action center shut up already and stop the flood of noise from users that claim that "the AV does not work, Windows tells me that and Windows is always right!".  ::)

Drop this line, goes nowhere.

P.S. If you want to debug the issue and get some grip of what's up here, here's a short howto on querying the WMI namespaces relevant for the security center on this KB article: A security program is still listed in Windows Security Center and in Action Center after the security program is uninstalled.
« Last Edit: October 26, 2013, 01:24:35 PM by doktornotor »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 65811
Re: Avast is Killing my P.C.! help please.
« Reply #8 on: October 26, 2013, 02:02:08 PM »
And yet now avast 9 does not run with security center for whatever odd reason so where do you think the problem lays.?
Its obvious the new version is to blame and should be corrected forthwith.
avast! 2014 is running very well with Windows Action Center for me.
The problem is always on Windows size, the Security or Action Center, and the way it creates/populates its own repositories.
It could happen with any antivirus. Sometimes, booting 2 or 3 times (giving time to Windows fully load) solves the issue.
The best things in life are free.

Offline Eddy

  • Avast Evangelist
  • Serious Graphoman
  • ***
  • Posts: 15398
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast is Killing my P.C.! help please.
« Reply #9 on: October 26, 2013, 02:27:10 PM »
Arnold, 28 january 2010 > READ THIS
If you don't know what you are talking about, it is better not to talk at all.
Now please stop polluting Snoopy's thread so we can try to help him.
« Last Edit: October 26, 2013, 02:29:00 PM by Eddy »

Offline Arnold72

  • Poster
  • *
  • Posts: 493
  • RIP.Jay "padre" Miner.(May 31, 1932 – June 20, 19
Re: Avast is Killing my P.C.! help please.
« Reply #10 on: October 26, 2013, 03:00:50 PM »
As usual this thread has stooped to nonsense personal criticisms with no conclusive suggestions or answers given.
I have stated clear facts and that is all i will say on this matter seeing as nobody wants to give answers but would rather criticize other peoples abilities.

Why is it that avast has worked perfectly well with the security center in previous versions and not with avast 9.?
A clear question which requires a clear answer.
Avast Free V9.0.2006.||Comodo Firewall 6.3||Sandboxie.||SUA.||Firefox Web Browser.

Online CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9114
Re: Avast is Killing my P.C.! help please.
« Reply #11 on: October 26, 2013, 03:19:50 PM »
Why is it that avast has worked perfectly well with the security center in previous versions and not with avast 9.?
A clear question which requires a clear answer.
It hasn't, the issue has been around for ages and has troubled avast over several versions, it has also been discussed many times in many forums of different AV's and the instructions to reset the security centre have been given.

doktornotor

  • Guest
Re: Avast is Killing my P.C.! help please.
« Reply #12 on: October 26, 2013, 03:25:16 PM »
I have stated clear facts

Negative, captain...

and that is all i will say on this matter

Yeah, you clearly are sounding like a stuck scratched record...

seeing as nobody wants to give answers

... and failing to read what's been said by others in addition.

Offline Arnold72

  • Poster
  • *
  • Posts: 493
  • RIP.Jay "padre" Miner.(May 31, 1932 – June 20, 19
Re: Avast is Killing my P.C.! help please.
« Reply #13 on: October 26, 2013, 03:27:36 PM »
Herr doktor.!

Your posts are not helpful.

Again personal criticisms.

Try Again doktor.
Avast Free V9.0.2006.||Comodo Firewall 6.3||Sandboxie.||SUA.||Firefox Web Browser.

doktornotor

  • Guest
Re: Avast is Killing my P.C.! help please.
« Reply #14 on: October 26, 2013, 03:29:07 PM »
Herr doktor.!
Your posts are not helpful.

Stop hijacking other people's thread with similar personal crap, Sir. You got your links and reading wrt WMI. Yet you come again to repeat your claims, failing to provide any substance to them. Enough, please.