Author Topic: Avast Preferences  (Read 5355 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Avast Preferences
« on: October 25, 2013, 12:46:48 AM »
Hi There,
I have updated my iMac to OS X Mavericks and it appears that the latest Avast is not quite compatible with it.

The preferences DO NOT WORK. 

Trying from the Apple Menu top left does not work!

Trying from the GUI clicking on the wrench..DOES NOT WORK!  Makes me wonder what else is not working??

I find the Auto Updates are very unreliable as well, manual seems to work, but Auto Updates are few and far between.



  • Guest
Re: Avast Preferences
« Reply #1 on: October 25, 2013, 06:32:42 AM »
The preferences does work, you just have to add it back to the system preferences pane.

The preference pane in the Incompatible Software folder on the main drive. "/Incompatible Software/"
Double clicking the Avast.prefPane file to open resolves the problem of the preferences pane.

I haven't noticed any other problems with avast aside from the preferences problem.


  • Guest
Re: Avast Preferences
« Reply #2 on: October 25, 2013, 04:25:12 PM »
Well it sort of works!  I did go into the "Incompatible software" FOLDER and double clicked the pref pane thingy.

What it did was tell me that it was already installed do I want to replace it?  Which I did.

END RESULT was that the pref pane opens but that's about all it does.

When I try to click on the lock in order to change a setting NOTHING HAPPENS!!!

So all the incompatible folder pref pane did was allow me to open it but unable to change any settings, so it is still not working!


  • Guest
Re: Avast Preferences
« Reply #3 on: October 26, 2013, 12:14:24 AM »
It seems that 10.8 > 10.9 transition works differently for different people/computers. Anyway, re-install in Maverics with current version should fix it easily.


  • Guest
Re: Avast Preferences
« Reply #4 on: October 26, 2013, 10:10:53 AM »

I've reproduced the crash of the System Preference.

Just after installing Avast! 8.0 you can open Avast! preference and configure the program without any problems.
However, if you will fix the permission of the system disk (I regularly do it), then you can't configure Avast! any more.
It is still possible to open the preference pane of Avast!, but when you click any options, then System Preference will crash.
I installed the very latest version released yesterday (8.0, 40005).

I'm not a programmer, so I don't see which is a cause (Mavericks or Avast!8 ), but there should be a problem.
I just hope this problem will be fixed as soon as possible.

I hope it will help! Thank you!

Edited: removed unnecessary emoticon.
« Last Edit: October 26, 2013, 10:26:36 AM by nobu-ad »


  • Guest
Re: Avast Preferences
« Reply #5 on: October 26, 2013, 03:05:54 PM »
I cannot use preferences from the Avast software options, meaning directly from Avast.  However I can from the Macbook Pro system preferences area.  The lock won't work from Avast but will unlock from system preferences only.  Click on system preferences and click on the Avast icon and there you are.  I'm not sure why it won't work directly from Avast.


  • Guest
Re: Avast Preferences
« Reply #6 on: November 15, 2013, 06:39:44 AM »
Thanks a lot adicerni . It worked for me from the Mac book pro preference area . Was struggling with Maverics mail and the update also did not work for me . Bought airmail and it was also not working because of this issue. You have indeed saved my day . Thanks a ton again