Author Topic: How do you disable the "webrep" overlay?  (Read 4446 times)

0 Members and 1 Guest are viewing this topic.

Zurar

  • Guest
How do you disable the "webrep" overlay?
« on: November 01, 2013, 08:02:14 PM »
Ok, I'm now on Avast! 2014.9.0.2006 and have virtually no problems with the program, the only problem I do have is the annoying "webrep" overlay that's CONSTANTLY in the way (see attached image).  How do I disable this thing?  I don't mind the internet security features, except for the overlay.  The overlay does me absolutely no good and simply gets in the way.  I know how to check the URLs of links myself and can easily determine if they're safe to click on or not myself (providing people with tips on how to stay safe online while surfing is kind of a side-job for me).  Is there any way to disable just the overlay; or do I have to remove the whole plugin for my browser (I'm on firefox, btw).

Erroneus

  • Guest
Re: How do you disable the "webrep" overlay?
« Reply #1 on: November 01, 2013, 09:07:06 PM »
+1, doesn't like the overlay also, because often it sits on top other objects. Would be nice if only the overlay could be turned off.

Zurar

  • Guest
Re: How do you disable the "webrep" overlay?
« Reply #2 on: November 01, 2013, 11:43:23 PM »
Thanks for the support on this Erroneus and MICAH.  The pop-up itself isn't so much the issue as the positioning of it.  Like Erroneus said, it gets in the way.  This should either display in a corner where it's out of the way, or be a toggle so you can turn it off.  The example pic I attached previously was an especially annoying example as even the little icon, before the pop-over image displays, is covering up text.

Edit: Not to mention, I still have the tab open displaying that page with the pop-over, and it's bugged.  The pop-over will NOT disappear, even when I mouse over another link that should trigger it.
« Last Edit: November 01, 2013, 11:45:27 PM by Zurar »

Zurar

  • Guest
Re: How do you disable the "webrep" overlay?
« Reply #3 on: November 04, 2013, 05:12:14 PM »
Well, it looks like the only way to disable the overlays (for now) is to disable the browser plugin entirely.  Not the ideal solution, as it appears this plugin also provides the browser security (at least based off its description).  But honestly; with my knowledge of scam and potentially dangerous sites, and how to avoid them; I'd rather take the slight risk over the major annoyance and reduction in productivity.

cslemmen

  • Guest
Re: How do you disable the "webrep" overlay?
« Reply #4 on: November 07, 2013, 06:28:38 PM »
I was having this same issue on slashdot and it was driving me nuts so I worked up a fix. If you are on Firefox (others?) you can use the following code to make a bookmarklet that will remove the icon but retain the hover behavior:

Code: [Select]
<a href="javascript:(function(){els=document.getElementsByTagName('span');for(var e=0;e<els.length;e++){if((els[e].className=='wrc13 wrc_injected')){els[e].className='wrc_injected';}}})();">avastno</a>
I made a link in my bookmarks toolbar though I'm sure there's a way to write it so it runs for all sites if you want that behavior.

-S

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6699
  • Trust only what you test yourself!
Re: How do you disable the "webrep" overlay?
« Reply #5 on: November 07, 2013, 06:32:11 PM »
This was a discussed during the beta test. The explanation was it had something
to do with one part of code conflicting with another piece of code and couldn't quite
get resolved.  :)
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

joshuachavanne

  • Guest
Re: How do you disable the "webrep" overlay?
« Reply #6 on: January 10, 2014, 11:34:13 PM »
I tried many solutions, and barring turning off the WebRep, I decided to override the css in Firefox itself.  You can do this by finding the classes that show up if you inspect the icons, and setting display: none on them in css.  You add this to the userContent.css file in the 'chrome' directory in your user profile directory, you may need to make the chrome folder if your account doesn't have one.  just add the proper css selectors and override from there.  Does require one to restart Firefox, but its way better than turning off Avast auto heal and stuff.

All the best,
Josh