Author Topic: Avast IS 9 blocking network share, Java applications  (Read 14929 times)

0 Members and 1 Guest are viewing this topic.

SlyFox

  • Guest
Re: Avast IS 9 blocking network share, Java applications
« Reply #15 on: November 27, 2013, 02:18:37 PM »
I am also having this issue, which happens during initialization of the Subsonic service from the agent. I'm running a fresh install of Avast Premier (30-day trial) which includes rules for subsonic-agent.exe and subsonic-service.exe.

I have tried the following:
Set allowable ports on subsonic-service.exe to All for upstream and down.
Set allowable ports on "Java(TM) Platform SE Library" to All for upstream and down.
Set default packet rule on "Java(TM) Platform SE Library" to Allow for all protocols for In/Out.
Set default packet rule on subsonic-service.exe to Allow for all protocols for In/Out (changed back to Auto-decide after it no change was found).
Set subsonic-agent to All connections preset.

I have also attempted to troubleshoot using Wireshark but discovered that Wireshark cannot capture traffic to the loopback (127.0.0.1) on Windows.

Potential Workaround:
I have noticed that, if I start the service with the Avast firewall off, then start the firewall after Subsonic is running, Subsonic will continue to function. My suspicion is that Subsonic is performing some sort of network reachability test on launch and, if the test fails, it doesn't open a listener on its configured port. Obviously, this is not desirable as this requires manual effort any time Subsonic needs to be launched.

Exactly my situation as well. For now I just have the firewall turned off all the time, which is hardly ideal.

Hopefully you have your Windows Firewall turned on, please?