Author Topic: Tips on Using AVAST 9 with Agnitum Outpost  (Read 4306 times)

0 Members and 1 Guest are viewing this topic.

jared19

  • Guest
Tips on Using AVAST 9 with Agnitum Outpost
« on: November 08, 2013, 10:51:02 PM »
This is just a bit of info on how to make the 2 program co-operate.

Apparently, Avast 9 Web Shield changed the way it operate compared to the previous version. After Updating from Avast 8 to 9, ALL my inet facing programs failed miserably to connect, and that includes Avast's own updater.

It seems that Avast Web Shield is redirecting all inet requests to itself. While Avast 8 does the same thing, Avast 9 is more thorough, which I assume is better protection (or not, depending the point of view). Meanwhile, Outpost in "Block Most" mode uses white list on which program can access which port, and that redirection needs to be included in the list.

So, if you're using Avast with Outpost, you need to allow all programs which you allowed to connect to the inet in Outpost to make outbound TCP connection to remote port 12080, or they won't connect to the inet. And you have to explicitly include Avast updater to the list ([Path to Avast Installation]\Setup\instup.exe), allowing it to make that same connection, or you won't be able to update Avast.

Just wish this kind of info is available when updating to Avast 9. Maybe it can be stickied somewhere and/or included to the FAQ.

Hope it helps

Offline dbrisendine

  • Malware Fighter
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1258
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #1 on: November 08, 2013, 11:28:56 PM »
Thanks for the heads up on this as many people have reported a problem with Avast 9 and other firewalls.  In Outpost, did you add a common rule to each Application policy or did you make a global rule?
Win7 x32 Ult. SP1, Brain 2.0 / Win10 x64, Brain2.5
My help is always free but if you would like to help encourage me or show your thanks -----> DONATE

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88167
  • No support PMs thanks
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #2 on: November 09, 2013, 12:06:25 AM »
I have had the Agnitum Outpost firewall (in many versions) for even longer than the nine years of using avast and I haven't done anything special to make Outpost Firewall Pro and avast free work well together.

When installing OFP it detects avast and seeks confirmation that you have it installed, when you confirm that you have it asks you to make exclusions for outpost in avast, I have always said I did that, but never did. On the next screen it says you can choose to use the OFP Web Control, I have always declined (unchecked) this option.

I have never explicitly added a special rule for avast in OFP for outbound TCP connection to remote port 12080 and no problems. The main thing is that the avast processes should almost be detected automatically and rules created and always allow the avast processes.

Of you ever experience a problem, you could always put OFP into auto-learn mode for a while and that should deal with this.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline schmidthouse

  • VIRUS FREE A Long Time
  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 7171
  • When you think you know, Think Again
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #3 on: November 09, 2013, 12:21:41 AM »
+1
Well I can second that!
 As I have also used OPFW Pro with Avast on XP and now Win 8.1 and have not found the situation the OP has described.
I do think Firewalls are tricky programs but Just saying Avast and OPFW have always played well together without added intervention on my systems. :)

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3395
  • Avast shall conquer the whole world
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #4 on: November 09, 2013, 03:10:39 AM »
+2 I have no issue at all with OPFW with Avast 9 on W8 ;) as DvaidR said you don't need OPFW with Web Control because Avast already have web shields, when you install a software always set OPFW to learning mode first for 1 day (24hrs) before you start that way you won't get any confliction after 24hrs OPFW reset it back to Rules Wizards.
« Last Edit: November 09, 2013, 03:17:44 AM by SpeedyPC »
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v23.9.6082 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

jared19

  • Guest
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #5 on: November 09, 2013, 11:07:50 AM »
Thanks for the heads up on this as many people have reported a problem with Avast 9 and other firewalls.  In Outpost, did you add a common rule to each Application policy or did you make a global rule?
In Outpost, I add the rule manually for each applications I think needed to connect to the inet. Yes it's cumbersome, but I like to control which proggie can do what.

For those who doesn't have this problem, I notice that you all seem to use the Pro/paid version of Outpost. Maybe I should have been clear from the start, I'm using the free version of OSS and yes I've disabled parts of it which I think Avast could handle better.

As for the auto-learn mode, I only use it if it's absolutely necessary and can't figure out why a prog can't connect. Even when I did use it, I manually re-tweak the rules later, aiming for the minimum access rights necessary for a prog to work.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88167
  • No support PMs thanks
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #6 on: November 09, 2013, 12:24:26 PM »
If you have Outpost set as Rules Wizard, you still have control as you still get the popups.

So essentially your tip is the control freaks amongst us, I like to be in control, but I don't want to be creating rules for every port used by an application.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline SpeedyPC

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3395
  • Avast shall conquer the whole world
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #7 on: November 09, 2013, 01:33:35 PM »
@jared19 why don't you buy a lifetime licence for Outpost Pro FW instead of using an outer date free version, because Outpost is not planning to release another latest free version any more so you're better off buying a lifetime licence for Pro.
Gigabyte 670 LGA1200 Full ATX MB | Intel Core i9-13900 CPU/LGA 1700 | GeForce Nvidia RTX-4070/12GB | 32GB DDR4 | 2 x 1TB Samsung SSD | W11 Home 64bit | Avast Premium v23.9.6082 | Avast SecureLine VPN | Avast Secure Browser | Avast Driver Updater | Avast BreachGuard | Firefox 64bit | MalwareBytes Premium | Adguard Premium | CCleaner Portable | Macrium Reflect | 7-Zip

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #8 on: November 12, 2013, 03:49:34 PM »
I'm not sure, but seems the 9.0.2008 has corrected some issues with Outpost.
Fixed issue with Outpost FW warning („unsigned“ driver)
http://forum.avast.com/index.php?topic=139606.45
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88167
  • No support PMs thanks
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #9 on: November 12, 2013, 04:15:29 PM »
I'm not sure, but seems the 9.0.2008 has corrected some issues with Outpost.
Fixed issue with Outpost FW warning („unsigned“ driver)
http://forum.avast.com/index.php?topic=139606.45

Unfortunately it doesn't appear to have been a complete success as I got OFP notices on avast loading unsigned kernel mode drivers (on both win7 and win XP Pro), see my post http://forum.avast.com/index.php?topic=139606.msg1018650#msg1018650 and http://forum.avast.com/index.php?topic=139606.msg1018672#msg1018672 on that topic.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67199
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #10 on: November 12, 2013, 05:59:35 PM »
I'm not sure, but seems the 9.0.2008 has corrected some issues with Outpost.
Fixed issue with Outpost FW warning („unsigned“ driver)
http://forum.avast.com/index.php?topic=139606.45

Unfortunately it doesn't appear to have been a complete success as I got OFP notices on avast loading unsigned kernel mode drivers (on both win7 and win XP Pro), see my post http://forum.avast.com/index.php?topic=139606.msg1018650#msg1018650 and http://forum.avast.com/index.php?topic=139606.msg1018672#msg1018672 on that topic.
Thanks David. Hope they take a look on these issues then.
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 88167
  • No support PMs thanks
Re: Tips on Using AVAST 9 with Agnitum Outpost
« Reply #11 on: November 12, 2013, 07:07:28 PM »
I have sent two support packages for my win7 and XP systems. Hopefully they have that and can glean some information from them.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.9.6082 (build 23.9.8494.792) UI 1.0.781/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security