Author Topic: high cpu usage  (Read 2553 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
high cpu usage
« on: November 11, 2013, 12:47:38 AM »
Now moved to avast as my antivirus, but in the first hour or two after booting up the pc, it practically stops as avastSvc.exe takes 98%+ of my CPU usage. Is this usual? Anyone else had similar problems? I did a search on here but couldn't see anything similar.
Running windows  XPHome on a an acer netbook.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37182
Re: high cpu usage
« Reply #1 on: November 11, 2013, 12:50:34 AM »
did you uninstall your previous used AV before installing avast?

General: Uninstalling a third-party antivirus software


  • Guest
Re: high cpu usage
« Reply #2 on: November 11, 2013, 01:45:04 AM »
Also, use CCleaner to remove any left over registry keys, etc.  Use the search function on your computer and put in the search box the name of your old anti-virus, to see anything comes up that needs to be removed before installing Avast.  It only takes one registry key or anything else that may cause Avast not to install properly.  It may take a little more time, but I rather make the time and make sure nothing is showing up from my old anti-virus.

If you have any questions or need help, please feel free to post back.

Thank you for using Avast and have a great evening.


  • Guest
Re: high cpu usage
« Reply #3 on: November 14, 2013, 10:18:00 PM »
OK, it's taken me a while, but I have run the AVG uninstaller, twice, searched for and removed everything with avg in the filename, run ccleaner, run ccleaner to fix the registry,  uninstalled avast and re-installed it.
Still the same! runs ok for a bit then suddenly goes up to 98% cpu usage and everything else stops.

Any other ideas. Doesn't seem to happen on the desktop I loaded it to about the same time.


  • Guest
Re: high cpu usage
« Reply #4 on: November 15, 2013, 04:12:15 AM »
I had a similar problem on my Windows XP SP3.  There would be 100% CPU usage upon Windows start-up.

Here is what you can try:

Workaround 1.  Proceed to Avast -> Settings -> Update.  Scroll down to Details.  Check mark "My Computer is permanently connected to the internet."  Click OK at the bottom.  Re-boot Windows, and verify if you still have the 100% CPU problem.

Workaround 2.  If the above does not work, proceed to Avast -> Settings -> Update.  From under Virus Definitions, click on the drop down box Settings.  Select "Ask when an update is available."  Click OK at the bottom.  This will switch the virus definition update from automated to manual.  This is not an ideal solution, but it should mitigate your 100% CPU problem.


  • Guest
Re: high cpu usage
« Reply #5 on: November 15, 2013, 05:02:18 AM »
To add to the reply above, try clearing your Prefetch folder (including the layout.ini file).
Reboot (it may take awhile as Prefetch has to repopulate itself.