Author Topic: Avast service is off, can't fix.  (Read 13239 times)

0 Members and 1 Guest are viewing this topic.

Offline DreamPhreak

  • Newbie
  • *
  • Posts: 4
Avast service is off, can't fix.
« on: November 20, 2013, 06:58:34 AM »
EDIT (2/26/2014): I keep getting a lot of daily connections to my site from this topic (because of the screenshots loading below which are on my server). That must mean that there are still people from Google coming here looking for an answer to my same problem. I'm back to let you future readers know that I have never found fully-working fix for this problem, just a quick fix that doesn't address the issues. I am now using Avira (and loving it more than Avast), But if you really NEED a fix for this same problem as I had in this topic, I'll save you the trouble of reading through the whole thing:

completely uninstall Avast and then re-install using one of the links from here only: http://forum.avast.com/index.php?topic=140385.msg1023290#msg1023290

Somehow those direct download links (from Avast's own file servers) work really well, as opposed to the ones on CNet.com, which are unreliable and loaded with adware (and it's probably CNet's fault their installer made my Avast program malfunction.)






Program Version: 2014.9.0.2008
Virus Definitions Versions: N/A "Avast service is not running. Failed to update."
Type: Free Antivirus
OS: Windows 7 Ultimate x64 - SP1

Okay, so, for the past week I have been spending countless hours trying to get Avast! to work. I have done every suggestion I could find on the internet, such as going to Control Panel -> Programs and Features -> Change avast and then going to Repair. And also doing full uninstallations like
  • Uninstalling Avast.
  • Using avastclear.exe in Safe Mode.
  • Using Avast! Cleanup Tool 1.3 (By Mark Russinovich) Edit: AKA "Rejzors Uninstall tool".
  • Clearing out the registry using CCleaner
  • And then of course restarting the computer after each step above just to make sure.

But then when I install Avast!, and immediately after it installs and runs, In the main program window is a giant red bar that says "You are unprotected! The avast! service is off", and clicking either "Resolve All" button or "Start" link does nothing at all. And yes I also restarted my computer again after installing.

I can't use the internal updater on the program cause it just gives me the error: "Avast service is not running. Failed to update."

In services.msc: Avast! Antivirus Properties service status is "Stopped". When I try to Start it, I get the error: "Windows could not start the avast! Antivirus service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion".

And all of this I have done multiple times, as I said: For the past week just spending every day doing the same thing over and over, hoping that maybe one of the times will fix it or I might notice something I overlooked, but NOPE, nothing works AT ALL.

While I am waiting for a response here, I am going to see if I can find an earlier version of Avast! like 8.0 or something and hope that it at least works.
« Last Edit: February 26, 2014, 07:30:16 AM by DreamPhreak »

Offline acceltech

  • Newbie
  • *
  • Posts: 12
Re: Avast service is off, can't fix.
« Reply #1 on: November 20, 2013, 08:01:15 AM »
Did you check if your computer have any existing AV before installing Avast?

Offline DreamPhreak

  • Newbie
  • *
  • Posts: 4
Re: Avast service is off, can't fix.
« Reply #2 on: November 20, 2013, 09:56:26 AM »
Yes, "Malwarebytes Anti-Malware Free" which I had forgotten I installed a long time ago, I uninstalled that and it had not been running previously.

Offline marcosgildavid

  • Newbie
  • *
  • Posts: 3
Re: Avast service is off, can't fix.
« Reply #3 on: November 20, 2013, 02:23:35 PM »
I'm having the same exact problem.

Versions are exactly the same except I'm using Windows 7 SP1 32bits.

I can see the Avast service starts but a few seconds later ir crashes.

Is anyone else having these issues?
I need to sort this out ASAP or I'll have to install another AV. I can't browse the web without an AV. :(

Offline Nigel888

  • Newbie
  • *
  • Posts: 1
Re: Avast service is off, can't fix.
« Reply #4 on: November 20, 2013, 03:10:26 PM »
 >:(

I have exactly the same error. Running Win 7

I uninstalled AVG and rebooted

I have Emsisoft free installed for one off checks.

When I go to uninstall it fails saying no network connection.

________________________

Restarted in safe mode with networking and re-ran the installer - scan now working in safe mode but login/add device does not.

Rebooted in normal mode ....

Installation finished and a scan started.

Adding computer failed ... registered ... adding worked.

Half a day wasted ... I do hope this is as good as all the reviewers say.




Offline marcosgildavid

  • Newbie
  • *
  • Posts: 3
Re: Avast service is off, can't fix.
« Reply #5 on: November 20, 2013, 03:42:56 PM »
Just checked the logs, it seems the AvastSVc.exe service is crashing with this error:


Unhandled exception: Address=697f4fb8 Code=c0000005


Any help?

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1255
Re: Avast service is off, can't fix.
« Reply #6 on: November 20, 2013, 03:55:53 PM »
1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition

Note : You need to be ONLINE during the install (sometimes online installer works whereas offline doesn't)

http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #4]
3. Uninstall in safe mode using Avastclear.
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
5. Install the version you downloaded.
6. Reboot.
ReplyQuoteNotify
Windows 7 Home Premium 64-bit • Avast Internet Security 2015 • MBAM Premium (latest) • Google Chrome • CCleaner •

Offline marcosgildavid

  • Newbie
  • *
  • Posts: 3
Re: Avast service is off, can't fix.
« Reply #7 on: November 20, 2013, 04:04:25 PM »
I already did that yesterday!
Complete uninstall them a fresh install.
It worked fine until I rebooted the pc.

The only thing I noticied different were a couple of windows updates.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1255
Re: Avast service is off, can't fix.
« Reply #8 on: November 20, 2013, 04:13:27 PM »
I already did that yesterday!
Complete uninstall them a fresh install.
It worked fine until I rebooted the pc.

The only thing I noticied different were a couple of windows updates.

Are you sure you ran the ONLINE installer? This is a different installer than the normal one...
Windows 7 Home Premium 64-bit • Avast Internet Security 2015 • MBAM Premium (latest) • Google Chrome • CCleaner •

Offline DreamPhreak

  • Newbie
  • *
  • Posts: 4
Re: Avast service is off, can't fix.
« Reply #9 on: November 20, 2013, 07:27:21 PM »
1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition

Note : You need to be ONLINE during the install (sometimes online installer works whereas offline doesn't)

http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #4]
3. Uninstall in safe mode using Avastclear.
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
5. Install the version you downloaded.
6. Reboot.
ReplyQuoteNotify


I had already done that too. And yes it was both the regular "avira_free_antivirus_en.exe" and the online one, I can see the "avast_free_antivirus_setup_online" file-name that I have downloaded multiple times.

I have also used "Rejzors Uninstall Utility", that was #3 in the first post as "3. Using Avast! Cleanup Tool 1.3".
« Last Edit: November 20, 2013, 07:29:06 PM by DreamPhreak »

Offline DreamPhreak

  • Newbie
  • *
  • Posts: 4
Re: Avast service is off, can't fix.
« Reply #10 on: November 20, 2013, 07:49:55 PM »
Wait a second... Alikhan, was there anything different about those downloads besides it being online? For some reason, after I downloaded yours specifically, now it works:

http://dreamphreak.com/i/73250.png

I already had downloaded the online version multiple times before, and the other offline version multiple times before too (but deleted them in frustration). But for some reason, just following your steps despite being the same thing I had already done worked! how?



*Edit: Removed direct loading of the screenshot because of too many access requests going to my server. It's still there, but you have to manually open it if you want to see it.
« Last Edit: February 26, 2014, 07:32:06 AM by DreamPhreak »

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1255
Re: Avast service is off, can't fix.
« Reply #11 on: November 20, 2013, 09:32:24 PM »
Wait a second... Alikhan, was there anything different about those downloads besides it being online? For some reason, after I downloaded yours specifically, now it works:



I already had downloaded the online version multiple times before, and the other offline version multiple times before too (but deleted them in frustration). But for some reason, just following your steps despite being the same thing I had already done worked! how?

There seems to be a bug with the offline installer (or an incomplete download).  To answer your question, I'd need to know where you downloaded your previous online installers from... perhaps they were corrupt too...

If you could read this post and like attach the broken installer it would be of a great help..

Drake127 (avast! team) posted this:

"I have also seen this issue mentioned more than once but we still didn't identify the cause. There are many reason why you wouldn't extract htmlayout.dll. I would be inclined to blame it on incomplete download but it's also possible that somebody uploaded wrong SFX to our hosting partners. Do I understand correctly that once downloaded, that exact installer either always works or is always broken?"

http://forum.avast.com/index.php?topic=139553.0

« Last Edit: November 20, 2013, 09:36:44 PM by Alikhan »
Windows 7 Home Premium 64-bit • Avast Internet Security 2015 • MBAM Premium (latest) • Google Chrome • CCleaner •