Author Topic: High cpu usage instup.exe (avast antivirus installer)  (Read 13906 times)

0 Members and 2 Guests are viewing this topic.

Offline exodius

  • Newbie
  • *
  • Posts: 17
High cpu usage instup.exe (avast antivirus installer)
« on: November 24, 2013, 02:35:46 AM »
hi avast,
instup.exe takes more cpu usage, how to solve this problem? I use avast IS v2014.9.0.2008 in my windows 7 sp1 enterprise x86. thanks in advance.
screenshot on attach.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 72626
  • No support PMs thanks
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #1 on: November 24, 2013, 01:46:51 PM »
That should only be there whilst it checks for updates (commonly VPS update) and actions the update if present - once complete this process should close.

On my system I have to be reasonably quick to do a screen capture as it isn't there too long.

When is this happening, I suspect soon after boot ?
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.4.2227 R4 beta1/ Outpost Firewall Pro9.1/ Firefox 40.0.3, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.8/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline exodius

  • Newbie
  • *
  • Posts: 17
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #2 on: November 26, 2013, 04:49:22 PM »
Thanks for the info, problem solved. :)

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 72626
  • No support PMs thanks
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #3 on: November 26, 2013, 06:18:15 PM »
You're welcome.

What did you do to resolve it (it may help others) ?
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.4.2227 R4 beta1/ Outpost Firewall Pro9.1/ Firefox 40.0.3, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.1.8/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline wizzlbang

  • Jr. Member
  • **
  • Posts: 68
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #4 on: November 30, 2013, 10:58:57 AM »
I've run into the same problem, instup.exe just lingers and eats up a lot of CPU and slowing things down pretty badly. I've tried rebooting, but it's there every time I boot. I can't get it to close, either, and it wont go away on its own.
« Last Edit: November 30, 2013, 11:06:30 AM by wizzlbang »

Offline drake127

  • Avast team
  • Sr. Member
  • *
  • Posts: 257
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #5 on: November 30, 2013, 11:09:32 AM »
At least one case of indecent eating will be fixed in next release. If you want to make sure it's the issue you experience, send me a process dump when it eats. ;)

Please note that eating CPU is expected during program and VPS update when it's decompressing downloaded packages.
ASUS P8C WS, Intel Xeon E3-1245V2, 16 GB ECC RAM, Samsung 850 Pro 256 GB, Windows 8.1 Pro

Offline wizzlbang

  • Jr. Member
  • **
  • Posts: 68
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #6 on: November 30, 2013, 11:19:25 AM »
The problem is it wont go away, though. It seems to get stuck on whatever stage it's on and starts heating up my laptop.

Offline drake127

  • Avast team
  • Sr. Member
  • *
  • Posts: 257
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #7 on: November 30, 2013, 11:28:49 AM »
The problem is it wont go away, though. It seems to get stuck on whatever stage it's on and starts heating up my laptop.
It will go away after few minutes. If you wish to "fix" it, disable self-defense and delete file C:\ProgramData\AVAST Software\Persistent Data\Avast\Logs\Update.log.
ASUS P8C WS, Intel Xeon E3-1245V2, 16 GB ECC RAM, Samsung 850 Pro 256 GB, Windows 8.1 Pro

Offline kkito

  • Newbie
  • *
  • Posts: 1
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #8 on: February 17, 2014, 06:44:52 AM »
Hi! I have the same problem: instup.exe uses up to 98% cpu, and it's just impossible to do something else on my computer. It's been, like, two hours, and it won't go away, so... can I do something to fix it?  :-[

crofty59

  • Guest
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #9 on: February 17, 2014, 09:45:24 AM »
I also had a problem with instup.exe  using around 50% cpu, even after updating vps.
Waited a while approx 10 minutes still there, so rebooted computer back to normal, after reboot.

Cheers

Offline banzai_beagle

  • Newbie
  • *
  • Posts: 3
Re: High cpu usage instup.exe (avast antivirus installer)
« Reply #10 on: February 26, 2014, 03:57:13 PM »
Ok, I have the same problem, instup.exe running constantly, just started today.

I do not have the folder C:\ProgramData\AVAST Software\Persistent Data on my computer so cannot delete the log file after turning off self defense.

I cannot stop instup.exe in Task Manager.  I cannot remove Avast in Control Panel because when I try a popup says the installer is already running.

Avast has hijacked my computer.  It is acting exactly like a virus. 

I tried restoring my computer to a week ago with no effect.  Next step is to restage my computer and NOT USE AVAST! 

If you guys did this, please fix it.

If you guys did not do this, somebody has hijacked your program on my computer and you have a bigger problem.