Author Topic: Avast 2014 and Visual studio debugging IIS  (Read 4792 times)

0 Members and 1 Guest are viewing this topic.

Offline uname193487

  • Newbie
  • *
  • Posts: 3
Avast 2014 and Visual studio debugging IIS
« on: October 31, 2013, 01:44:41 PM »
Since the 2014 update i've been unable to debug my asp.net applications whilst avast is running.
The only way i remove the 'Unable to start debugging on the web server. The underlying connection was closed: An unexpected error occurred on a receive.' message is to disable all shields.
Prior to this update everything was working fine and although I remember this was an issue before (earlier versions of avast) I obviously found the settings to get around this without disabling the entire thing.  This implies that something about my settings was changed by the new install which I really don't understand why.

I simply want to be able to use visual studio and avast at the same time.
Has anyone else had this problem, and if so have you found a solution?
« Last Edit: November 06, 2013, 05:02:07 PM by uname193487 »

Offline dj1.nc

  • Newbie
  • *
  • Posts: 8
Re: Avast 2014 and Visual studio debugging IIS
« Reply #1 on: November 03, 2013, 12:54:59 AM »
A similar problem happens when trying to debug a WinForms app using Visual Studio 2012 and Avast 9.0.2007.  Avast alerts you that the program (your .exe that's being run in the debugger) is a virus.

I was running Avast 7 and held off on version 8, so I tried  9.  I looked everywhere in version 9's settings but couldn't find anything that would help.  No way I'm going to try and muck with "exclusions" and add an entry for every program I write.

So, I've removed Avast 9 and gone back to 7.

Offline uname193487

  • Newbie
  • *
  • Posts: 3
Re: Avast 2014 and Visual studio debugging IIS
« Reply #2 on: November 04, 2013, 11:04:50 AM »
Thanks for the info dj1.nc
Seems they are determined to make Avast unusable for developers.
I'm trying to find an AIS v8 installer and then going back to Commodo or AVG in 3 months after my current subscription.

Offline uname193487

  • Newbie
  • *
  • Posts: 3
Re: Avast 2014 and Visual studio debugging IIS
« Reply #3 on: November 06, 2013, 05:00:15 PM »
Got the following from Avast support (eventually).

*********************************************************
Please open your avast! and then follow these steps:

Avast! settings -> Troubleshooting -> Redirect Settings

under WEB panel in field ‘Ignored addresses:’ add: localhost

then

Settings -> Tool -> Firewall -> Customize -> Policies -> System Rules-> Allow Windows file and printer sharing check enabled

then

Settings -> Tool -> Firewall -> Customize -> Policies -> System Rules-> Allow rdc check enabled

then

Settings -> Tool -> Firewall -> Customize -> Policies -> Packet Rules-> Enable windows Networking in and out
*********************************************************
After a reboot this allowed the VS IIS debug process to connect.

As for winforms apps, the only thing i could do was exclude my build folder parent folder (most of my dev lives under this folder so it's mostly covered).  Although this does mean you could be excluding a significant portion of you hard drive!

Still not happy with the interface, but at least I can continue using it (but still not sure about extending the license).

Offline dj1.nc

  • Newbie
  • *
  • Posts: 8
Re: Avast 2014 and Visual studio debugging IIS
« Reply #4 on: November 09, 2013, 06:19:30 AM »
Update:  I saw where turning off the setting "DeepScreen" would likely help with this because it's purpose is to interogate those apps (.exe and I'm guessing your IIS .Net .dll's).  I was pretty sure I had turned that off the 1st time I tried version 9 (2014), but I removed version 7 and tried 9 again, with that turned off.

That setting is in the main settings screen under the "Avast" category.  I also turned off "Reputation services" right above that setting.

This solved it for me with Visual Studio and standard WinForms apps.  I usually do IIS asp.net apps but I'm on a detour right now with this WinForms app.  I say that because if it works for me running the WinForms .exe app in debug mode, it'll probably work for you with IIS.

Give it a try.  I've rebooted several times and Avast has updated definitions several times, and it's still working fine with Visual STudio now.

Offline dj1.nc

  • Newbie
  • *
  • Posts: 8
Re: Avast 2014 and Visual studio debugging IIS
« Reply #5 on: December 01, 2013, 06:44:33 AM »
Looks like Avast has broken this again.  I have not changed anything on my side whatsoever, but today Avast (2014 build 2007) started not letting me compile in Visual Sudio 2012.  I verified DeepScreen was still off.  I let Avast update to build 2008 and rebooted.  Still blocking the compile with the "Evo (susp)" message.

It was good for a while, but I guess I'll have to uninstall Avast finally and go to another software.  It's clear from the answers they give in these forums that they have no idea about developers using Visual Studio.