Author Topic: Avast Web Shield and CCleaner  (Read 9554 times)

0 Members and 1 Guest are viewing this topic.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85124
  • No support PMs thanks
Re: Avast Web Shield and CCleaner
« Reply #15 on: December 20, 2013, 01:17:44 PM »
Again we can see great "help" from Evangelists.
If you don't have Pale Moon,Opera Presto or Opera Blink installed please ignore this topic.

The problem being the topic title mentions nothing about Pale Moon, if that is the issue with ccleaner. I find hard to understand why this ccleaner interaction would be limited to Pale Moon and Opera and not other browsers as well.

That said why would you have ccleaner clean avast files, have you tried actually unchecking those options in ccleaner and see if those browsers have a problem.

The only web shield related file in the _avast_ folder is the Webshlock.txt this is the Web Shield Lock txt file in use for files locked whilst they are in the temp folder and being scanned.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.5.2470 (build 21.5.6354.675) UI 1.0.646/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline abruptum

  • Super Poster
  • ***
  • Posts: 2269
Re: Avast Web Shield and CCleaner
« Reply #16 on: December 20, 2013, 01:44:43 PM »
Please,check first post again.
I found temporary fix.
In CCleaner under System I unchecked Temporary Files and Web Shield is working with Pale Moon,Opera Presto and Opera Dev. again.
With this version of Avast a new file important for Web Shield is introduced and when it is deleted by CCleaner or probably other cleaners,
it is not recreated until reboot.
Don't know why Firefox and IE11 are not affected.
I don't use Chrome,but it looks like it is also not affected.
Developers,please fix this.

Offline abruptum

  • Super Poster
  • ***
  • Posts: 2269
Re: Avast Web Shield and CCleaner
« Reply #17 on: December 20, 2013, 07:34:17 PM »
Except this problem with CCleaner and "alternative" browsers,Web Shield is working great.
Browsing is faster.Windows Firewall outbound rules are working.Also,unlike before Web Shield is working
with SafeIP (proxy).

Offline lukor

  • Avast team
  • Super Poster
  • *
  • Posts: 1881
    • AVAST Software
Re: Avast Web Shield and CCleaner
« Reply #18 on: December 21, 2013, 09:31:23 AM »
Hi guys, this is caused by the fact that ccleaner deletes the temp folder (_avast_) with which avast is operating.

We made changes again to prevent this by locking a file webshlock.txt on the temp folder. This change is included with the latest webshield patch distributed by emergency update.

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Avast Web Shield and CCleaner
« Reply #19 on: December 21, 2013, 10:04:06 AM »
We made changes again to prevent this by locking a file webshlock.txt on the temp folder. This change is included with the latest webshield patch distributed by emergency update.

What emergency update?.  I haven't seen anything to suggest it has happened here. I am running 2014.9.0.2011. How can I tell whether that fix has been applied here?

Please don't tell me I'm going to have to do a complete uninstall/reinstall again. From memory I've done that twice already with this version.
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11113
  • No support PM's thanks
Re: Avast Web Shield and CCleaner
« Reply #20 on: December 21, 2013, 10:17:25 AM »
We made changes again to prevent this by locking a file webshlock.txt on the temp folder. This change is included with the latest webshield patch distributed by emergency update.

What emergency update?.  I haven't seen anything to suggest it has happened here. I am running 2014.9.0.2011. How can I tell whether that fix has been applied here?

Please don't tell me I'm going to have to do a complete uninstall/reinstall again. From memory I've done that twice already with this version.
You don't have to uninstall anything, the emergency update process will fix the problem for you automatically http://forum.avast.com/index.php?topic=143211.0

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Avast Web Shield and CCleaner
« Reply #21 on: December 21, 2013, 10:36:15 AM »
... the emergency update process will fix the problem for you automatically http://forum.avast.com/index.php?topic=143211.0

Craig, thanks for the link, although I find the last few posts in it a bit confusing.
OK, I have the files mentioned but my question still remains. Has the patch actually been applied. Do I have to go through the procedure of stopping the web shield, rebooting etc, or does the fact that the two files are there indicate it is all done.

Is there not a log entry somewhere that shows the application of the patch and indicates that it was successful? Should there not have been some on screen notice or popup that my Avast program had been updated?.

If for any reason at some stage in the next few days I have to reinstall again from the 2014.9.0.2011 file I downloaded several days ago, which obviously doesn't have the patch, will the patch be again automatically applied, or is that a once only emupdate.

If I need or choose to do a repair, will that result in the patch not being present?.

Will I have to download the install file again to get a current patched one, and does it have a different identification to the previous one?. 
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline abruptum

  • Super Poster
  • ***
  • Posts: 2269
Re: Avast Web Shield and CCleaner
« Reply #22 on: December 21, 2013, 11:22:28 AM »
I've received Web Shield patch and this problem is solved.
Thanks.