Author Topic: I can't use virtual wifi with 2014 IS  (Read 4316 times)

0 Members and 1 Guest are viewing this topic.

M1628393554

  • Guest
I can't use virtual wifi with 2014 IS
« on: October 20, 2013, 07:38:48 AM »
My English is poor, but I will try. :)
I can't establish virtual wifi for my mobile phone with 2014 IS even if I choose Internet Connection Sharing (ICS) mode . I think it's a bug of firewall because the problem didn't happen in avast 8. Could you help me? Thank you!

seeker15

  • Guest
Re: I can't use virtual wifi with 2014 IS
« Reply #1 on: December 20, 2013, 08:55:00 PM »
I know I got the warning that this topic is at least 20 days old. But I preferred posting here itself when I have the same issue.

This is definitely firewall's problem. Disabling it, let us connect mobile and other devices to the hotspot to share the internet.

This is what happens: I create a wifi hotspot and try to establish connection from the external device such as mobile.
The hotspot is found, tries to connect but gets stuck at 'obtaining IP address'

Disable FIREWALL and it gets connected instantly and the internet is shared. Keep the FW disable and you can browse the internet.

BUT if you enable it again (with the device still connected via wifi), the browsing stops.

How do we solve this? Avast team or Anyone with AIS and using ICS, please help!  :-\
Thanks. I did not try this with 8 so cannot confirm if that works and I don't have to, right ?

Quick Note: It doesn't matter if we set FW in Private/Public High Risk Zone. It just doesn't work!

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40604
  • Dragons by Sasha
    • Malware fixes
Re: I can't use virtual wifi with 2014 IS
« Reply #2 on: December 20, 2013, 09:41:29 PM »
Go to tools > firewall > policies
Select Internet connection sharing mode


seeker15

  • Guest
Re: I can't use virtual wifi with 2014 IS
« Reply #3 on: December 21, 2013, 05:32:55 AM »
Hi, essexboy, thank you for the awesome tip. I never knew there was something like that! Anyway, enabling that solves the obtaining IP address problem. The device gets connected now.

However, please note that I set my FW to Public/High Risk Zone because I don't like unsolicited incoming connection. Then I figured out that this mode is also blocking the device from accessing the shared internet. If, however, I set the FW to Private Zone, then I can access the internet.

How do I keep the FW in public zone for better safety and yet successfully access the shared internet of my PC with my device?
The public mode is blocking the incoming request from the device as shown in the firewall log (screenshot attached).

Thanks

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40604
  • Dragons by Sasha
    • Malware fixes
Re: I can't use virtual wifi with 2014 IS
« Reply #4 on: December 21, 2013, 12:19:54 PM »
Public is designed to be very restrictive as it is intended for when you use a public Wi-Fi access point and your computer would be liable to attack
If your router is properly secured then private is a secure solution

seeker15

  • Guest
Re: I can't use virtual wifi with 2014 IS
« Reply #5 on: December 21, 2013, 02:50:09 PM »
Yes, but here, I am using my own PC as the hotspot and trying to give the device access to its internet connection using encrypted wifi connection (as I understand by WPA2 PSK while creating the hotspot). So, this looks to me as if I am giving explicit consent to connect while at the same time shielding my PC from external intrusion. This is too technical for me to explain.

I am using USB data card/dongle (mobile broadband) to access the internet. I don't understand what is router security so can't say. Anyway, the Data Card comes with application that have software feature that can turn your PC into virtual wifi hotspot. It works with that. But I need to update that software to use the functionality as the default that came, don't have the feature incorporated then. So, I am using mhotspot to do the thing. I remember using with AVG Internet Security back then, and had no problem. This is the first time I am using with AIS 2014. Maybe avast is too hard while in public mode or there is some problem I don't know. So, I'd like a workaround other than using the private mode because I see public mode blocking many unnecessary connection, which I think is a good thing over the more intrusive web today!