Poll

Have you experienced download problems with WebShield? Did it get any better after this fix.

No apparent download issues, before or after.
43 (39.4%)
I do have some issues, running XP or Vista, no change after the fix.
3 (2.8%)
I do have some issues, running Windows 7 or 8, no change after the fix.
39 (35.8%)
I had some issues, running Windows 7 or 8, issues are gone after the fix.
12 (11%)
I do have some issues, don't know if I have the fix or not.
12 (11%)

Total Members Voted: 0

Author Topic: Fix for WebShield download issues  (Read 116355 times)

0 Members and 1 Guest are viewing this topic.

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #120 on: January 23, 2014, 10:58:23 PM »
Any new updates? Still having to disable web shield whenever I download a file, doesn't matter the size - ie: just installed an Adobe Flash Player update that was a mere 1 mb. It would not download unless Web Shield was disabled.

I am also still unable to view YouTube videos unless Web Shield's disabled (freezes within the first few seconds).

Everything works perfectly when Web Shield is disabled.

I've been patient, but I'm starting to think these issues are borderline irresponsible. It's approaching a month now and these issues are an inconvenience on a daily basis, multiple times a day. I've been using Avast since 2009, and have never encountered a problem as browser-breaking as this one until this 2014 edition.
« Last Edit: January 23, 2014, 11:01:37 PM by lucern »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #121 on: January 23, 2014, 11:01:06 PM »
Are you sure you are running Avast! 2014 9.0.2013?

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #122 on: January 23, 2014, 11:02:08 PM »
Yes, I have checked for the respective files, and have the latest versions.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #123 on: January 23, 2014, 11:02:47 PM »
Which files? Can you post a screenshot of the version info of aswstm.sys?

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #124 on: January 23, 2014, 11:12:49 PM »
I am using Avast version 2014.9.0.2013
aswstm.sys is version 9.0.2013.292

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #125 on: January 23, 2014, 11:26:50 PM »
 :'(
Hmm, so you are indeed running the latest version. So, no, there hasn't been any updates since yesterday when 2013 was released. We were so far under the impression that the problems were fixed. What is your OS version?

Could you, please, switch to the proxy?

Webshield.ini

add the following two lines;
[General]
UseStreamFilter=0

- restart after the edit, or at least restart the "avast! antivirus" service
- edit the ini files with notepad running as administrator

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #126 on: January 23, 2014, 11:44:30 PM »
Strange, I've been testing some YouTube videos, and now and sometime they play, and sometimes they freeze, which is an improvement. Crossing my fingers the problem will resolve itself over the next few days.

I also test downloaded another file - a larger one, 69.3 mb from the Blender site (http://www.blender.org/).
Downloading with Web Shield on - it downloads, but Windows says the file is corrupt.
Downloading with Web Shield off - no problems.

If I switch to the proxy, will I need to manually turn it off for future Avast version updates?

Thanks for your support.

Edit: My OS is Windows 7 Professional.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #127 on: January 23, 2014, 11:52:58 PM »

Lucern,
this is something definitely new, not a known bug to us.

Could you harvest some logs for us?
To do that, please create StreamFilter.ini in the avast! program data folder with the following content:

[Common]
FileLogLevel=0
RecordInput=1
RecordOutput=1

-restart the shield afterwards
-you might need to edit the file with notepad running under administrator, otherwise self-defense will prevent you from editing it.
-after the problem appears, could you
   -stop the shield
   -send us the C:\Programdata\Avast Software\Avast\Log folder
   -send us the C:\Programdata\Avast Software\Avast\nsf folder

Thanks. Lukas.

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #128 on: January 24, 2014, 12:05:29 AM »
I remember reading in earlier pages of this thread other users describing the same bug - downloads would hang at 99%. If they finish (sometimes they will simply time out), they are corrupt. I've been experiencing the same issue since the beginning of the installation of the 2014 version of Avast in December.

I did as you said, added the lines to the StreamFilter.ini file and recreated the problem - but the Log and nsf folders were not created, so no logs were created. Is there another step I need to do?

Edit: I also restarted the Web Shield after making the edits to the StreamFilter.ini file before recreating the problem, and stopped it afterward.
« Last Edit: January 24, 2014, 12:13:29 AM by lucern »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #129 on: January 24, 2014, 12:19:07 AM »
If you could not find the log folder, you are probably looking into a wrong place. The log folder is always there.


C:\Programdata\Avast Software\Avast\Log

C:\Programdata\Avast Software\Avast\Nsf


Of course, you must be running streamfilter, you can verify that by checking if aswstm driver is running, such as:


SC QUERY aswstm


You should also stop the webshield after you have re-created the problem - so that the logs gets written to the disk, but the files (with zero length though) should be visible on the disk as soon as the shield starts.


lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #130 on: January 24, 2014, 12:23:19 AM »
I've attached a screenshot of my Avast folder - is this not the correct directory?

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #131 on: January 24, 2014, 12:24:29 AM »
Yes, incorrect one.


Please you the one I've mentioned before.

lord ami

  • Guest
Re: Fix for WebShield download issues
« Reply #132 on: January 24, 2014, 12:28:26 AM »
Go to your Windows partition and write "programdata" manually, as:

lucern

  • Guest
Re: Fix for WebShield download issues
« Reply #133 on: January 24, 2014, 12:37:37 AM »
Thanks for the tip, Lord Ami. It was a hidden folder, and selecting the option to show all folders displayed it.

I've attached the StreamFiler.log file from the log folder. The forum will not let me attach files from the nsf folder. I tried to zip the entire folders but the forum will also not let me attach zip files.
Let me know if I did this right or not.

Edit: Added the StreamFilter.log file.
« Last Edit: January 24, 2014, 12:40:16 AM by lucern »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Fix for WebShield download issues
« Reply #134 on: January 24, 2014, 12:44:21 AM »
Lucern,
we would need the complete nsf folder contents. You can upload the zip file to your anonymous FTP server here:


ftp.avast.com/incoming


Or mail it to my email address (its rypacek {at} avast {dot} com)
Thanks.L.

You can also use this public file depot:
http://www.uschovna.cz/en/poslat-zasilku





« Last Edit: January 24, 2014, 12:46:17 AM by lukor »