Poll

Have you experienced download problems with WebShield? Did it get any better after this fix.

No apparent download issues, before or after.
43 (39.4%)
I do have some issues, running XP or Vista, no change after the fix.
3 (2.8%)
I do have some issues, running Windows 7 or 8, no change after the fix.
39 (35.8%)
I had some issues, running Windows 7 or 8, issues are gone after the fix.
12 (11%)
I do have some issues, don't know if I have the fix or not.
12 (11%)

Total Members Voted: 0

Author Topic: Fix for WebShield download issues  (Read 86441 times)

0 Members and 1 Guest are viewing this topic.

Offline bikemanAMD

  • Sr. Member
  • ****
  • Posts: 343
Re: Fix for WebShield download issues
« Reply #60 on: January 01, 2014, 10:05:46 PM »
Still Problems accessing Router GUI with Avast installed, tried turning off webshield, tried setting for the proxy version, may do a clean install of it one more time, and try again...

Could be Router issue as well, at&t gateway Netgear 7550N

on Windows 8.1 Pro 64bit

Windows 8.1 Pro with Media Center- AMD A6-3620 APU/Radeon 6530D, 8gb DDR3 ram, 1tb hard drive-Avast 9.0.2018  Windows 8.1  Pro 64bit, Windows 8 Firewall
Secondary Laptop: XP 32bit, 60gb hard drive-Avast 9.0.2018
Acer Netop W7 (32bit) 320gb hard drive, Avast 9.0.2018

Offline olddog

  • Poster
  • *
  • Posts: 566
Re: Fix for WebShield download issues
« Reply #61 on: January 01, 2014, 11:42:50 PM »
Could be Router issue as well, at&t gateway Netgear 7550N

Disable Browser AOS ext/add ons
Temporarily turn off all shields (right click Avast task bar icon, select avast shields control, turn off for 10 minutes).
Start browser
Try to access router - if you can then the problem is NOT the router.
Right click  Avast task bar icon and turn shields back on.
3.4Ghz Intel i7, 8Gb Ram, GeForce GTX560, Win 7 Pro 64 bit, Dual 1920x1080 monitors, Avast 2014, Firefox 26, Malwarebytes Pro, Paragon 14

Offline bikemanAMD

  • Sr. Member
  • ****
  • Posts: 343
Re: Fix for WebShield download issues
« Reply #62 on: January 01, 2014, 11:50:46 PM »
Currently still no access after doing the above steps--eventually comes up with page cannot be displayed, am able to Ping the Router though, so some reason just can't get the GUI up, I think will restart it later on, and I think will be fine after that I hope.

3rd time it's done this month
Windows 8.1 Pro with Media Center- AMD A6-3620 APU/Radeon 6530D, 8gb DDR3 ram, 1tb hard drive-Avast 9.0.2018  Windows 8.1  Pro 64bit, Windows 8 Firewall
Secondary Laptop: XP 32bit, 60gb hard drive-Avast 9.0.2018
Acer Netop W7 (32bit) 320gb hard drive, Avast 9.0.2018

Offline opollo

  • Newbie
  • *
  • Posts: 4
Re: Fix for WebShield download issues
« Reply #63 on: January 02, 2014, 10:30:15 AM »
I've recently been having problems with the web shield, when its switched on I cannot connect to the internet, switch it off it works.
What is going on, I've never in many a year when using avast had any problems with it until now.

Join the club, annoying, isn't it!! You'd think they'd fix it in an 'automatic update', but so far, nothing. Here's the thing,  I'm not a computer geek, I don't want to trial a 'patch', I just want the product, Avast,to work. If you're offering a 'patch', why can't you incorporate it in a normal update??


And your operating system versions are, guys? Thanks.

Mine is Windows Home 7... thank you. Avast is 2014.9.0.2011

My OS is win7 32bit!
« Last Edit: January 04, 2014, 12:19:32 AM by opollo »

Offline batagy

  • Newbie
  • *
  • Posts: 1
Re: Fix for WebShield download issues
« Reply #64 on: January 02, 2014, 09:07:53 PM »
Hi!

Actually for me this latest 2014.9.0.2011 build introduces a problem, probably Webshield related.
My OS is Windows 8.0 Pro N, 64bit.

Since this latest Avast upgrade I have problems to login to my router webgui at http://192.168.0.1/ (Router is TP-Link WR842ND with Gargoyle  1.5.11 firmware.

Issue: in Firefox 26.0, if I go to http://192.168.0.1 address, then Firefox puts this message:
Quote
Server: httpd_gargoyle/1.0 14mar2008
Date: Mon, 30 Dec 2013 20:48:38 GMT
Expires: Mon, 30 Dec 2013 20:48:38 GMT
HTTP/1.1 301 Moved Permanently
Location: login.sh
HTTP/1.0 302 Found

If I directly enter the webGUI addresses, like "http://192.168.0.1/overview.sh", then it comes up in Firefox and I can browse in menu. if I click Logout, then same error comes up. If I enter "http://192.168.0.1/login.sh", then page also comes up, but after filling the password and sending, error raises.

In Internet Explorer 10.0, there is no such error message, however in IE the logout doesn't work either, the browser remains logged in.

It seems some cookie expiration problem, but it's definitely related to Avast Free Antivirus, because if I disable Avast then issue is perfectly gone.

My dll version:
aswstm.sys - file version: 9.0.2011.265
aswstm.sys.sum - file size: 223 bytes

Could you check this issue in latest 9.0.2011 build?

Thanks a lot

Offline amandakenney

  • Newbie
  • *
  • Posts: 1
Re: Fix for WebShield download issues
« Reply #65 on: January 02, 2014, 09:50:49 PM »
I just got my computer back from the factory completely wiped due to a problem with the hard drive.  When I redownloaded Avast on 12/28 I downloaded PRO since you had a sale and I was so happy with the free software up until I sent my computer away at the beginning of December.  Now many features of websites no longer work, and my internet connection is constantly interrupted when other devices are not affected (ie, it's not the internet but my computer).  Before I downloaded Avast, the computer worked just fine and all the features functioned.  I've tried turning off the web shield and it did not work.  I followed the directions and found the aswstm.sys file, but have to express the frustration of the previous poster.  I'm not a computer geek. You guys are speaking things that make little to no sense to me. I don't understand your directions on the webshield.ini  Basically I just either want it to work with little effort from me, or to get a refund and go with something else. I have a good and easy av so I don't have to be a computer geek.

Sorry, I forgot something...  I currently have the web shield disabled and still am having issues especially with social media sites and my college email. 

My system is windows 8.  I don't even know how to tell you much more than that without you walking me through it.

Please don't take my frustration personally, it isn't meant that way.  But the help just left me more confused
« Last Edit: January 02, 2014, 10:06:15 PM by amandakenney »

Offline Bolerom

  • Newbie
  • *
  • Posts: 1
Re: Fix for WebShield download issues
« Reply #66 on: January 03, 2014, 01:08:26 PM »
I have the same problem on W8.1
Ever since I updated the version on the 31st of December, I wasn't able to connect to internet in any program (browser or other connecting to internet).
The issue was there until I turned off the web shield (had a bit of a nightmare figuring out the problem!) and then everything went back in order, with the shield off!
No changes with the patch. And don't want to mess around any more with that problem.

I never experienced a single problem with Avast before.
Now it's becoming quite annoying since I can't browse with the Avast on...

Is there any solution, a possible update fixing the problem?
Is there a possibility to get back to another version of Avast? And how to do so?

Browsers: Chrome (31.0.1650.63 m) and Firefox (26.0)
System: Windows 8.1 64 bits
Avast Free antivirus 2014.9.0.2011

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81774
  • No support PMs thanks
Re: Fix for WebShield download issues
« Reply #67 on: January 03, 2014, 02:38:29 PM »
@    Bolerom
Given that the patch doesn't work (which was more related to downloading problems, not connection), it is possible that your issue could be avast being blocked. When the program is updated the executable files change and on occasion your firewall will block these changed processes.

What is your firewall ?
Does it allow avastSvc.exe internet access ?
- If it does delete the entry for it and do a reconnect to the internet, this should force the firewall to ask permission again.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline castalla

  • Jr. Member
  • **
  • Posts: 41
Re: Fix for WebShield download issues
« Reply #68 on: January 03, 2014, 04:35:44 PM »
Fix applied.  No effect on connectivity problems with Squeezeplay (squeezebox player) player fails to connect to server.

Offline fleeavast

  • Newbie
  • *
  • Posts: 3
Re: Fix for WebShield download issues
« Reply #69 on: January 03, 2014, 05:28:38 PM »
Hi guys,

several of you reported problems with downloads and general connectivity issues when WebShield is running. Especially on Windows 7 (SP0).

Luckily, we have been able to identify one of the possible causes and have prepared a patch for you. This patch is already online and should be downloaded automatically via the emergency updating mechanism.

Since we were unable to reproduce the same behavior in the test lab, my thanks go to LordAmi, who worked with us for a few days to isolate the issue and test all intermediate fixes. Thanks LordAmi!

We are not sure if it will solve all of the problems, but those of you who have experienced issues, please try it and report here.

The fix/patch is distributed on schedule and during certain events in the system (such as Logging in). It may take a while until all of you have the patch installed. In case you would like to make it quicker I recommend the following:

1) turn of WebShield from avast UI ( Settings / Active Protection )
2) restart the computer
3) open C:\Program Files\Avast Software\Avast\Setup\Inf\x86 or x64 (based on your OS version) in explorer and wait a few minutes
4) shortly after login you should see a new file created here with the name aswstm.sys.sum
5) once you see it there, turn WebShield back on

To verify you have the patch applied, you may go to:

C:\Program Files\Avast Software\Avast\Setup\Inf\x86 or .\x64

You should see:
aswstm.sys - file version: 9.0.2011.265
aswstm.sys.sum - file size: 223 bytes

The same file (aswstm.sys) should also be in your Windows\System32\Drivers folder (use 64bit explorer to check this on 64bit builds).

If these files are present and you have just started WebShield again, you should be already running the updated version.
I would be very happy to hear about your experience with the patched driver.

Lukas

I have already verified that the files exist in both locations but I am still unable to access the internet. I have never had this issue before when updating avast antivirus free. I just updated it this morning and immediately after I am unable to access the internet unless I disable the webshield. Please come out with a new patch or fix or workaround other than disabling the avast web shield.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81774
  • No support PMs thanks
Re: Fix for WebShield download issues
« Reply #70 on: January 03, 2014, 05:29:27 PM »
Fix applied.  No effect on connectivity problems with Squeezeplay (squeezebox player) player fails to connect to server.

As I mentioned in my last post the fix isn't connection related but problems with downloads, so it is unlikely to succed for your problem.

You should start your own 'new topic' and we will try and help. In that topic answer the following:

What is your operating system ?
What avast version and build are you using (e.g. avast free - 9.0.2011, etc.) ?
Are you getting any errors displayed
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81774
  • No support PMs thanks
Re: Fix for WebShield download issues
« Reply #71 on: January 03, 2014, 05:30:52 PM »
<snip quote>
I have already verified that the files exist in both locations but I am still unable to access the internet. I have never had this issue before when updating avast antivirus free. I just updated it this morning and immediately after I am unable to access the internet unless I disable the webshield. Please come out with a new patch or fix or workaround other than disabling the avast web shield.

Read my previous comments, this fix is unrelated to your problem.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Ancorgoban

  • Newbie
  • *
  • Posts: 1
Re: Fix for WebShield download issues
« Reply #72 on: January 03, 2014, 09:10:17 PM »
I am also experiencing similar problems since the update to 2014.9.0.2011
Web shield on:
downloads stop at 99% and never finish, sometimes reports that the publisher cannot be verified.
many website require that I refresh the browser several times to get the site to load.
Web shield off:
no problems.
I have tried the fix and I have the correct version of the .sys file but the .sum is only 78 bytes

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 81774
  • No support PMs thanks
Re: Fix for WebShield download issues
« Reply #73 on: January 03, 2014, 11:21:00 PM »
The .sum file is like a checksum file so that the fix version aswstm.sys isn't replaced by avast's integrity checking, but I don't know why yours is only 78 bytes.

Is the aswstm.sys version number and file version the same as previously mentioned aswstm.sys - file version: 9.0.2011.265 ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.7.2388 (build: 19.7.4674.494)/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Zyla

  • Jr. Member
  • **
  • Posts: 30
Re: Fix for WebShield download issues
« Reply #74 on: January 04, 2014, 03:14:59 AM »
I am also having problems

I have the correct aswstm.sys 9.0.2001.265 version in the windows/system32/drivers folder

Fire Fox and IE pages often have to be refreshed in order to load, and downloads dont finish when the web shields are on (avast and MBAM would not update either with the web shields on)

This is on Windows 7


It also only seems to be the web shield as i can play online games with no problem



(edit) after uninstalling zone alarm firewall and installing the new version, the situation seems to have resolved itsself (still early). So it may have been a problem with Avast 9.0.2011 and a older version of Zone Alarm
« Last Edit: January 04, 2014, 03:58:48 AM by Zyla »