Author Topic: Avast stopping an application working  (Read 3681 times)

0 Members and 1 Guest are viewing this topic.

Foxman50

  • Guest
Avast stopping an application working
« on: January 04, 2014, 07:07:49 PM »
Hi All

Ive updated Avast to 2014.9.0.2011, but it is stopping an application working on my pc.

The application is Minimwatch, which connects to its counter part application Minimserver which runs on my NAS. Basically Minimwatch updates information on Minimserver. This is a java app, but basically since the update yesterday the app is not working. Disabling Avast in "avast! shields control" then allows the application to work.

Is there a way to tell Avast to ignore this application, or tell it its safe.

Graeme

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: Avast stopping an application working
« Reply #1 on: January 04, 2014, 07:39:04 PM »
Are you getting a warning or deepscreen pop-up?
If so a screenshot would be nice.  :)
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Foxman50

  • Guest
Re: Avast stopping an application working
« Reply #2 on: January 04, 2014, 07:56:07 PM »
Hi Para-Noid

It wasn't me ok, just so you know. :)

No i don't get any pop ups or indication from Avast at all, or any other app. Only reason i suspected Avast was because its the only thing id updated.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: Avast stopping an application working
« Reply #3 on: January 04, 2014, 08:11:26 PM »
I should have asked this before...what make you think it's avast preventing the application from running?  ???

The reason I ask is that when avast blocks something you will get a pop-up.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Foxman50

  • Guest
Re: Avast stopping an application working
« Reply #4 on: January 04, 2014, 08:20:18 PM »
Disabling Avast via "avast! shields control" allows the application to work correctly.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: Avast stopping an application working
« Reply #5 on: January 04, 2014, 09:02:32 PM »
1) Do you get "any" pop-ups when you access the file?  Make sure "all" shields are active.
    If you do get a screenshot.

2) Have you ran a full scan using both avast and MalwareBytes?

Do step 1 then step 2. Running both scans will take a while.

You may be having issues with java. Java is well known to be easily exploited.

Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Foxman50

  • Guest
Re: Avast stopping an application working
« Reply #6 on: January 04, 2014, 11:12:59 PM »
Both scans completed, nothing found. Is there a way to tell Avast that an application is safe.

castalla

  • Guest
Re: Avast stopping an application working
« Reply #7 on: January 05, 2014, 12:32:05 AM »
This seems similar to http://forum.avast.com/index.php?topic=144058.0  where there are no popups or warnings either.  The application just fails to connect.  Switching web-shield off works as a 'fix'.


Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2235
Re: Avast stopping an application working
« Reply #8 on: January 05, 2014, 12:36:56 AM »
This seems similar to http://forum.avast.com/index.php?topic=144058.0  where there are no popups or warnings either.  The application just fails to connect.  Switching web-shield off works as a 'fix'.

I wouldn't recommend turning off the Web Shield?

Can't you just exclude the folder since avast! UI > Settings > Scroll to Exclusions > [enter path] > Add.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6711
  • Trust only what you test yourself!
Re: Avast stopping an application working
« Reply #9 on: January 05, 2014, 01:06:12 AM »
This seems similar to http://forum.avast.com/index.php?topic=144058.0  where there are no popups or warnings either.  The application just fails to connect.  Switching web-shield off works as a 'fix'.

I wouldn't recommend turning off the Web Shield?

Can't you just exclude the folder since avast! UI > Settings > Scroll to Exclusions > [enter path] > Add.

Me neither.

Thanks Alikhan! That was going to be my next suggestion. I wanted to exclude any and all possibilities.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Foxman50

  • Guest
Re: Avast stopping an application working
« Reply #10 on: January 05, 2014, 12:10:45 PM »
castalla - Yes i think its an identical issue, they are both UPnP server related issues.

All - No, added the folder to exclusions but did not work.

On the link castalla posted there is an exclusion for web shield, where you can add the process. Ive checked my process and it comes up with

"Java(TM) Platform SE binary (32 bit)"

in Task Manager

Im not sure i want to add this as an exclusion because, im not sure but, i think that's asking for trouble.

I only need to run this application for 30 seconds or so, so to be honest i think ill just turn off web shield and turn it back on after i've ran and closed the Minimwatch app.

Thanks for all your suggestions

Regards Graeme