Author Topic: VPN works only with disabled Firewall  (Read 3644 times)

0 Members and 1 Guest are viewing this topic.

Offline reto@blaettlers.ch

  • Newbie
  • *
  • Posts: 1
VPN works only with disabled Firewall
« on: November 05, 2013, 09:48:51 PM »
Hello,

I have a SSL-VPN Connection to my Office with Barracuda SSL VPN. It starts an RDP-Session by using a JAVA Modul.

If I try to start it while AVAST Internet Security Firewall (current Version 2014.9.0.2007) is running, the RDP Session does not start (it connects to the local SSL VPN Agent 127.0.0.1:5xxxxx, the SSL-Agent opens a tunnel to the Office-Net).

As soon as I disable the AVAST Firewall, it works fine.

I already checked the Firewall logs, no hint. I set RDP (mstsc.exe) to be accepted for in and out connections.

How can I get the SSL Agent running?

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: VPN works only with disabled Firewall
« Reply #1 on: November 13, 2013, 09:24:02 PM »
I've also had this problem since I went from free to premium when the firewall kicked in.  If I set the firewall off for the minimum 10 minutes, let the barracuda/ssl vpn agent fire open my connection then enable the firewall I can continue to use the connection. I'm about to try and per the faqs etc try and reconfigure it to actually just work instead of off connect on but saw your email first so thought I should response.
By which I mean, settings/active protection/firewall to off for 10 minutes, use your vpn link to open the connection, then back to active protection firewall on.
« Last Edit: November 13, 2013, 09:32:19 PM by engarde »

Offline dbrisendine

  • Malware Fighter
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1258
Re: VPN works only with disabled Firewall
« Reply #2 on: November 13, 2013, 10:49:14 PM »
If you go to Tools > Firewall > Settings > Policy > System Rules, what is Disabled or Not Configured?  Also, in Firewall > Settings > Network profiles, how is the current connection set (Public or Private) (with or without Friends checked)?

If you change profile to Public, does it work?  Public with Remote desktop connection Enabled?

One other thing is to turn on logging for blocked packets (Tools > Firewall > Settings > Advanced > Firewall logs) as this is turned off by default; you may be able to see what is blocked and adjust accordingly.
Win7 x32 Ult. SP1, Brain 2.0 / Win10 x64, Brain2.5
My help is always free but if you would like to help encourage me or show your thanks -----> DONATE

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: VPN works only with disabled Firewall
« Reply #3 on: November 14, 2013, 10:17:50 PM »
Public/private with or without friends no joy. I tried to reconfigure chrome the browser I was using with ask rules for internet in/out and default but no joy. I will give the blocked ports tracing a go next.

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: VPN works only with disabled Firewall
« Reply #4 on: November 17, 2013, 08:05:17 PM »
Enabling logs shows exactly nothing being blocked. Nor switching from private to public. Similarity if I explicitly enable remote on private or public
« Last Edit: November 17, 2013, 08:19:29 PM by engarde »

Offline jursa

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Re: VPN works only with disabled Firewall
« Reply #5 on: January 06, 2014, 04:39:35 PM »
Hi, this problem with baracuda VPN should be fixed in latest build. 9.0.2011 -> http://forum.avast.com/index.php?topic=142936.0

Could you please re-test it  ?

Thnx,
David.

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: VPN works only with disabled Firewall
« Reply #6 on: January 07, 2014, 09:08:26 PM »
It is fixed BUT the firewall keeps disabling itself, per the ugly long thread of delights for 2011