Author Topic: WebShield + Analogx Proxy  (Read 11447 times)

0 Members and 1 Guest are viewing this topic.

leomalav

  • Guest
WebShield + Analogx Proxy
« on: June 22, 2005, 02:27:33 PM »
Hi everybody

I'm almost finished setting up Avast in my computers! Bear with my just a little longer...  :)

I have two of them running Windows 98 SE, in a small network.

The no. 1 has the broadband connection to the internet,  Avast and WebShield running (explorer set manually to "localhost - port 12080") . This is computer 192.168.10.1.

I wanted to share the broadband connection with computer no. 2 (192.168.10.2) and so I installed Analogx proxy on computer no. 1.

The lan has been set to 192.168.10.1 and port 6588 in computer no. 2 Explorer, as instructed by Analogx readme.

The problem is the following...

If I have the WebShield running on computer no. 1, I get a "Does not support loopback URL localhost:12080ÿ.com.br/" error on computer no. 2 browser.

If I revert the Explorer in computer no. 1 to its default configurations (disabling webshield), everything works perfectly!

It seems that the two proxies are not working well together...

Any ideas?

Tia

Leonardo

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: WebShield + Analogx Proxy
« Reply #1 on: June 22, 2005, 04:22:47 PM »
Step-by-step instructions on how to set up a proxy server:
http://forum.avast.com/index.php?topic=12123.msg102656#msg102656
Hope this helps...
The best things in life are free.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #2 on: June 22, 2005, 05:44:22 PM »
I don't know why it does not work together, but there is also the other way to share the web.

1) edit avast4.ini in c:\Alwil Software\avast4\data\avast4.ini
2) in the section [WebScanner] add the line

[WebScanner]
ListenOnLocalhostOnly=0

3) restart WebShield provider

Then you can configure the browser on the computer 2 to use proxy on 192.168.10.1, port 12080

;-)

It should work also the way how you originaly configured it. Perhaps the AnalogX is reading the configuration from Internet Explorer and forwards (or reject to forward) the request based on this config - and this might be turned off in it's configuration, I guess.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #3 on: June 22, 2005, 06:03:21 PM »
If you still want to use AnalogX on the machine B (perhaps because you don't want to see the virus warnings when the user from machine B tries to download one  :P), do the following:

1) edit your avast4.ini as in my previous post - that is: add the line ListenOnLocalhostOnly=0 to the [WebScanner] section a restart WebShield

2) change your proxy configuration in IE settings on machine A to: 192.168.10.1, port 12080

3) change the proxy on machine B to: 192.168.10.1, port 6588


leomalav

  • Guest
Re: WebShield + Analogx Proxy
« Reply #4 on: June 23, 2005, 12:48:17 AM »
Hi Lukor

Thanks!

Both solutions you presented worked like a charm!  ;)

Anyway, I guess I'll go with the first one, and let the Web Scanner work double time!  :D

Regards

Leonardo

cvsa

  • Guest
Re: WebShield + Analogx Proxy
« Reply #5 on: June 23, 2005, 09:39:04 AM »
Great !!!

Thank you Lukor !! :D :D :D

cvsa

  • Guest
Re: WebShield + Analogx Proxy
« Reply #6 on: June 24, 2005, 09:03:48 AM »
Since i did that setting, i have trouble opening some links in my browser (firefox) : many messages "documents contain no data").

Could it be due to the new websield parameter ?

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #7 on: June 24, 2005, 01:09:59 PM »
Since i did that setting, i have trouble opening some links in my browser (firefox) : many messages "documents contain no data").

Could it be due to the new websield parameter ?

No. It just controls on what interfaces (IP addresses) will WebShield accept connections. This does not alter other functionality nor changes the way how requests are processed.

"Document contains no data" does not necessary mean it is an error - perhaps the link is down, or the server is too busy and the like.
Is this resproducible on some links or does this happens randomly?

cvsa

  • Guest
Re: WebShield + Analogx Proxy
« Reply #8 on: June 24, 2005, 02:12:24 PM »
it could be because the server is busy...

i have to click 2 or 3 times on the link to have it opened.... but it looks like it works better with IE than with FF............. ::)

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #9 on: June 24, 2005, 02:39:35 PM »
Internet Explorer retries the connection up to 3 times, before it notifies you about the problem. WebShield also retries so together they migh connect even to a fairly overloaded server.

leomalav

  • Guest
Re: WebShield + Analogx Proxy
« Reply #10 on: August 10, 2005, 01:29:51 AM »
I don't know why it does not work together, but there is also the other way to share the web.

1) edit avast4.ini in c:\Alwil Software\avast4\data\avast4.ini
2) in the section [WebScanner] add the line

[WebScanner]
ListenOnLocalhostOnly=0

3) restart WebShield provider

Then you can configure the browser on the computer 2 to use proxy on 192.168.10.1, port 12080


Hi Lukor

I've been using the above solution for a while now, and it's raised an interesting security question...

I have Zone Alarm running on computer 1 (protecting the broadband connection) and I noticed  that some programs on computer 2 are able to access the internet without being detected by it, simply by automatically using the Internet Explorer configuration (proxy on 192.168.10.1, port 12080).

It happens because the WebShield scanner acts as a proxy, and as it has already been given access rights in Zone Alarm on computer 1, no pop-ups asking for permission show up!

The main question is: couldn't a malicious program on computer 2 (or even on computer 1!) take this same Internet Explorer configuration, use the WebShield as a proxy (bypassing Zone Alarm), and have free access to the internet, creating a dangerous security hole?

Regards

Leonardo

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: WebShield + Analogx Proxy
« Reply #11 on: August 10, 2005, 03:46:37 AM »
Internet Explorer retries the connection up to 3 times, before it notifies you about the problem.
Lukor, do you know how to change/tweak this Internet Explorer setting? Sometimes I want it test more times but often, to wait a little more to give me an error (when, for instance, many pages are opened at the same time).
The best things in life are free.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #12 on: August 10, 2005, 12:16:59 PM »
Internet Explorer retries the connection up to 3 times, before it notifies you about the problem.
Lukor, do you know how to change/tweak this Internet Explorer setting? Sometimes I want it test more times but often, to wait a little more to give me an error (when, for instance, many pages are opened at the same time).

I have no idea, sorry. Perhaps a google will answer  :P

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: WebShield + Analogx Proxy
« Reply #13 on: August 10, 2005, 12:21:26 PM »
I have Zone Alarm running on computer 1 (protecting the broadband connection) and I noticed  that some programs on computer 2 are able to access the internet without being detected by it, simply by automatically using the Internet Explorer configuration (proxy on 192.168.10.1, port 12080).

Leomlav, this is of course possible. If you open the proxy to outside world, you also need to restrict the access rights for it. If you have firewall installed only on computer 1, you have no way of detecting which process from computer 2 is connecting to the WebShield proxy. The only parameter you may limit is the IP ipaddress of the connecting pc (computer 2 in this case).

On the other hand, you may install zonealarm on computer2 too and there you can control connections to computer1 port 12080 in a standard way.

leomalav

  • Guest
Re: WebShield + Analogx Proxy
« Reply #14 on: August 10, 2005, 03:35:44 PM »

Leomlav, this is of course possible. If you open the proxy to outside world, you also need to restrict the access rights for it. If you have firewall installed only on computer 1, you have no way of detecting which process from computer 2 is connecting to the WebShield proxy. The only parameter you may limit is the IP ipaddress of the connecting pc (computer 2 in this case).

On the other hand, you may install zonealarm on computer2 too and there you can control connections to computer1 port 12080 in a standard way.

Hi Lukor

I'll install Zone Alarm in computer 2 and give it a try! Talk about overkill...  :D

Thanks

Leonardo