Author Topic: Avast Installs In Internet Explorer Only  (Read 4781 times)

0 Members and 1 Guest are viewing this topic.

VaEsther

  • Guest
Avast Installs In Internet Explorer Only
« on: January 28, 2014, 09:44:05 AM »
Hello,

For 2 days I attempted a 'custom' install of Avast's free version only to have it install only as an Internet Explorer's  'helper' each time.  I wanted an installation for my entire computer not just IE Avast seemed to have other plans.

After installing Avast (and rebooting my computer) its device manager indicated Avast was not connected.  I tried accessing the options on the device manager's home page but nothing worked.  The other section of the device manager were all blank.  However, WinPatrol notified me Avast wanted to make changes to Internet Explorer and did I agree.  I clicked 'No' yet Avast's IE 'Helpers were installed anyway.



I have installed, uninstalled (with Revo Uninstaller) and reinstalled Avast numerous times without success.  I hope someone can assist with this issue.           

Thank you.                               
« Last Edit: January 28, 2014, 09:47:54 AM by VaEsther »

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37152
  • Not a avast user
Re: Avast Installs In Internet Explorer Only
« Reply #1 on: January 28, 2014, 11:05:50 AM »
For security programs always use the vendors uninstall tool

wwww.avast.com > support > downloads > uninstall utility


VaEsther

  • Guest
Re: Avast Installs In Internet Explorer Only
« Reply #2 on: January 28, 2014, 07:04:16 PM »
Hello,

Thank you for your reply.  But how do I install Avast for my entire computer and not just a plugin for Internet Explorer?

AdrianH

  • Guest
Re: Avast Installs In Internet Explorer Only
« Reply #3 on: January 28, 2014, 07:06:33 PM »
Hello,

Thank you for your reply.  But how do I install Avast for my entire computer and not just a plugin for Internet Explorer?

Download and run this tool  avast! cleaner: http://files.avast.com/iavs9x/avastclear.exe

To install again , first turn off other software like WinPatrol, let the installer do its job.

Online CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11175
  • No support PM's thanks
Re: Avast Installs In Internet Explorer Only
« Reply #4 on: January 28, 2014, 07:10:50 PM »
What part of the shields are you choosing not to custom install ? you need the three main shields at least File Mail and Web, I get the feeling you are unticking everything and only leaving Browser Protection ticked.

VaEsther

  • Guest
Re: Avast Installs In Internet Explorer Only
« Reply #5 on: February 12, 2014, 01:50:59 PM »
Hello Craigb,

Thank you for your reply.  You are absolutely correct, I unticked web, mail and file protection before installation.  I did this because I have MBAM Pro which also have those shield protections and I thought having both protections would cause a problem.

At the moment I am using Microsoft Security Essential and MBAM.  I know I must uninstalled MSE, should I also uninstall MBAM before installing Avast?

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2233
Re: Avast Installs In Internet Explorer Only
« Reply #6 on: February 12, 2014, 01:55:18 PM »
Hello Craigb,

Thank you for your reply.  You are absolutely correct, I unticked web, mail and file protection before installation.  I did this because I have MBAM Pro which also have those shield protections and I thought having both protections would cause a problem.

At the moment I am using Microsoft Security Essential and MBAM.  I know I must uninstalled MSE, should I also uninstall MBAM before installing Avast?

No, both avast! and Malwarebytes (free or Paid) run together. You should keep Malwarebytes Pro enabled and set the mutual exclusions between the 2 programs:

Note: In v9 set the exclusions for all shields and scans in:

avast UI > Settings > Antivirus > [scroll down] to Exclusions

https://forums.malwarebytes.org/index.php?showtopic=10138&page=1&#entry417798.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Online CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11175
  • No support PM's thanks
Re: Avast Installs In Internet Explorer Only
« Reply #7 on: February 12, 2014, 02:19:18 PM »
MBAM Pro isn't an Anti-Virus so it works well with avast, The web protection of MBAM also works in a completely different way to the Web Shield in avast so you need to have avast installed as your core protection then decide if you want all features of Malwarebytes active.

Just to add! there is no problem in running all MBAM features alongside of avast which is what I have mine set to :)

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6710
  • Trust only what you test yourself!
Re: Avast Installs In Internet Explorer Only
« Reply #8 on: February 12, 2014, 06:31:35 PM »
You can safely uninstall the "browser protection" module.
Control Panel>Uninstall a Program>double click "avast">click "change">untick "browser protection">reboot

Or you can disable the "avast online security" add-on" in each of your browsers.

For the best protection "install" the web, file and mail shields.
These are your frontline of defense/protection.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

VaEsther

  • Guest
Re: Avast Installs In Internet Explorer Only
« Reply #9 on: February 14, 2014, 10:25:03 PM »
Hello everyone,

Thank you for all the helpful replies, I am grateful to have so many responses to my need of assistance.

In an attempt to correctly install Avast I took your suggestions into account and did the following:

1.  Uninstalled Microsoft Securities Essential
2.  Exited WinPatrol
3.  Installed Avast (none of the shields were unchecked) using the link provided by AdrianH  -  http://files.avast.com/iavs9x/avastclear.exe
4.  Rebooted my computer

After rebooting, again I noticed the Avast icon did not appear in the taskbar.  However, (again) Avast was installed as a browser security in Internet Explorer and FireFox (which I had not noticed after prior installations).  It did not appear in Chrome.  Also, again I could not access the "computer protection".

The 'preference manager' indicated I was 'UNPROTECTED' and Avast 'Service' and 'Self Defense' were 'OFF'.  Of course I clicked the 'Start', 'Turn On' and 'Resolve All' buttons but to no avail.  I even attempted to fix the problem by going to Microsoft's 'Uninstall Programs' and changing Avast, twice.  However, both times I received an 'Error' and the following information:


20:18:37Infoinstcont[112,1828]--
20:18:37Infoinstcont[112,1828]2014/02/14 20:18:37 START: Avast installer/updater
20:18:37Infoinstup[112,1828]Command: '"C:\Program Files\AVAST Software\Avast\Setup\Instup.exe" /control_panel /instop:uninstall'
20:18:37Infoinstup[112,1828]CPU: AMD Athlon(tm) II X2 250 Processor,2
20:18:37Infoinstup[112,1828]OS: Windows 7 ver 6.1, build 7601, sp 1.0 [Service Pack 1] x64
20:18:37Infoinstup[112,1828]Memory: 38% load. Phys:2400116/3931112K free, Page:4194303/4194303K free, Virt:4109544/4194176K free
20:18:37Infoinstup[112,1828]DISKs: C:\ - 191GB free / 377GB total
20:18:37Infoinstup[112,1828]DISKs: E:\ - 67GB free / 72GB total
20:18:37Infoinstup[112,1828]Running module version: '9.0.2013.292'
20:18:37Infosimutex[112,1828]Checking for the mutex ownership.
20:18:37Infoguiwizard[112,1828]Setup gui was successfully started.
20:19:04Infoinstupcore[112,1828]Product pre-change has started.


I will uninstall Avast again and reinstall MSE.  Avast has received raved reviews (more than MSE) and I wanted to include it as part of my computer protection arsenal.  However, for now Avast is eluding my computer. :'(

Thank you,
VaEsther
« Last Edit: February 14, 2014, 10:28:40 PM by VaEsther »

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2233
Re: Avast Installs In Internet Explorer Only
« Reply #10 on: February 14, 2014, 10:57:48 PM »
3.  Installed Avast (none of the shields were unchecked) using the link provided by AdrianH  -  http://files.avast.com/iavs9x/avastclear.exe

That is the link the the avast remover. That will remove avast! from your PC. Follow these simple instructions to do a clean install...

1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition

Note: It's important you used the stub online installer from the one I linked.. NOT the offline one.

Note: You need to be ONLINE during this install (online installer works in all cases whereas offline sometimes doesn't)

http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #4]
3. Uninstall in safe mode using Avastclear.
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
Check : Once uninstalled check in device manager>view>show hidden devices if there is anything related to avast with a yellow triangle.. if so, uninstall it and reboot.
5. Install the version you downloaded.
6. Reboot.
ReplyQuoteNotify
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

VaEsther

  • Guest
Re: Avast Installs In Internet Explorer Only
« Reply #11 on: February 15, 2014, 07:54:11 AM »
Hello Alikhan,

Thank you for your quick reply. You are correct, I posted the wrong link above.  I downloaded 'Avast! Free Antivirus' from Avast! Installation Files page:  http://www.avast.com/download-software.

So far I have installed and uninstalled Avast in practically every way imaginable (I have yet to use Rezjors Uninstall Utility) yet it continues to install as a browser security addon only!  I have uninstalled Avast!  through Microsoft Uninstall Programs, Revo Uninstaller, Avast's Uninstaller, Restored to an earlier point (which I did tonight) and manually deleted left over files and registry keys.  I cannot help but think something which have yet to be identified is preventing Avast! Free Antivirus from installing correctly on my computer.

I may try to download Avast! again sometime in the near future, however for now prudence suggest I stop attempting to force the issue.

Again, thank you all for your invaluable assistance.
VaEsther