Author Topic: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate  (Read 10265 times)

0 Members and 1 Guest are viewing this topic.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76079
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #15 on: February 22, 2014, 10:53:47 PM »
Gut, Feedback erwünscht.

Schönen Abend,
Asyn
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

H.Gold

  • Guest
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #16 on: February 24, 2014, 03:23:00 PM »
Hallo,

die Avast-Vers. 9.0.2011 hatte mich ja derart geärgert, dass ich Avast auf allen Rechnern durch ein anderes AV-Programm ersetzt habe. Bis dahin war ich ein treuer und zufriedener Avast-Benutzer – von der Vers. 5 bis zur 9.0.2008.

Jetzt wollte ich Avast nochmal eine Chance geben. Deshalb teste ich auf meinem Laptop-Oldie gerade die Vers. 9.0.2013. Der muss für so etwas immer als Test-Objekt herhalten – läuft es auf dem akzeptabel, ist das bei den anderen Rechnern erst recht so.             

Was den Web-Schutz betrifft, so bin ich da gleich mal erschrocken – das ist bei der aktuellen Vers. ja sogar nochmal schlimmer geworden. Das Problem vom Themenstarter habe ich zwar nicht, dafür aber eine sehr hohe Prozessor-Auslastung. 

Wenn ich z. B. einen DSL-Speedtest mache, schnellt die Prozessor-Last der „AvastSvc.exe“, während dem Download-Test, auf bis zu 60% hoch.

Beim Abspielen eines Flash-Videos liegt die zwar die meiste Zeit bei 0, zwischendurch aber immer wieder mal kurzzeitig bei bis zu 40% - wodurch das Video nicht mehr durchgehend flüssig läuft.

Und auch beim einfachen Surfen, also beim Laden der Web-Seiten, ist die recht hoch.

Vorher (bis zur Vers. 9.0.2008) war das nicht so. Das ist erst, seitdem am Web-Schutz etwas geändert wurde. Auf besagtem Laptop liefen die Versionen 5 bis einschl. 9.0.2008 wunderbar, da gab es keinerlei Probleme.

Bevor ich Avast endgültig abhacke, habe ich jetzt noch „diesen Eintrag in die WebShield.ini“ ausprobiert.

Ergebnis: Statt auf 60% hochzuschnellen, bleibt die Prozessor-Last der „AvastSvc.exe“, während dem Download-Test, jetzt unter 10%.

Das gleiche beim Flash-Video: Statt bis zu 40%, sind es jetzt nur noch max. 7%.

Und auch beim einfachen Laden der Web-Seiten, liegt die jetzt deutlich niedriger.

Da dieser Eintrag ja nichts anderes bewirkt, als dass der Web-Schutz eben so wie „früher“ arbeitet, drängt sich einem schon die Frage auf, warum man den nicht einfach so belassen hat, statt den derart zu „verschlimmbessern“?!   

Statt über einen Eintrag in die WebShield.ini, das einfach über die GUI auswählen/einstellen zu können, wäre auch sehr viel einfacher.   

Apropos „GUI“: Mir ist aufgefallen, dass durch diesen Eintrag die GUI etwas seltsam reagiert. Damit kann ich aber leben, da ich die ja nicht so oft benutze.

Was das Einfügen in die WebShield.ini selber betrifft, so geht das übrigens auch sehr viel einfacher. Auch den Selbstschutz muß man hierfür nicht deaktivieren. Statt dessen den Rechner einfach im abgesicherten Modus starten. 

Hier die WebShield.ini dann mit dem Editor öffnen, die zuvor abgespeicherten Zeilen rein kopieren, Datei speichern, Rechner neu starten – fertig! 
   
Grüße

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76079
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #17 on: February 25, 2014, 06:56:26 AM »
Danke für dein Feedback.

LG Asyn
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

semper

  • Guest
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #18 on: February 25, 2014, 02:32:19 PM »
Hallo Asyn.

Offenbar hat der Eintrag des zusätzlichen Parameters in die WebShield.ini geholfen. Seitdem hatte ich keinen einzigen Abbruch der Internetverbindung mehr zu verzeichnen.

Danke für den Tipp!

Avast! bleibt also installiert, was mir eigentlich ganz recht ist.

In Anlehnung an den Kommentar von H.Gold nun noch diese zwei Fragen: 1. Was bewirkt der zusätzliche Eintrag nun genau bzw. welcher Fehler des Programms wird mit ihm verhindert - oder vielmehr - wodurch trat der Fehler überhaupt auf. 2. Gibt es durch das Zusatzparameter jetzt evtl. eine Sicherheitslücke im Programm (Backdoor etc.)?

Es würde mich schon interessieren, ob die Fehlerursache im Betriebssystem oder im Programm selbst liegt und ob zukünftige Programmupdates mit dem Ini-Eintrag zurecht kommen oder diesen wieder überflüssig machen werden. 

Gruß

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76079
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #19 on: February 26, 2014, 06:49:58 AM »
1. Offenbar hat der Eintrag des zusätzlichen Parameters in die WebShield.ini geholfen. Seitdem hatte ich keinen einzigen Abbruch der Internetverbindung mehr zu verzeichnen. Danke für den Tipp!
2. Was bewirkt der zusätzliche Eintrag nun genau bzw. welcher Fehler des Programms wird mit ihm verhindert - oder vielmehr - wodurch trat der Fehler überhaupt auf.
3. Gibt es durch das Zusatzparameter jetzt evtl. eine Sicherheitslücke im Programm (Backdoor etc.)?
4. Es würde mich schon interessieren, ob die Fehlerursache im Betriebssystem oder im Programm selbst liegt und ob zukünftige Programmupdates mit dem Ini-Eintrag zurecht kommen oder diesen wieder überflüssig machen werden. 

1. Bitteschön.
2. Setzt den Web-Schutz in den Proxy-Modus.
3. Nein, keine Sorge.
4. Auf einigen wenigen Systemen gibt's noch Probleme mit dem neuen Stream-Filter, es wird daran gearbeitet.

LG Asyn
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

semper

  • Guest
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #20 on: February 26, 2014, 04:11:37 PM »
Danke Asyn, für Deine Antworten.

Allerdings habe ich mit einer Antwort ein Verständnisproblem:


2. Setzt den Web-Schutz in den Proxy-Modus.

Laut den Angaben meiner hiesigen avast! Installation unter Einstellungen > Update > Proxyeinstellungen benutze ich statt einem Proxyserver eine "Direkte Internetverbindung (Kein Proxy)" und den Standartport 8080 für den Zugang.

Falls ich Deine Antwort unter 2. aber richtig verstanden habe, bedeutet die Prameterzuzweisung in der WinShield.ini, daß nun doch ein Proxy hinzugefügt wurde und der Internetverkehr jetzt über diesen geleitet wird, womit sich auch der Port geändert haben dürfte.

Da ich aber keine Angaben dazu im Einstellungsmenü finde, bin ich da nicht ganz sicher. (1) Welcher Proxyserver wird denn nun verwendet, (2) welchen Port verwendet er, (3) wieso mußte ich dazu die Ini-Datei erweitern und konnte diesen Schritt nicht in den Einstellungen vornehmen? Natürlich stellt sich mir nun auch die Frage, (4) ob dies ein lokaler und/oder transparenter Proxy ist, oder (5) ob hier von avast! mein Internetverkehr mitgelesen und evtl. sogar protokolliert bzw. gefiltert wird (also de facto doch eine "Backdoor"), und falls Ja, (6) nach welchen Standards.

Im Wiki von Avast gibt es zu der Lösung via ini in Verbindung mit der Free-Version nicht genug Info, um alles zu beantworten. Außerdem bin ich, wie Du vielleicht an meinen Fragen bereits erkennen konntest, keineswegs mit Profiwissen aus dem IT-Wesen ausgestattet. Tschuldige also , daß ich hier damit an Dich herantrete (und evtl. schon zu nerven anfange) - aber das Thema ist ja nicht nur sicherheitsrelevant sondern betrifft auch die Privatsphäre, und da werde ich naturgemäß ziemlich sensibel.

Gruß

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76079
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: (Schon wieder) Internetabbrüche nach dem letzten Programmupdate
« Reply #21 on: February 27, 2014, 06:54:32 AM »
Falls ich Deine Antwort unter 2. aber richtig verstanden habe, bedeutet die Prameterzuzweisung in der WinShield.ini, daß nun doch ein Proxy hinzugefügt wurde und der Internetverkehr jetzt über diesen geleitet wird, womit sich auch der Port geändert haben dürfte.

Es ist ein lokaler Proxy, du mußt also keine Einstellungen ändern. Der Web-Schutz funktionierte bis 9.0.2008 auf allen BS gleich (Proxy-Modus), in den neueren Versionen wird unter W7 und höher der Stream-Filter eingesetzt.

LG Asyn
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0