Author Topic: Firewall won't turn on!  (Read 3482 times)

0 Members and 1 Guest are viewing this topic.

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Firewall won't turn on!
« on: March 04, 2014, 08:54:17 PM »
I ran the cleaner and did a clean install of the current internet security. After install I can't connect to Internet plus the firewall will not turn on. I click turn on and it says unable to start firewall!  This happened after I updated to the 2014 version and couldn't resolve so I restored to an earlier date. Please help!

Offline Michael (alan1998)

  • Massive Poster
  • ****
  • Posts: 2780
  • Volunteer
Re: Firewall won't turn on!
« Reply #1 on: March 04, 2014, 08:57:47 PM »
Try a repair install. Add/Remove Programs > Avast! (version) > Double Click > Repair > Continue.

If that doesn't help let me know.
SOC Analyst, Digital Forensics & Incident Response (no cert), SIEM Design and Management, HTB Competitor & Pentesting (no cert). I occasionally write custom applications for threat detection...

Personal security is a mindset, not an application. Think before clicking.

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Re: Firewall won't turn on!
« Reply #2 on: March 04, 2014, 09:06:44 PM »
No luck.

Thank for responding! :)

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Re: Firewall won't turn on!
« Reply #3 on: March 04, 2014, 10:27:25 PM »
I noticed in the device manager/network adapters that there is several avast firewall drivers with ! But I can't access internet to update! 

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall won't turn on!
« Reply #4 on: March 04, 2014, 10:29:09 PM »
Since v9, that's changed. Those devices of avast! shouldn't be in device manager.

You need to do a clean install.

1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition

Note: It's important you used the stub online installer from the one I linked.. NOT the offline one.

Note: You need to be ONLINE during this install (online installer works in all cases whereas offline sometimes doesn't)

http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #4]
3. Uninstall in safe mode using Avastclear.
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
Check : Once uninstalled check in device manager>view>show hidden devices if there is anything related to avast with a yellow triangle.. if so, uninstall it and reboot.
5. Install the version you downloaded.
6. Reboot.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Re: Firewall won't turn on!
« Reply #5 on: March 04, 2014, 11:44:14 PM »
I have uninstalled and ran both cleaners. I had to uninstall devices myself and rebooted. I still can't access internet. Says there might be a problem with the driver for the wireless network connection adapter. Tried direct connection to modem and still no service.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall won't turn on!
« Reply #6 on: March 04, 2014, 11:54:29 PM »
I have uninstalled and ran both cleaners. I had to uninstall devices myself and rebooted. I still can't access internet. Says there might be a problem with the driver for the wireless network connection adapter. Tried direct connection to modem and still no service.

So you did each step I mentioned?

Have you tried resetting your network adapter?

Can you access the internet without avast! installed?

What security programs did/do you use?
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Re: Firewall won't turn on!
« Reply #7 on: March 05, 2014, 12:20:28 AM »
I did all steps except install avast cuz you said I needed internet and I didn't have it.  After completely removing avast I did not have internet.

Resetting was unsuccessful. Would not install drivers cuz no internet I guess.

No I can not access internet without avast!  It baffles me cuz what effect does avast have on my drivers?

I use avast and malwarebytes.

Last time I tried updating was after the release and this is the same problem I was having then. A simple restore gets me back to normal except no 2014 avast.


Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2234
Re: Firewall won't turn on!
« Reply #8 on: March 05, 2014, 12:40:31 AM »
If after completely removing avast using add/remove + the avastclear.exe and avast cleanup tool and you still have no internet it's not related to avast! since it's been removed.

You have checked in device manager to see if any entries are present?

If resetting was unsuccessful I assume the network driver has gone corrupt and you need to re-install the correct one.

Download the correct driver from your manufacturer and save it onto a removable media option (such as a USB).

Then install it onto the affected PC.
Windows 10 Home 64-bit • Avast Free (latest stable version) •  Malwarebytes 4 Premium (On-Demand) • Windows Firewall Control • Google Chrome • LastPass • CCleaner • O&O ShutUp10 •

Offline Jkhs3

  • Newbie
  • *
  • Posts: 6
Re: Firewall won't turn on!
« Reply #9 on: March 05, 2014, 12:53:26 AM »
I will do that. Thank you for your help!