Author Topic: Multiple EAS Scheduled Database Replication Problem  (Read 2440 times)

0 Members and 1 Guest are viewing this topic.

Offline Peck4919

  • Newbie
  • *
  • Posts: 3
Multiple EAS Scheduled Database Replication Problem
« on: March 28, 2014, 07:42:24 PM »
New installation.  Three out of seven planned EAS server installs.
Installed full SQL on all, Installed EAS, subscribed child servers (Apollo and Aeacus) to the root server (Destiny) successfully.  Created Database Replication task on the root server.  Right click it and run it, everything finishes successfully.
Added a Schedule Event to run the job on the root EAS every day at 6:00 AM.  The scheduled task fails every time (Unknown error.).  I'm afraid to forge ahead on my installs until I get this right.

In the Event Log for the Root AES I get the following 2 errors:
1) Database command failed [CServer::ReplicateServer, 80040E14]: SQLServerAgent Error: Request to run job DESTINY-avastent-policy_publication-apollo-2 (from User sa) refused because the job is already running from a request by Schedule 8 (Replication agent schedule.)

2) Database command failed [CServer::ReplicateServer, 80040E14]: SQLServerAgent Error: Request to run job DESTINY-avastent-policy_publication-AEACUS-1 (from User sa) refused because the job is already running from a request by Schedule 7 (Replication agent schedule.). 

There is one entry pertaining to each of the child servers.

It almost seems as if the child servers are trying to start the job on the root server while the root server is already running the job.

I tried deleting the schedule and then replicating the database, then putting the schedule back, and replicating again.  The scheduled replication continues to fail.

At this point, the only way to replicate is for me to do it manually, every day.

There are NO firewalls blocking traffic between servers.

Any help or advise would be greatly appreciated..

Offline Peck4919

  • Newbie
  • *
  • Posts: 3
Re: Multiple EAS Scheduled Database Replication Problem
« Reply #1 on: April 10, 2014, 03:39:33 PM »
Having received no replies, I thought this might be due to the root AES running Server 2003 and SQL 2005.  I blew out my entire installation, and created a new root server.  Server 2008 R2 with SQL 2008 R2.  I rebuilt everything from scratch.  All three servers are Server 2008 R2 with SQL 2008 R2 installed.  I still get the same two errors in Event Viewer and the replication is listed as having failed.

Database command failed [CServer::ReplicateServer, 80040E14]: SQLServerAgent Error: Request to run job **SPAM**-avastent-policy_publication-AEACUS-1 (from User sa) refused because the job is already running from a request by Schedule 22 (Replication agent schedule.). 

Database command failed [CServer::ReplicateServer, 80040E14]: SQLServerAgent Error: Request to run job **SPAM**-avastent-policy_publication-apollo-3 (from User sa) refused because the job is already running from a request by Schedule 24 (Replication agent schedule.). 

Manual replications succeed, but scheduled replications fail.

Anyone?
« Last Edit: April 10, 2014, 03:42:20 PM by Peck4919 »

Offline Peck4919

  • Newbie
  • *
  • Posts: 3
Re: Multiple EAS Scheduled Database Replication Problem
« Reply #2 on: April 22, 2014, 03:38:34 PM »
Just in case anyone looks here.  To follow up, I believe this is a false failure indication.  Although the scheduled rep's continue to say that they have failed, there is no indication that the replication is not happening.  If I create a new job on one server, the next day all servers are aware of the change.  It appears as though everything is functioning correctly, despite the fact that the job indicates a failure.

Offline Max Marak

  • Avast team
  • Jr. Member
  • *
  • Posts: 39
Re: Multiple EAS Scheduled Database Replication Problem
« Reply #3 on: April 23, 2014, 04:11:33 PM »
Thanks for the info on this one!

Did this only happen with the one install? I'd be very interested to know if (and how) you can replicate it.