Author Topic: I can't turn on my Avast File System Shield  (Read 10578 times)

0 Members and 1 Guest are viewing this topic.

Offline wipeout

  • Newbie
  • *
  • Posts: 8
I can't turn on my Avast File System Shield
« on: April 05, 2014, 06:05:18 PM »
I have been using avast for years now and this is the first time something like this happened. I updated avast to newest version available (9.0.2016.330) and got exclamation mark at the avast taskbar icon...that referred to File System Shield not being active. When I tried to activate it, I got an error message saying; "The following components could not be started - File System Shield". In the settings menu I couldn't even click on to active it. (picture below) I've literally tried everything that I've read about this problem and nothing worked. I've tried reinstalling a fresh copy several times, but no results. Furthermore, I've tried with avast uninstaller program in safe mode, still no results... So, is there an alternative way to fix this ?

I appreciate any help...thanks everyone.

BTW: I'm using a Free version of Avast !
« Last Edit: April 05, 2014, 06:09:36 PM by wipeout »

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6712
  • Trust only what you test yourself!
Re: I can't turn on my Avast File System Shield
« Reply #1 on: April 05, 2014, 06:15:40 PM »
Have you tried a repair?

Control Panel>Uninstall a Program>double click "avast">click "repair">reboot
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #2 on: April 05, 2014, 06:16:45 PM »
First try a repair of avast.
If that fails perform a real clean install.
Instructions can be found in many other threads on this webboard.

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #3 on: April 05, 2014, 07:57:46 PM »
Yes, I forgot to mention that I've tried the repair... I've also tried reinstalling software several times...but every time the same problem, file system shield not working.

Thanks for the reply, if you have some other idea how to fix this, please let me know.

Offline Para-Noid

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6712
  • Trust only what you test yourself!
Re: I can't turn on my Avast File System Shield
« Reply #4 on: April 05, 2014, 08:09:19 PM »
Have you tried to reboot then reboot again?
Sometimes it may take repeated reboots.
Don't know why...it just does.
Dell Inspiron, Win10x64--HP Envy Win10x64--Both systems Avast Free v17.9.2322, Comodo Firewall v8.2 w/D+, MalwareBytes v3.0, OpenDNS, Super Anti-Spyware, Spyware Blaster, MCShield, Unchecky, Vivaldi Browser and, various browser security tools.

"Look before you leap!" Use online scanners before you click on any link.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #5 on: April 06, 2014, 08:28:58 AM »
Did you use the online installer or the complete downloaded package when performing the clean install ?

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #6 on: April 06, 2014, 11:36:00 AM »
I've installed it by complete download package...but I don't know whether there is the package for online installation available ...? I even tried installing older versions of program that worked before, but now even them appear with the same problem (older versions of avast 9).

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #7 on: April 06, 2014, 11:44:05 AM »
1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition.
Here are the installer links. Note: You need to be ONLINE during this install.
http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

2. Uninstall Avast by control panel  [If you don't have Avast in control Panel go to #4]
3. Uninstall in Safe Mode using Avastclear.
http://www.avast.com/uninstall-utility
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
http://rejzor.wordpress.com/avast-cleanup-tool/
5. Be Sure Too Check Once Uninstall is Complete:Device Manager>View>Show Hidden Devices
If there is anything related to Avast with a yellow triangle then uninstall it (highlight, right click) and reboot.
6. Install the version you downloaded.
7. Reboot.

offline installers:
http://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup.exe
http://files.avast.com/iavs9x/avast_internet_security_setup.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup.exe

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #8 on: April 06, 2014, 09:22:03 PM »
So, I've done everything as you wrote, step by step...installed using online installer, but the file system shield still appears not to be working again. Anyway, I noticed that when installing older avast versions, exclamation mark does not appear, even though the file system shield is not active nor can be turned on. It all looks like avast file system shield *.dll file is missing or something...do you maybe know if there is such file in avast folder ? I've checked every single .dll file's description in the folder and none of them says File System Shield, while there are *.dll's for both web and mail shields...I will put the pictures of what avast folder contains below, in case you know what could be missing...

Thank you very much for your time and help...I appreciate it a lot.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #9 on: April 06, 2014, 09:48:01 PM »
What OS/SP?
Is/was there any other anti-malware software on the system?
And please follow the instructions and attach the logs.
http://forum.avast.com/index.php?topic=53253.0

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #10 on: April 07, 2014, 12:37:16 PM »
I'm on Windows XP Professional, service pack 2. I have malwarebytes installed on my computer, but I only run it occasionally, when scanning individual files...anyway, I really doubt that a virus is causing this...but I just can't figure out what exactly happened to avast, everyone else who had the same problem solved it by just reinstalling the program..hmm.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #11 on: April 07, 2014, 12:49:57 PM »
First thing you need to do is installing SP3 and ALL (security) updates released after that.

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #12 on: April 07, 2014, 05:56:24 PM »
Ok, I've installed SP3 with all the updates. Should I try to reinstall now ?

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: I can't turn on my Avast File System Shield
« Reply #13 on: April 07, 2014, 06:02:28 PM »
Yes, please do the clean install again.
I know it is a bit of work, but it will prevent some problems.
If the problem persists, follow the instructions ( http://forum.avast.com/index.php?topic=53253.0 ) and attach the logs in your next post.

Offline wipeout

  • Newbie
  • *
  • Posts: 8
Re: I can't turn on my Avast File System Shield
« Reply #14 on: April 14, 2014, 10:41:32 AM »
Re-installation on SP3 did not solve the problem. Sorry, but can you please explain me what exactly I need to do ? Do I need to scan the whole system with malwarebytes and then copy the log at the end of it, or is it something else ?

By the way, I can perform boot time scan with avast, but I don't know where can I find logs once it's finished.