Author Topic: AIS is changing my active network profile in windows 7  (Read 20948 times)

0 Members and 1 Guest are viewing this topic.

MacGeyer

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #15 on: April 30, 2014, 03:19:43 PM »
Same problem for me, should be fix quickly by Avast

Raphael

kaidai

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #16 on: April 30, 2014, 06:16:37 PM »
Use avast 9.0.2016.330 can temporarily and occationally fix 2 of my machines, but not the third. :(

Or setup an packet rule:
TCP In 77.234.41.0-77.234.47.255
and restart the computer.
But this trick does not always work.

MacGeyer

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #17 on: May 02, 2014, 09:38:18 AM »
Hi,

I can and want use any trick, AIS is used by lots of pro customers it simply has to work correctly !
In windows the network is detected as public, the share and lot's of things aren't setup correctly.
I shouldn't have to care if it is a bug of Windows or Avast, without Avast it is working and with Avast installed customers have problems.

Regards,

Raphael

Al Simer

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #18 on: May 02, 2014, 02:41:56 PM »
Same problem here. AIS changed my home network to "Open" and has caused the homegroup feature to fail. I realized this was happening yesterday when I needed to simulate a networking problem that a friend was having and I realized that my homegroup had stopped working. I have been recommending Avast for over 4 years now and have never had a problem. Please fix this. I was going to purchase the 3 PC product for a family member today but I think I will install the free version for now.

Malacath

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #19 on: May 03, 2014, 05:58:27 PM »
Same thing is happening here.

I can't use homegroups because of this.

When is Avast going to fix this?


Yamash

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #20 on: May 03, 2014, 09:27:09 PM »
Hi,

I can and want use any trick, AIS is used by lots of pro customers it simply has to work correctly !
In windows the network is detected as public, the share and lot's of things aren't setup correctly.
I shouldn't have to care if it is a bug of Windows or Avast, without Avast it is working and with Avast installed customers have problems.

Regards,

Raphael

I agree with you.

I'm waiting for a reasonable reply and a fix for this issue.

panchalshp

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #21 on: May 03, 2014, 11:32:52 PM »
I filed a ticket after 3-4 trials they have solution.
But i am not satisfied with that.
The solution is as follows

You can try to turn off the avast! self-defense module by following these steps:
go to: avast! > Settings > Troubleshooting > uncheck 'Enable avast! self-defense module' > OK

This setting let me do what i want but if i have to turn off some features of avast which makes my pc vulnerable, in that case why should i pay to avast?


GTX66

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #22 on: May 04, 2014, 03:09:59 AM »
If you are using AIS . Why do you have the Window's firewall turned on?

kaidai

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #23 on: May 04, 2014, 09:40:05 AM »
If you are using AIS . Why do you have the Window's firewall turned on?

Windows Firewall is the affected component, not the cause of this bug.
Even Windows Firewall is completely turned off (it is disabled in all the 3 profiles), the bug is still there.

Malacath

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #24 on: May 04, 2014, 12:51:41 PM »
Windows Firewall is disabled for me also on both my Windows 7 machines.

This is actually a serious bug in Avast. It is also a major security hole.

In order to allow media streaming to my xbox and other devices I have to switch on file and media sharing for public networks.

This is not safe.

Avast is supposed to secure my computers but in fact it creates a major security hole by forcibly switching my systems network profile to public and forcing me to enable sharing on public networks.

So come on AVAST and acknowledge and fix the major security hole avast creates.

GTX66

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #25 on: May 04, 2014, 02:32:49 PM »
Well this need to be fixed for those that are affected by it.

Malacath

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #26 on: May 04, 2014, 03:16:57 PM »
Just to add. This bug only seems to effect Windows 7.

My Windows 8.1 machine has no problems with homegroups with avast premier.

It's my two Windows 7 machines that break when premier is installed.

I've just uninstalled Avast on one of my Windows 7 machines and homegroups now work fine also the advanced sharing settings have switched back to 'Home'

I have now just installed Avast free edition and homegroups still works. It looks like it's definitely the Firewall component on Avast Premier(and Internet security) that breaks everthing.

darkhalf

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #27 on: May 12, 2014, 12:43:18 PM »
Hey guys I've raised a ticket on this issue since it has been affecting me for the last few weeks and many hours of research and uinstalling/reinstalling etc. Windows 7 Pro was affected. Windows 8.1 changed itself to public (but was able to change it back at least inside Avast)

Version occurred since 2014.9.0.2016 and is still existant in 2018 too

I only was able to get my network profile back after uninstalling Avast. The only way to see the current set profile

Network and Sharing Centre > Change Advanced sharing settings > Private/Public will show as (current Profile) which does not match what you see under 'View your basic network information' making the problem very difficult to find

From Avast support after raising my ticket:
Quote
We have found a bug in our program. It will repaired it in next avast release. Now, your customers should disable avast SelfDefence in program there: Settings / Troubleshooting / untick "Enable avast! self-defense module"

Offline justinlee

  • Poster
  • *
  • Posts: 400
Re: AIS is changing my active network profile in windows 7
« Reply #28 on: May 12, 2014, 08:24:46 PM »
First thing i notice is that you are using AIS and have Windows firewall ON. Try using the Firewall built into AIS and turn Windows Firewall OFF. There is probably some conflict.
Windows 7 Home Premium (64-bit) SP1,
Intel Core i5-2410M @2.30GHz, 6GB RAM
AvastFree Antivirus & ZoneAlarm Free.

Malacath

  • Guest
Re: AIS is changing my active network profile in windows 7
« Reply #29 on: May 12, 2014, 08:33:23 PM »
No Windows Firewall is off.

But avast still changes the profile to Public which breaks homegroups