Author Topic: New Avast! Not Installing on Windows Server 2012 R2 Essentials  (Read 14437 times)

0 Members and 1 Guest are viewing this topic.

jdfrench3

  • Guest
Re: New Avast! Not Installing on Windows Server 2012 R2 Essentials
« Reply #15 on: May 20, 2014, 12:10:52 AM »
That defeats the need to have Avast! actually fix the problem. Windows Server 2012 R2 Essentials installs with a locked-down version of IE. Avast! needs to fix the Small Office Administrator program to work with IE on the Server. Even the latest version of SOA (1.3.3.42) doesn't work with the Server IE.

However from a client machine, the SOA on the Server works fine, using the client's IE.

nannunannu

  • Guest
Re: New Avast! Not Installing on Windows Server 2012 R2 Essentials
« Reply #16 on: May 20, 2014, 01:34:14 AM »
That defeats the need to have Avast! actually fix the problem. Windows Server 2012 R2 Essentials installs with a locked-down version of IE. Avast! needs to fix the Small Office Administrator program to work with IE on the Server. Even the latest version of SOA (1.3.3.42) doesn't work with the Server IE.

However from a client machine, the SOA on the Server works fine, using the client's IE.

Honestly, coming from someone who is seriously in the "don't point fingers at the other guy, just fix your stuff" camp with respect to software vendors, I think in this case you may be asking for more than you should. 

If I understand correctly, you are complaining about IE Enhanced security mode, which has been on by default for ...  a while...  It is also trivial to turn it off for administrators, while leaving it on for non-privileged users (should you have any with local login rights for your server)...  No direct experience with the Essentials flavor, but it appears to be the same as other versions of server 2012 and 2012R2 according to a quick search:

http://oxfordsbsguy.com/2012/12/03/how-to-disable-ie-enhanced-security-configuration-in-windows-server-2012-essentials/

When you look at what IE ESC is, it makes sense that some web applications will not run while it is enabled...  I'm still glad that it is the shipping default from Microsoft, but I also understand that it isn't a magic bullet.

So disable IE ESC, or as you've pointed out, there is no reason why you need to run it from the console of the server.  Any admin workstation can open the URL just fine.  So...  Why are we having this conversation?

jdfrench3

  • Guest
Re: New Avast! Not Installing on Windows Server 2012 R2 Essentials
« Reply #17 on: May 20, 2014, 11:05:31 AM »
I have disabled IE ESC. Avast! SOA still will not display on the Windows Server 2012 R2 IE browser.

nannunannu

  • Guest
Re: New Avast! Not Installing on Windows Server 2012 R2 Essentials
« Reply #18 on: May 20, 2014, 03:28:42 PM »
I have disabled IE ESC. Avast! SOA still will not display on the Windows Server 2012 R2 IE browser.

Have you installed silverlight?

jdfrench3

  • Guest
Re: New Avast! Not Installing on Windows Server 2012 R2 Essentials
« Reply #19 on: May 22, 2014, 11:22:30 AM »
Silverlight is installed.......