Author Topic: Wont boot after Avast install  (Read 5574 times)

0 Members and 1 Guest are viewing this topic.

Offline petejdesign

  • Newbie
  • *
  • Posts: 3
Wont boot after Avast install
« on: July 01, 2014, 05:36:30 PM »
I know this has been covered all over the place, but after extensive searching I have not been able to find a solution or a thread where someone has confirmed a fix and I am getting extremely frustrated. The macbook had no startup issues prior to installing Avast, and now ever since the install and one scan it wont boot up. I cant get it into safe mode and right now the only thing I can get to is single user mode where I have tried a number of command lines suggested to uninstall Avast with no success, just the same "file or directory not found" error.

Has there been any progress in figuring out this issue or is there a compiled list of commands to try to type in to get this thing uninstalled?? Thanks!

Offline garethanderson

  • Newbie
  • *
  • Posts: 1
Re: Wont boot after Avast install
« Reply #1 on: July 20, 2014, 09:13:59 PM »
I am having exactly the same problem. After 3 years of flawless service, I installed Avast last night and it has killed my mac. I have tried the thread contents so far and none work.

I can ONLY get to Single User Mode and nothing else. Avast has ruined my mac.

Please how do I uninstall this via SUM because none of the suggestions so far work.


Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: Wont boot after Avast install
« Reply #2 on: July 20, 2014, 10:11:51 PM »
AFAIK, this is the command for command line uninstall of version 9:

Code: [Select]
sudo sh /Library/Application\ Support/Avast/components/uninstall/com.avast.uninstall.app/Contents/MacOS/uninstall.sh
« Last Edit: July 20, 2014, 10:14:12 PM by specimen9999 »

Offline macncheese

  • Newbie
  • *
  • Posts: 1
Re: Wont boot after Avast install
« Reply #3 on: July 21, 2014, 04:59:43 AM »
when  I attempt to go to single user or safe mode (Shift-Command-V, and/or Shift) it starts up in that mode, then
final words on the screen are CPU halted then system powers down. 
This is my Daughter's new (used) Macbook Pro - was trying to help her by having her load Avast and this happens!
I'm a PC person - so really unfamiliar with Macs .  Please help and I appreciate the most elementary instructions as I have no idea what to do

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5203
Re: Wont boot after Avast install
« Reply #4 on: July 21, 2014, 09:56:27 AM »
Go into your Library as stated earlier and try that.

If this fails, install AppCleaner (3rd party app that gets rid of remnants...like Revo Uninstaller for PC's).  In Macs, you can't just drag and drop into the trash.  Once you download and install AppCleaner, drag from Applications Avast into over the AppCleaner icon, which I suggest you put on your desktop.  A window will open up that will contain all registries and everything related to what you want to delete.  Click on delete and it's gone into your trash bin.

They now make CCleaner for Macs, and I recommend it to thoroughly delete items since the Apple trash removal is not as thorough.  It takes longer, but it's worth it and decrypts it.

I've used AppCleaner for getting rid of other software and it's recommended by other devs., and best of all, it's free.  :)  I'm not sure Avast recommends it, but it works for stubborn software that you can't remove.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: Wont boot after Avast install
« Reply #5 on: July 21, 2014, 06:03:51 PM »
when  I attempt to go to single user or safe mode (Shift-Command-V, and/or Shift) it starts up in that mode, then
final words on the screen are CPU halted then system powers down. 
This is my Daughter's new (used) Macbook Pro - was trying to help her by having her load Avast and this happens!
I'm a PC person - so really unfamiliar with Macs .  Please help and I appreciate the most elementary instructions as I have no idea what to do

This sounds like a much more serious issue you should contact an Apple Certified technician.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5203
Re: Wont boot after Avast install
« Reply #6 on: July 22, 2014, 11:40:00 AM »
This sounds like a much more serious issue you should contact an Apple Certified technician.

They are going to tell you that if it's a 3rd party app. they want nothing to do with it, but it can't hurt.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: Wont boot after Avast install
« Reply #7 on: July 22, 2014, 01:04:26 PM »
This sounds like a much more serious issue you should contact an Apple Certified technician.

They are going to tell you that if it's a 3rd party app. they want nothing to do with it, but it can't hurt.

Actually, it's not clear that the culprit is Avast!, CPU halted might be an hardware issue, or it has to do with a very borked booting environment, in that case, important files can be retrieved using Target Disk Mode and complete new OSX install.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5203
Re: Wont boot after Avast install
« Reply #8 on: July 23, 2014, 08:34:41 AM »
Actually, it's not clear that the culprit is Avast!, CPU halted might be an hardware issue

Do you make external back-ups besides using Time Machine?  I would suggest it.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline specimen9999

  • Sr. Member
  • ****
  • Posts: 349
Re: Wont boot after Avast install
« Reply #9 on: July 23, 2014, 01:46:31 PM »
Actually, it's not clear that the culprit is Avast!, CPU halted might be an hardware issue

Do you make external back-ups besides using Time Machine?  I would suggest it.

You are quoting me so it's not obvious if the question is directed at me or pete and gareth?

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5203
Re: Wont boot after Avast install
« Reply #10 on: July 24, 2014, 09:07:20 AM »
It's directed at Pete, the OP.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.