Author Topic: The avast service is off.  (Read 6889 times)

0 Members and 1 Guest are viewing this topic.

Offline amr.jamal

  • Newbie
  • *
  • Posts: 1
The avast service is off.
« on: July 11, 2014, 01:37:17 AM »
my avast free antivirus tells me that " You Are Not Protected " and that " the avast service is off "
there is button nest to it named " Start " / "Resolve all " but when i click it it won't do anything...
any help ??

Offline DJBone

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6345
Re: The avast service is off.
« Reply #1 on: July 11, 2014, 01:42:18 AM »
Hello and welcome to the Forum! :)

Repair avast!:
1. Control Panel -> Programs & Features -> avast!
2. Click on 'Repair'.
3. Follow instructions.
4. Reboot.

DJBone
Win10 x64, APS (always latest version)
Avast Mobile Security (always latest version)

Offline HerryCZ

  • Newbie
  • *
  • Posts: 11
Re: The avast service is off.
« Reply #2 on: July 14, 2014, 01:04:17 PM »
Hi,

I have the same problem. After update to last version and after 2 restarts I can see that service down. After that I try to switch service to run (via Avast GUI then via Windows Services). Only few seconds is on and again fall down. I try do Repair Avast and still the same. Then I uninstall it and now I can't install back due Avast problems with proxy (other traffic is without problems only Avast can't download install files).

Now I can't find offline instalator and run without AV.
My NB is with Windows XP professional SP3 without Active Directory and I have administrator rights.

Have you any suggestions how to resolve it.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: The avast service is off.
« Reply #3 on: July 14, 2014, 01:08:08 PM »
- Which avast!..?? (Free/Pro/IS/Premier)
- Which version..??
- Other security related software installed..??
- Which AV(s) did you use before avast!..??
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HerryCZ

  • Newbie
  • *
  • Posts: 11
Re: The avast service is off.
« Reply #4 on: July 14, 2014, 02:18:17 PM »
Ohh sorry

Avast Free 2014
Another security SW which I use is Spy-Bot and Comodo Firewall
No other AV wasn't use on this computer.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: The avast service is off.
« Reply #5 on: July 14, 2014, 02:22:02 PM »
First, drop Spybot..!!

Then:
1. Download avast! Free Antivirus: http://files.avast.com/iavs9x/avast_free_antivirus_setup.exe
2. Follow instructions: http://www.avast.com/uninstall-utility (Run this tool for all prior installed avast! versions..!!)
3. Reinstall avast! with the downloaded installer from point 1.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HerryCZ

  • Newbie
  • *
  • Posts: 11
Re: The avast service is off.
« Reply #6 on: July 14, 2014, 10:06:04 PM »
OK, I try It, but I have questions.

Spy Bot is bad or it's only for just a precaution.
And when I try use avastcleaner I haven't anythink to clear, avast was unistalled normaly by classic uninstaler.

Now it's look like that is OK.


Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5420
  • Spartan Warrior
Re: The avast service is off.
« Reply #7 on: July 14, 2014, 10:43:55 PM »
OK, I try It, but I have questions.

Spy Bot is bad or it's only for just a precaution.
And when I try use avastcleaner I haven't anythink to clear, avast was unistalled normaly by classic uninstaler.

Now it's look like that is OK.
Spy Bot is obsolete and ineffective for what you need it to do.  Use Malwarebytes Free instead.  See this page for a direct download link to the latest version:  http://www.malwarebytes.org/products/

Is classic uninstaller a non-Windows uninstaller?  That is, is it a third-party program you installed on your system?
Windows 10 Home 64-bit 20H2 Avast Premier Security version 21.3.2459 (build 21.3.6164.652) UI version 1.0.612.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67250
Re: The avast service is off.
« Reply #8 on: July 15, 2014, 03:16:49 AM »
SpyBot? Hmmm... Obsolete...
The best things in life are free.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71213
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: The avast service is off.
« Reply #9 on: July 15, 2014, 07:31:17 AM »
Spy Bot is bad or it's only for just a precaution.
Both.
Win 8.1 [x64] - Avast PremSec 21.7.6459.IBC [UI.658] - EEK - Firefox ESR 78.12 [NS/uBO/PB] - TB 78.12
Avast-Tools: Secure Browser 92.0 - Cleanup 21.2 - SecureLine 5.12 - Driver Updater 21.2 - CCleaner 5.83
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline HerryCZ

  • Newbie
  • *
  • Posts: 11
Re: The avast service is off.
« Reply #10 on: July 16, 2014, 07:55:19 AM »
Yesterday again service fall down and again I can't run avast service. Sorry but I haven't time to repairing this issue. Now I install AVG.

Offline Corleth

  • Newbie
  • *
  • Posts: 4
Re: The avast service is off.
« Reply #11 on: August 07, 2014, 12:11:49 PM »
I have the very same problem. The root of all this is when one is behind a proxy - the original parts of avast work fine with proxy, but the stuff which is being added in the latest versions (including registration) is obviously programmed by less competent people who don't make it proxy compatible.

In the couple of past versions I experienced the same thing after upgrade - the service started but crashed later. I had to enable direct connection on my proxy to make the the upgrade/reinstall process work. Once I registered the key, I was able to reenable the proxy and the service kept working fine, and worked fine after reboot.

Unfortunately, now when I updated from 2018 to 2021, this workaround doesn't work anymore. I was hoping they might have fixed it, so I didn't disable the proxy first before update. The update didn't finish properly, I got exception violation in instup.exe after reboot (completely lame programming if you ask me). The service didn't work at all. So I did uninstall/install with proxy disabled, but for some reason it wiped out my registration/settings completely. Upset, I did system restore to 2018 , but that ended completely messed up, the avast UI got stuck in a loop crashing with an exception. So I uninstalled it and installed pre-2018 version again, this time it fortunately remembered my registration and settings, then I upgraded to 2021 with proxy disabled, it finished fine, and kept all the settings and even worked after reboot. But as soon I enable the proxy and reboot, the avast service crashes every time. It runs for a while whenever I try to start it, but then crashes again. So I am now about to rollback to older version and never update again unless they fix it.

I searched the internet regarding this but only found posts recommending reinstalling the avast ad nausea, eventually running special cleanup programs in between, and blaming other programs for the problem. Obviously the company refuses to see that the problem stems from their own incomplete proxy support. I doubt their QA ever tried that, because it is so trivial to reproduce that they couldn't miss it otherwise.

Ironic thing is, when I tried to fill the bug report from within avast when this happened for the first time, that didn't work at all - I had to turn the proxy off again to make it work at all. Which means that normal people who are having this problem are unable to report it at all. I reported that as well, but I am loosing my faith that the company cares at all...




Offline Corleth

  • Newbie
  • *
  • Posts: 4
Re: The avast service is off.
« Reply #12 on: August 07, 2014, 02:34:27 PM »
So I am now about to rollback to older version and never update again unless they fix it.

Grmph, I was unable to roll back because whenever I now uninstall avast, it wipes out my settings, and when I install the old version, it immediately automatically updates to the latest 2021 version.

So I gave up, did system rollback to 2021 version with my latest registration/settings, and checked what IP addresses avast needs open to phone home to get the service working. It turns out that even with the proxy setting enabled, it tries to connect to IPs in these ranges directly:

195.39.12.0/24      (r-X-12-30-195.avast.com)
159.253.143.0/24  (aXYZvg.avast.com)
77.234.40.0/21      (r-X-Y-234-77.ff.avast.com)

When it can't connect to (some of?) these, the service stops working. (BTW, accessing the support/feedback page from avast UI requires direct access yet another range to work at all, but that doesn't bother me that much.)

So I added exception rules to allow direct connection to these machines to make it work for now. Once added, the service is finally able to start.

But I hope someone from the avast dev team will finally realize there is a problem on their side and get this fixed. Program which doesn't work properly or even crashes just because it can't phone home feels pretty lame, doesn't it? And if you can't get even the elementary networking right, how is your product to be trusted?

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45693
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: The avast service is off.
« Reply #13 on: August 07, 2014, 03:40:36 PM »
Streaming updates requires Internet access to various servers.
I happen to trust my AV otherwise I wouldn't have installed it in the first place.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, AvastOmni 21.6, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: The avast service is off.
« Reply #14 on: August 08, 2014, 09:43:09 AM »
avast was unistalled normaly by classic uninstaler.

Does that mean you used the Avast Uninstaller Tool in Safe Mode?  Otherwise this could be causing problems by leaving remnants and installing any other AV will create more problems.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.