Author Topic: Fully silent, network install?  (Read 5834 times)

0 Members and 1 Guest are viewing this topic.

Offline ICSIT

  • Newbie
  • *
  • Posts: 6
Fully silent, network install?
« on: July 17, 2014, 12:14:55 AM »
Our school is new to Avast and is in the process of configuring the remote installation process to deploy the Avast Endpoint Protection Plus product onto our Win7 x64 machines.
I've got the Enterprise Admin server up and running on a Win2k12r2 box

We have hundreds of systems so we're trying to automate the process as much as possible (As with all our software).

Creating the custom installation package has thus far seemed pretty straight forward, except for one piece-

How do we keep the flippin' thing from TALKING after install??  I've found where to modify the settings from EAC /Group settings, but those settings don't seem to apply until the client has made contact with the server.  That means this ridiculous "talking" business happens EVERY TIME we do a fresh install.

I'm assuming I'm just missing something - for product billed as being for Business/Edu/Enterprise, I can't image there's a whole lot of love for talking software - image that craziness in a University lab when everyone logs on for the first time after an install...
« Last Edit: July 21, 2014, 08:25:08 PM by ICSIT »

Offline Ethan C.

  • Newbie
  • *
  • Posts: 9
Re: Fully silent, network install?
« Reply #1 on: July 18, 2014, 08:09:21 AM »
I had the same problem. I put the following into the custom ini settings and it stopped.

Code: [Select]
[Common]
SoundsEnabled=0

Offline ICSIT

  • Newbie
  • *
  • Posts: 6
Re: Fully silent, network install?
« Reply #2 on: July 21, 2014, 08:23:49 PM »
I had the same problem. I put the following into the custom ini settings and it stopped.

Code: [Select]
[Common]
SoundsEnabled=0

Thanks I'm clearly missing something then.  Where do I find the custom.ini file?  I'm using the EAC to customize the install/deployment. I'm not seeing reference to it in the documents I have.

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #3 on: July 21, 2014, 10:08:09 PM »
If you are using EAC to configure and download client and you want a silent install, you need to right click Computer library > Properties > Policies > Silent/Gaming Mode.  Check both Silent /Gaming mode and Silent when Full screen app is running.  Then click on Sounds and uncheck Enable Avast! sounds.

Offline ICSIT

  • Newbie
  • *
  • Posts: 6
Re: Fully silent, network install?
« Reply #4 on: July 21, 2014, 11:27:15 PM »
If you are using EAC to configure and download client and you want a silent install, you need to right click Computer library > Properties > Policies > Silent/Gaming Mode.  Check both Silent /Gaming mode and Silent when Full screen app is running.  Then click on Sounds and uncheck Enable Avast! sounds.

I've already configured the remote policy this way - I've checked both boxes found in the "Silent/Gaming" mode screen.
They seem to work once the machine connects to the server and retrieves the policy, but the Sounds happen BEFORE that takes place - immediately after the silent install completes and the next user logs in.

Am I missing somthing?

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #5 on: July 22, 2014, 08:28:30 AM »
And you've unchecked "Enable Sounds"?

Offline ICSIT

  • Newbie
  • *
  • Posts: 6
Re: Fully silent, network install?
« Reply #6 on: July 22, 2014, 03:37:17 PM »
Ok, clarification -

I talked with my Helpdesk and got more specific information.

It turns out we're not using the EAC to push the installs.  We're pushing it via our regular software deployment method. 

The reason for this, I'm told, is that in order for the Avast server to push the install, we need "file and printer sharing" enabled on all of our workstations.  Is that correct?  I find that hard to believe - and hard to beleive that would again be acceptable in any secure IT environment.

So I guess my question is 2-fold

1) IS "File and Print Sharing Enabled" a requirement to use EAC fully? (Worth noting that it doesn't seem to mention that in any "requirements" document I've read"

2) If not, how do I configure/customize the client for pushing out via 3rd party and still have it reporting to our local server for updates/upgrades/reports/and additional configuration settings?

Thanks so much!

(PS - I have inquired with avast asking how I can go about paying for support, but haven't gotten an answer back in over a week now...)

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #7 on: July 22, 2014, 09:53:25 PM »
1.  Installation Guide to AEA + Endpoint Protection Suite >  https://forum.avast.com/index.php?topic=110470.msg868790#msg868790.

See helpful hints at bottom.  Excerpt after item 10 in hints: "NOTE: When you are deploying, Enable the Admin Shares. Windows XP systems should have File/Printer sharing DISABLED. Windows 7/Vista systems should have File/Printer sharing ENABLED".

And I will add, Network Discovery should be turn on.

2.  Can't help with deployment outside Avast! - Sorry.

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #8 on: July 22, 2014, 10:17:17 PM »
Also - Forgot to add this  (also from the installation guide helpful hints):  NOTE: Windows File and Printer Sharing must be enabled so avast! can create the necessary directories!  ALSO, all systems need to be rebooted after installation, so plan accordingly!

Offline ICSIT

  • Newbie
  • *
  • Posts: 6
Re: Fully silent, network install?
« Reply #9 on: July 22, 2014, 10:31:29 PM »
1.  Installation Guide to AEA + Endpoint Protection Suite >  https://forum.avast.com/index.php?topic=110470.msg868790#msg868790.

See helpful hints at bottom.  Excerpt after item 10 in hints: "NOTE: When you are deploying, Enable the Admin Shares. Windows XP systems should have File/Printer sharing DISABLED. Windows 7/Vista systems should have File/Printer sharing ENABLED".

And I will add, Network Discovery should be turn on.

2.  Can't help with deployment outside Avast! - Sorry.

That's really unfortunate about the File/Print share (and network discovery!)  Sticking it in a forum post under "helpful hints" rather than in a proper "system requirements" document is some lousy stuff.

Our entire systems management device can push out and update all sorts of software (as did our previous AV solution) without having to enable such things.  I can't imagine (aside from lousy programming) why this software would rely on such services.

And without any better documentation, I'm not even sure if it's possible to do a customized install but still use EAC to handle updates/upgrades (without the need for opening up all of our systems to the risky and otherwise completely unnecessary services that come with File and Printer sharing and Network discovery)

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #10 on: July 23, 2014, 08:44:15 PM »
Agree.

Offline murpmic

  • Newbie
  • *
  • Posts: 2
Re: Fully silent, network install?
« Reply #11 on: July 25, 2014, 12:08:20 AM »
I agree as well.  This is catered to those who use MS products heavily.  We use Suse Linux with Zenworks.  I could push a package nicely if I could figure out the command line switches to get this installed silently while talking to the AEA server.  I've got much of it but I can't get it to talk to the right server other than doing manual installs.  Once that is done then all is well.  BUt that means I have to touch thousands of devices.  This isn't good.  What is the command line for defining the EA Client setting during an install?

Offline drwebler

  • Newbie
  • *
  • Posts: 14
Re: Fully silent, network install?
« Reply #12 on: July 25, 2014, 09:19:59 PM »
Review the following discussion reference and see if that helps.
https://forum.avast.com/index.php?topic=84168.0
« Last Edit: July 25, 2014, 09:41:48 PM by drwebler »