Author Topic: Problema virus  (Read 6654 times)

0 Members and 1 Guest are viewing this topic.

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Problema virus
« on: July 27, 2014, 04:23:01 PM »
Salve a tutti,
dopo aver eseguito la scansione completa è stato trovato un virus trojan. Il problema è che risulta che il file sia di sola lettura e quindi non riesco ad eliminarlo/spostarlo e di conseguenza ad ogni scansione successiva il file compromesso risulta sempre nel computer.
Consigli?

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema virus
« Reply #1 on: July 28, 2014, 08:15:53 AM »
Ciao e benvenuto,
hai già provato ad eseguire una scansione all'avvio?
Di che file si tratta? Dove si trova?
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #2 on: July 28, 2014, 12:39:59 PM »
Il file si trova in C:\\Windows\SysWOW64\install\svchost.exe e quindi immagino sia un eseguibile se è un .exe
Il messaggio nello stato del file è" Minaccia: Win32: Trojan-gen"
« Last Edit: July 28, 2014, 01:17:50 PM by jef_97 »

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema virus
« Reply #3 on: July 28, 2014, 02:08:49 PM »
Prima di fare altro testa il file qui
https://www.virustotal.com/
e posta il link

ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #4 on: July 29, 2014, 02:12:39 PM »
Avrei un piccolo problema.. dopo C:\\Windows\SysWOW64 dovrei trovare la cartella install, ma non c'è. Come trovo il file?

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema virus
« Reply #5 on: July 29, 2014, 04:18:33 PM »
abilita la visualizzazione dei file nascosti e di sistema
http://aranzulla.tecnologia.virgilio.it/come-visualizzare-file-nascosti-su-windows-7-14694.html
oppure digita nella barra degli indirizzi di windows
C:\Windows\SysWOW64\install\

ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #6 on: August 09, 2014, 07:45:47 PM »
se abilito la visualizzazione dei file nascosti la cartella che sto cercando non appare, mentre se eseguo C:\Windows\SysWOW64\install\ la cartella risulta vuota. Dovrei fare una scansione all'avvio?

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Problema virus
« Reply #7 on: August 10, 2014, 10:11:36 AM »
se abilito la visualizzazione dei file nascosti la cartella che sto cercando non appare, mentre se eseguo C:\Windows\SysWOW64\install\ la cartella risulta vuota. Dovrei fare una scansione all'avvio?
sei sicuro che il file infetto sia svchost.exe e non sia il processo che attiva l'infezione? perchè svchost.exe è un file di sistema ed è importante saperlo perchè si rischia di dare colpa ad un file piuttosto che ad un altro.
abilita anche la visualizzazione dei file di sistema (apri una qualsiasi cartella, strumenti<opz cartella>visualizzazione>imp avanzate)
(ma alla fine di tutto togli la visualizzazione dei file di sistema e dei file nascosti)

apri l'unità C e nella casellina cerca scrivi:  svchost.exe  [invio]
alla fine della ricerca potresti avere un elenco di questi file in posizioni diverse sul disco, scansionali con avast...

« Last Edit: August 10, 2014, 10:19:10 AM by Giony »
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #8 on: August 12, 2014, 01:43:15 PM »
se abilito la visualizzazione dei file nascosti la cartella che sto cercando non appare, mentre se eseguo C:\Windows\SysWOW64\install\ la cartella risulta vuota. Dovrei fare una scansione all'avvio?
sei sicuro che il file infetto sia svchost.exe e non sia il processo che attiva l'infezione? perchè svchost.exe è un file di sistema ed è importante saperlo perchè si rischia di dare colpa ad un file piuttosto che ad un altro.
abilita anche la visualizzazione dei file di sistema (apri una qualsiasi cartella, strumenti<opz cartella>visualizzazione>imp avanzate)
(ma alla fine di tutto togli la visualizzazione dei file di sistema e dei file nascosti)

apri l'unità C e nella casellina cerca scrivi:  svchost.exe  [invio]
alla fine della ricerca potresti avere un elenco di questi file in posizioni diverse sul disco, scansionali con avast...


Anche se rendo visibili i file di sistema nascosti la cartella che cerco non appare, mentre se cerco nell'unità C svchost.exe non appare alcun risultato. Ho provato anche con una scansione all'avvio e ha trovato dei file infetti, ma il solito file appare ancora a ogni scansione.
Inoltre oggi (non so quanto possa centrare con l'argomento) il mio puntatore ha totalmente cambiato aspetto senza che io facessi nulla:   
è diventato una fila verticale di circa 6 punti vicini tra loro. Ho risolto riavviando il computer dato che anche se provavo a cambiare il puntatore (cambia puntatori del mouse > puntatori) non succedeva nulla.

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Problema virus
« Reply #9 on: August 12, 2014, 04:14:00 PM »
e quindi quale sarebbe questo file infetto? il solito che hai già detto?


prova a scaricare HitmanPro e poi manda una scansione, meglio se sei connesso a internet così utilizza anche il cloud  http://www.surfright.nl/it/hitmanpro
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #10 on: August 12, 2014, 10:57:23 PM »
Si il file infetto è questo C:\\Windows\SysWOW64\install\svchost.exe
Per quanto riguarda HitmanPro non c'è pericolo che vada in conflitto con l'antivirus?

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Problema virus
« Reply #11 on: August 13, 2014, 05:22:59 PM »
serve per fare scansione ma non è  in real time sennò non te lo dicevo
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #12 on: August 15, 2014, 11:28:37 PM »
Ho trovato dei PUP e 2 riskware. Subito dopo ho anche fatto una scansione con avast e il solito file infetto viene rilevato.

Offline Giony

  • Poster
  • *
  • Posts: 598
Re: Problema virus
« Reply #13 on: August 16, 2014, 09:14:20 AM »
Ho trovato dei PUP e 2 riskware. Subito dopo ho anche fatto una scansione con avast e il solito file infetto viene rilevato.
nei risultati di hmp ha rilevato lo stesso file di avast?
alla fine della scansione con hmp hai fatto per pulire?


prova a fare una cosa: disattiva momentaneamente avast, apri un file nuovo di testo.txt e dentro copia e incollaci questo testo:
copy C:\\Windows\SysWOW64\install\svchost.exe c:\questo1.vir
copy C:\Windows\SysWOW64\install\svchost.exe c:\questo2.vir
poi salvalo e rinominalo aggiungendo alla fine del nome del file .bat poi facci un doppio click per avviarlo, poi vai a vedere in c:\ se trovi almeno uno dei due file questo1o2.vir, se si prova a farlo scansionare su virustotal
Windows 10 Pro x64  -  Avast Internet Security 2016.11.2.2254  -  Mbam  -  HitmanPro  -  Ccleaner  -  Chrome

Offline Ferefar

  • Jr. Member
  • **
  • Posts: 20
Re: Problema virus
« Reply #14 on: August 16, 2014, 11:29:01 PM »
Ho trovato dei PUP e 2 riskware. Subito dopo ho anche fatto una scansione con avast e il solito file infetto viene rilevato.
nei risultati di hmp ha rilevato lo stesso file di avast?
alla fine della scansione con hmp hai fatto per pulire?


prova a fare una cosa: disattiva momentaneamente avast, apri un file nuovo di testo.txt e dentro copia e incollaci questo testo:
copy C:\\Windows\SysWOW64\install\svchost.exe c:\questo1.vir
copy C:\Windows\SysWOW64\install\svchost.exe c:\questo2.vir
poi salvalo e rinominalo aggiungendo alla fine del nome del file .bat poi facci un doppio click per avviarlo, poi vai a vedere in c:\ se trovi almeno uno dei due file questo1o2.vir, se si prova a farlo scansionare su virustotal

No, non ha rilevato lo stesso file di avast.
Sì, ho eliminato i file corrotti.
Ho creato il file .bat come mi hai detto ma il problema è che se vado in C:\Windows\SysWOW64\ non trovo la cartella install, anche se ho attivato la visualizzazone dei file nascosti.