Author Topic: problems on start up  (Read 10566 times)

0 Members and 1 Guest are viewing this topic.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
problems on start up
« on: August 14, 2014, 04:26:05 AM »
Lately, when I start my computer I get "device driver software was not successfully installed" and it mentions the "avast! Firewall NDIS Filter Miniport". This never used to happen.

Should I be concerned about this? If so, what can I do about it? I have a paid version of Avast and it seems to be working well otherwise.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: problems on start up
« Reply #1 on: August 14, 2014, 08:13:06 AM »
Hi vincewillis and welcome to the forum.  :)

Have you made any recent changes to your machine that coincides with you getting this error message?  What is your OS and did this happen after a recent MS Update?  What version of Avast are you using?  Is you machine acting fine otherwise? 

Have you tried an Avast Repair? 
1. Control Panel > Add/Remove programs -> Avast
2. Click on Repair
3. Follow instructions
4. Reboot

Let us know how it goes.  Thank you.

Edited:  Additional content added.
« Last Edit: August 14, 2014, 09:02:22 AM by SafeSurf »
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #2 on: August 14, 2014, 09:46:24 AM »
Hi SafeSurf,

I'm using Windows 7. The Program version is 9.0.2021 and the Definitions version is 140813-1.

I haven't tried Avast Repair (I don't know where that is), my computer isn't having any problems with Avast otherwise that I know of.

I think it started after a MS update but I'm not positive about that. I recently added a digital camera program that included Quicktime (I deleted QT), that's about it. I deleted Google Chrome too but that didn't change anything.

I was just wondering if it's something I should be concerned about and if I could stop it from occurring.

OK, will do.

« Last Edit: August 14, 2014, 09:48:18 AM by vincewillis »

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: problems on start up
« Reply #3 on: August 14, 2014, 10:15:39 AM »
Question:  When you installed Avast, did you do a default install or custom install?  If was a default install, you most likely got Chrome installed with Avast.  So if you are re-installing Avast, do a Custom install and only click what you want (you can pick any browser you want afterwards).

Some other users have reported problems after doing the Windows MS Update, but with OS 8.1. You an do a search to see what they did, however they were not behind a proxy that I am aware of.

Let us know if the Repair works. 

You have scanned your machine for malware?  Thank you.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #4 on: August 15, 2014, 03:49:12 AM »
OK.

I tried Avast Repair but that didn't help, I still get a failed installation warning of "avast! Firewall NDIS Filter Miniport".

Next I did an Avast full scan which found 5 instances of "NSIS:Adware-OH, when I applied the Avast fix to them they were sent to the Chest. After this was done I still got the warning.

Lastly I did an Avast boot scan which apparently didn't find anything, Avast didn't mention any problems. After this was done I still got the warning.

I'm quite sure, when I installed Avast, it was the default install. I'm giving some thought to taking the computer to a tech store where I know they uninstall Avast when they check out a computer. Then I would reinstall the custom version, maybe that would solve the problem.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: problems on start up
« Reply #5 on: August 15, 2014, 09:21:24 AM »
This is the Avast Uninstaller Tool http://rejzor.wordpress.com/avast-cleanup-tool/ along with a special tool to get rid of remnants - use in Safe Mode then reboot.  Bringing it to a tech. they may not have the vendor's tool and may just scrub your HD.  I would first try the Uninstaller tool first, then do a Custom install.

It may also be a good idea for you to have Malwarebytes-Antimalware Premium (MBAM) on your machine for extra protection if Avast found adware.  MBAM is resident and works with Avast with no conflict and is good at detecting adware.  Most of us here use it.  Prior to you uninstalling Avast, scan the items in your Virus Chest to see if they are still infected or were a FP or not.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #6 on: August 16, 2014, 10:10:20 PM »
I installed Malwarebytes-Antimalware Premium, did a MBAM scan, and nothing showed up.

Using Avast, I scanned the 6 files in the Avast Virus Chest ( there was one more item in there than before - name: mediaplayer.exe, virus: WIN32:Adware-gen[Adw]) and the result each time was a little window popping up that said "Scan Complete" with the name of the file. I don't know the significance of this.

I'll remove and reinstall Avast later tonight and see if that fixes the driver problem. Thanks for your help.

Offline thekochs

  • Speak Your Mind, Who minds don't matter, Who matters won't mind
  • Advanced Poster
  • **
  • Posts: 1115
  • Hapkido Blackbelt
Re: problems on start up
« Reply #7 on: August 16, 2014, 10:58:57 PM »
Here is How-To on clean un-install and install.......take the few extra minutes and do these steps..........

Avast Clean Un- & Re-Install
1. Download Avastclear, Rejzors uninstall tool and the appropriate Avast program edition.
Avastclear : http://files.avast.com/iavs9x/avastclear.exe
Rejzors Uninstall tool: http://rejzor.wordpress.com/avast-cleanup-tool/

Here are the Avast installer links. Note: You need to be ONLINE during this install.
http://files.avast.com/iavs9x/avast_free_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_pro_antivirus_setup_online.exe
http://files.avast.com/iavs9x/avast_internet_security_setup_online.exe
http://files.avast.com/iavs9x/avast_premier_antivirus_setup_online.exe

......Now............
2. Uninstall Avast by Control Panel>Programs [If you don't have Avast in control Panel go to #4]
3. Run Avastclear in Normal Mode and allow it to Reboot PC into Safe Mode to complete the removal process.
4. Run Rejzors Uninstall Utility in Normal Mode (removes traces avastclear doesn't) - reboot.
5. Be Sure To Check PC's Device Manager....Control Panel>System Once Uninstall is Complete.
    Make sure to show any hidden devices by selecting pull-down menu Device Manager>View>Show Hidden Devices
If there is anything related to Avast with a yellow triangle then uninstall it (highlight, right click) and reboot.
If you get an error just right-click & delete.
6. Install the Avast version you downloaded.
7. Reboot.
OpenDNS + Avast Free + MBAM Premium + MBAE Free Anti-Exploit + CryptoPrevent + Windows Firewall
Avast FAQ Videos
Avast 2016 Videos
Avast Clean Un/Re-Install How-To

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: problems on start up
« Reply #8 on: August 18, 2014, 09:40:24 AM »
Sorry, I've been away (without Internet due to the weather) for a while, but I'm back.  How is your machine running now?  Any problems?  If so, please refer to the directions listed on this link: https://forum.avast.com/index.php?topic=53253.0 and follow the directions for posting the basic logs for:

- MBAM
- Farbar Recovery Scan
- aswMBE.exe

Please ATTACH them to your next log so that can be reviewed for malware.  Thank you.
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #9 on: August 19, 2014, 04:40:37 AM »
Sorry I couldn't get back to this sooner, I finally got it to stop.

First I uninstalled it through the control panel > programs, next I used avastclear.exe, then I used rejzor's tool, and then I used avastclear.exe and rejzor's tool again to finally make the failed "avast! Firewall NDIS Filter Miniport" warning stop.

Hopefully I'll reinstall Avast tomorrow, thanks for the help.

Offline SafeSurf

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5198
Re: problems on start up
« Reply #10 on: August 19, 2014, 06:31:47 AM »
I would suggest a Custom install so you only get what you want on the installation, then reboot.  After rebooting, then you can configure your settings and register.  I'm very happy you got this far!  :D
Mac 10.9.4 /Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Premium)/ Mobile MBAM.

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #11 on: August 22, 2014, 01:29:29 AM »
Well I reinstalled Avast Internet Security and got the same warning "device driver software was not successfully installed" and "avast! Firewall NDIS Filter Miniport" failed to install. So I guess I'll uninstall Avast and leave it off my computer if it's not installing properly.

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 45984
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: problems on start up
« Reply #12 on: August 22, 2014, 02:26:03 AM »
Well I reinstalled Avast Internet Security and got the same warning "device driver software was not successfully installed" and "avast! Firewall NDIS Filter Miniport" failed to install. So I guess I'll uninstall Avast and leave it off my computer if it's not installing properly.
Did you do a full uninstall including using the avast! cleaner:
http://files.avast.com/iavs9x/avast_clear.exe
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, AvastOmni 21.6, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11134
  • No support PM's thanks
Re: problems on start up
« Reply #13 on: August 22, 2014, 03:21:26 AM »
Well I reinstalled Avast Internet Security and got the same warning "device driver software was not successfully installed" and "avast! Firewall NDIS Filter Miniport" failed to install. So I guess I'll uninstall Avast and leave it off my computer if it's not installing properly.
Did you do a full uninstall including using the avast! cleaner:
http://files.avast.com/iavs9x/avast_clear.exe
Bob read reply 9 ;)

Offline vincewillis

  • Newbie
  • *
  • Posts: 12
Re: problems on start up
« Reply #14 on: August 22, 2014, 03:40:45 AM »
Yup, completely uninstalled it. Reinstalled and get the same thing happening. Maybe I'll disable the minport or uninstall its driver if it isn't important.