Author Topic: "Unknown Error" when opening avast!  (Read 3354 times)

0 Members and 1 Guest are viewing this topic.

Offline Yosef

  • Newbie
  • *
  • Posts: 2
"Unknown Error" when opening avast!
« on: October 24, 2003, 07:58:14 AM »
Windows 2000 SP4, PIII - 600 mHz, 384 MB
avast! Home 4.1.287

Hello,
This problem first occured when the automatic update updated avast! to 4.1.  I uninstalled avast!, downloaded the latest version, and reinstalled.  That seemed to fix the problem.  But now it has returned.

When I open avast!, the splash screen comes up where it says it is testing the items in memory, then an error box pops up saying, "Unknown Error.  Program cannot set property into main Storage".  After clicking OK on the error box, the splash screen hangs there.  If I right-click on the taskbar button for the splash screen and choose Close, the splash screen will close and avast! will come up and everything else seems OK.  If I disable the testing of items in memory, it seems to open OK.

This did not occur before version 4.1.  And like I said, I have completely uninstalled and downloaded a fresh copy of 4.1.

Don't get me wrong, I love avast!.  And I love the added features in 4.1.   But this is making me sad    :'(

Could you help please?  Thanks.
« Last Edit: October 24, 2003, 09:17:09 AM by Yosef »

Offline Michal Zrůbecký

  • Avast team
  • Jr. Member
  • *
  • Posts: 83
    • avast! software
Re:"Unknown Error" when opening avast!
« Reply #1 on: October 24, 2003, 09:23:23 AM »
 1) Start Notepad program
 2) In Notepad, open the fileAVAST4.INI, that´s located in
    C:\PROGRAM FILES\ALWIL SOFTWARE\AVAST4\DATA.
 3) Find the section [Common] and the row
    Database=ODBC
 4) Change this row to
    Database=XML
 5) Save the file
 6) Restart your computer
avast! support team

Offline Yosef

  • Newbie
  • *
  • Posts: 2
Re:"Unknown Error" when opening avast!
« Reply #2 on: October 24, 2003, 09:39:20 AM »
Hey, that worked perfectly!  Problem solved!  Thanks, odpad!  ;D

And, wow, thanks for the fast reply!  You guys are great!  8)