Author Topic: Problem creating packages  (Read 4751 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Problem creating packages
« on: March 25, 2009, 07:34:26 AM »
Hi everyone,

Tricky problem ;-)

I'm trying to setup ADNM with multi-AMS.

I have two sites (USA and Australia) connected via VPN. There are full MSSQL 2005 servers at each location.

I have managed to get both sites installed and talking to their respective databases, as well as connecting one (USA) to the other (Australia) as the root AMS. I created a replication task to run on the root AMS and ran it. The database replicates properly from one SQL server to the other. I have confirmed this from the SSMS on the SQL servers.

I have then looked at the AMS mirror status on both servers (both set to mirror from the internet) and they say that they have completed successfully.

When I try to create an installation package I get the error "The installation package could not be edited. This usually means that the AMS updating mirror has not been properly initialized."

I have tried updating ADNM from Add/Remove programs, uninstalling & re-installing ADNM, re-creating the SSL certificates, deleting and re-creating the databases as well as manually running mirror.exe on both servers.

None of these seem to fix the issue. Is there any more info about trouble-shooting this? I've only found one reference to this issue in the forums and it was fixed by re-installing ADNM. This has not worked for me.

Regards,

Mike.

P.S.

This is the output of 'Show AMS Mirror Status' on one of the servers. They both show the same thing:

=========================================
avast! Distributed Network Manager Mirror
=========================================

Mirror folder: C:\Program Files\Alwil Software\Management Tools\mirror\mirror

Mirroring products: av_mgm,av_net,av_srv



Current versions in mirror:

avast! Distributed Network Manager: 4.8.952 (Jan 21, 2009)

avast! Network Client (managed): 4.8.1005 (Dec 19, 2008)

avast! Server Edition: 4.8.1059 (Dec 19, 2008)

Virus database: 090324-0 (Mar 24, 2009)

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Problem creating packages
« Reply #1 on: April 01, 2009, 08:55:55 PM »
Man, I wish I had a place to install multiple AMS servers.  Unfortunately, I don't have any experience with that yet.

I hope someone can help you out soon.  It looks like you've done the correct troubleshooting steps, I can't imagine why it wouldn't be working yet.

Good luck!
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

FLEURS200

  • Guest
Re: Problem creating packages
« Reply #2 on: April 08, 2009, 12:23:10 PM »
Hello,
I think apart from the add/remove programs updates, you can run the mirror.exe as well.
May be all files were not downloaded.
A+