Author Topic: Updating with Proxy...Help!  (Read 7990 times)

0 Members and 1 Guest are viewing this topic.

Kryton

  • Guest
Updating with Proxy...Help!
« on: October 24, 2003, 04:12:10 PM »
I've been having problems for awhile now with the updating process.  I'm using Avast Home edition with windows xp home.  I have the most recent update.  Whenever I manually run the update the update screen comes up and it seems like it is updating some files, but then it just sits there and does nothing.  If I leave the window open, about 15 minutes will pass and then it will complete everything very quickly and finish.  I don't know why.  I haven't had this problem before.  My internet provider uses a proxy server so I made sure to have that set in avast.  So I don't know what's up.  I've tried other AV programs and they use the proxy server just fine to update.  I really don't want to leave Avast, and go with an inferior AV program, but I may have to.  PLEASE HELP!  Thanks.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Updating with Proxy...Help!
« Reply #1 on: October 24, 2003, 09:47:54 PM »
I have WinXP Pro SP1 and proxy. No troubles in updates.
Do you use a firewall?
Besides the avast! update, other Internet applications are working well?

Please, do not leave avast!  ;)
The best things in life are free.

techie101

  • Guest
Re:Updating with Proxy...Help!
« Reply #2 on: October 24, 2003, 10:35:37 PM »
kryton,

This would only occur if the incoming packets are no longer being received.
What I would ask you to do is to try the manual update again and watch closely to see if your computer is attempting to communicate with the Avast server. (Watch the tray icons, or if using a firewall....open it, and monitor the traffic screen).  This will tell us if the "pings" are being sent and received.
If they stop, then the Avast server will consider communication lost and cease sending.  However, remember that Avast will automatically and periodically seek a connection again if you have Update set to Auto download.  It sounds like that is the situation here.

Then after running the test, send me your  ?:\Program Files\Alwil Software\Avast4\setup file, and the  ?:\Program Files\Alwil Software\Avast4\Data\log\setup,  they may reveal what caused the delay.  Cut/paste only the day you run the test I asked for above.  That's all I need to review.  Send them via IM or Private message

A remote possibility is that you may have another program temporarily seizing control of the port Avast wants to use for the download.  We can work on that later.  I need to ascertain which port is normally used.

Technical brought up a good point.  While Avast seems to be taking a "snooze", can you do anything else on your system such as surf the net...use any other programs etc?
Technical and I have virtually the same system setup as you so we should be able to help you.

techie :)
« Last Edit: October 24, 2003, 11:16:16 PM by techie101 »

Kryton

  • Guest
Re:Updating with Proxy...Help!
« Reply #3 on: October 25, 2003, 02:35:04 AM »
Thank you both for your help.  I am currently using Kerio 2.15 for my firewall.  When the Avast update is paused I am still able to surf and do other things on the net.

When I open up my Kerio status screen I see the Avast Update accessing the internet, but then it just sits there and no data is being trasmitted or received.  The Avast Update progress window goes through a few files checking to see if I have the latest version, then it pauses.  It seems to pause on different files each time.  Then 5 minutes later it continues and finishes the updating process like nothing ever happend.  

(I just tried to update and it worked this time)  Kerio told me that the local address was 2209, 2210, and 2211.  I assume that is the port?  It gives different numbers each time.  Is there a way to make Avast use the same port numbers each time?  

Thanks again for your help.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Updating with Proxy...Help!
« Reply #4 on: October 25, 2003, 02:54:54 AM »
kryton,
Technical brought up a good point.  While Avast seems to be taking a "snooze", can you do anything else on your system such as surf the net...use any other programs etc?
Technical and I have virtually the same system setup as you so we should be able to help you.
techie :)

Kryton, believe us  ;D Believe avast!  ;) Believe avast! users  :D
Thanks techie for your praise words...  ;)

I think Kryton that techie makes the goal: manual update. I do not use Kerio (but ZoneAlarm). But Kerio is a good firewall too and could handle avast! update. See if your "Kerio rules" do not avoid avast! update. I use a proxy and the port connected seem to be 8001 (Server: www.avast.com 66.98.166.72:8001). Sorry if I cannot help you more than this...

The best things in life are free.

Kryton

  • Guest
Re:Updating with Proxy...Help!
« Reply #5 on: October 25, 2003, 04:41:17 AM »
Well, I switched over to Zone Alarm.  It seems to be working more than it did with Kerio.  It will work, just sometimes it doesn't work on the first, second, or third trys  :)  But it eventually updates.  I noticed that there is a text file which has a list of the servers that are used for the update.  Is there a way to set Avast to just use one of the servers?  My proxy server is from a filtered ISP.  Sometimes it does not like foreign websites.  I don't know if this is the case, but I thought it might be something to ask about.  Thanks again for your help.

Kryton

kubecj

  • Guest
Re:Updating with Proxy...Help!
« Reply #6 on: October 25, 2003, 01:01:08 PM »
You can't tell the updater which server to use. It does automagically select one of four (currently) just to better distribute bandwith.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Updating with Proxy...Help!
« Reply #7 on: October 25, 2003, 01:14:09 PM »
Well, I switched over to Zone Alarm.  It seems to be working more than it did with Kerio.  It will work, just sometimes it doesn't work on the first, second, or third trys. But it eventually updates.Kryton

Yes Kryton, sometimes my ZA works similar as you tell. But I have to recognize it´s very rare this behavior  ;)

Edit: See techie explanation bellow.
« Last Edit: October 26, 2003, 12:18:29 AM by Technical »
The best things in life are free.

techie101

  • Guest
Re:Updating with Proxy...Help!
« Reply #8 on: October 25, 2003, 11:28:40 PM »
Kryton,

Sorry you did not receive my answer to your post.  I had received your logs and after looking at them determined the area where the problem lies, however, since you switched to Zone Alarm, it does not apply any longer. It related to configuring Kerio to "bypass" Avast, and having your provider check proxy settings.

Zone Alarm can be configured to ADD Avast server addresses into the TRUSTED ZONE. This should improve performance and access. (Open the ZA panel. Go into Firewall...Zones. Then add the Avast sites)

Also, if the Security setting of the ZA Firewall (Main tab) is HIGH. This could also cause connection problems.  Try it on MED.

Good luck
Techie

« Last Edit: October 25, 2003, 11:33:09 PM by techie101 »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Updating with Proxy...Help!
« Reply #9 on: October 27, 2003, 01:42:01 AM »
Kryton, any news about your problem?
You said: I really don't want to leave Avast, and go with an inferior AV program, but I may have to.  PLEASE HELP!  Thanks.

We are here to help you (if we can...)  ;)
The best things in life are free.

Kryton

  • Guest
Re:Updating with Proxy...Help!
« Reply #10 on: October 27, 2003, 05:23:10 AM »
Well, I'm still using Avast :)  I tried entering the addresses for the servers in my 'Trusted Zone' in Zone Alarm and I also set it to Medium, but I still had the same problem  >:(  So I'm guessing the problem is with my ISP.  Hopefully someday I will switch to high speed internet without a proxy and things will be great again  ;)  But, in the meantime I will just have to press my update button a few more times than usual  :)  I will not be leaving Avast.  Especially because of the great tech support I've received from this forum.  I would be crazy to leave that!  Thanks for all of your help.  Now I know where to go if I ever have a problem again.  Thanks!

Kryton

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Re:Updating with Proxy...Help!
« Reply #11 on: October 27, 2003, 01:38:06 PM »
Well, I'm still using Avast :)  I tried entering the addresses for the servers in my 'Trusted Zone' in Zone Alarm and I also set it to Medium, but I still had the same problem  >:(  So I'm guessing the problem is with my ISP.  Hopefully someday I will switch to high speed internet without a proxy and things will be great again  ;)  But, in the meantime I will just have to press my update button a few more times than usual  :)  I will not be leaving Avast.  Especially because of the great tech support I've received from this forum.  I would be crazy to leave that!  Thanks for all of your help.  Now I know where to go if I ever have a problem again.  Thanks!

Kryton

I think what you did is correct, I could not see the error and the bug  :'(
Although, to be sure, I suggest you exit ZA for a while and try to update. Without a firewall you can see if the trouble is in your ISP.

Try either to remove avast! from the ZA and see if, next time, the update calls ZA and you allow the update (named avast! setup) connect to the Internet all the time. Server rights is not necessary.

Btw, server rights is necessary for your proxy (if not, you won't be connected, I suppose).

Best regards.  ;)
The best things in life are free.