Author Topic: Vista 64bit: Error basInitLibrary  (Read 3792 times)

0 Members and 1 Guest are viewing this topic.

Offline puppeteer

  • Newbie
  • *
  • Posts: 2
Vista 64bit: Error basInitLibrary
« on: February 25, 2007, 08:13:16 PM »
Hello everybody!

Today I installed the 64bit version of Windows Vista on my computer and the first thing i did after setup was to install Avast home edition. But after the reboot Avast refused to work/start correctly. Instead following error message appeared:

Error basInitLibrary - initialization of basic library failed! Check out INI file or install program again, please. Error: 2147418115

I tried nearly everything which came to my mind (administrator rights, winxp emulation) but the programm still refuses to start.

Follwing services aren't running and cannot be started:
avast! Antivirus
avast! Mail Scanner
avast! Web Scanner
(the "avast! iAVS4 Control Service" is activated)

Maybe someone can help with an explanation?

Additional information:

I haven't installed an other antivirus application!
I installed Avast on the plain Vista installation without further configuration!
I have a high end system with enough ram and cpu power (C2D6600, 2gbram)!
I'm from Austria, so my english may suckĀ  :P
« Last Edit: February 25, 2007, 08:16:11 PM by puppeteer »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re: Vista 64bit: Error basInitLibrary
« Reply #1 on: February 25, 2007, 08:29:58 PM »
Please uninstall avast!, and install it again - this time into the default folder, offered by avast! installer (i.e. don't change it).

Offline puppeteer

  • Newbie
  • *
  • Posts: 2
Re: Vista 64bit: Error basInitLibrary
« Reply #2 on: February 26, 2007, 01:15:12 AM »
Hmm, strange... that really helped me out. Thank's a lot!