Author Topic: avast! 2015 Beta 3 and GlassWire  (Read 4682 times)

0 Members and 1 Guest are viewing this topic.

Offline valsamis.d

  • Newbie
  • *
  • Posts: 3
avast! 2015 Beta 3 and GlassWire
« on: October 06, 2014, 02:16:44 PM »
Hi All!

After installing avast! 2015 Beta 3 and rebooting my laptop (Win 8.1 x64) I got a PAGE_FAULT_IN_NONPAGED_AREA BSOD message referring to (gwdrv.sys) which is a driver of the GlassWire network monitoring tool (https://www.glasswire.com/). Reverting back to avast! 2014 solved this problem. So it looks like there's an incompatibility between avast! 2015 and GlassWire.

Thanks!

Offline avast98

  • Newbie
  • *
  • Posts: 1
Re: avast! 2015 Beta 3 and GlassWire
« Reply #1 on: October 31, 2014, 10:35:11 PM »
Same Problem here!
I had to revert from version 10.0.2206.692 to 9.0.2021.515 with a system restore point and the windows system recovery. I'm on windows 8.1. The error occured the first time right after iI updated Avast to the new version and the following reboot of windows.
No chance to enter windows while Glasswire is installed an Avast 10 is running.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: avast! 2015 Beta 3 and GlassWire
« Reply #2 on: October 31, 2014, 11:36:48 PM »
Please perform a clean installation of avast 2015.10.0.2026

Offline Zdenek

  • Avast team
  • Jr. Member
  • *
  • Posts: 38
Re: avast! 2015 Beta 3 and GlassWire
« Reply #3 on: November 10, 2014, 03:36:33 PM »
Hallo,

I have checked the final 2015 Avast version with latest GlassWire installation from the GlassWire web. All works smoothly without any BSOD.

Can you please check if your problem persists with the final Avast 2015 version and the latest GlassWre?

If yes, please can you create full memory dump for me for further analysis?

Thank you

Offline harryjamesuk

  • Newbie
  • *
  • Posts: 17
Re: avast! 2015 Beta 3 and GlassWire
« Reply #4 on: November 21, 2014, 10:55:10 PM »
Also just had this issue.

Uninstalled Avast and it fixed it.

Going to try a fresh reinstall now and I'll let you know how it goes.

Offline harryjamesuk

  • Newbie
  • *
  • Posts: 17
Re: avast! 2015 Beta 3 and GlassWire
« Reply #5 on: November 22, 2014, 01:29:58 AM »
Yes, I still get this problem even with a fresh install (As soon as the software installs, I get the blue screen).

I now also seem to have a corrupt version of Avast on my system as, I can not run, install nor uninstall Avast now.

I've provided all of the logs and dumps here:
https://drive.google.com/folderview?id=0B_bNDqAMGPKQVnhBSU1xLUpjcGc&usp=sharing

Any help would be much appreciated!
« Last Edit: November 23, 2014, 03:17:39 PM by harryjamesuk »

Offline harryjamesuk

  • Newbie
  • *
  • Posts: 17
Re: avast! 2015 Beta 3 and GlassWire
« Reply #6 on: November 23, 2014, 07:55:58 PM »
Turns out GlassWire have fixed the problem now!

The latest update will enable functionality with both Avast and GlassWire. You can download it from https://www.glasswire.com/.

I also fixed the issue about the corrupted Avast using the uninstall utility at http://www.avast.com/en-gb/uninstall-utility.

Hope this helps anyone else having the same issue!