Author Topic: High CPU usage for com.avast.proxy on Mac  (Read 9606 times)

0 Members and 1 Guest are viewing this topic.

Offline lane2

  • Newbie
  • *
  • Posts: 10
High CPU usage for com.avast.proxy on Mac
« on: October 22, 2014, 04:20:35 PM »
Platform
MacBook Air
13-inch, Early 2014
Processor  1.7 GHz Intel Core i7
Memory  8 GB 1600 MHz DDR3
Software  OS X 10.9.5 (13F34)

Avast Mac Security 2015
Version: 10.0 (43029)
Virus definitions version: 14102200

com.avast.proxy is consuming > 100% of CPU.  I allowed to run overnight in the hopes that there was some process that needed to complete.  Still running very high.  Is there a solution?

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #1 on: October 22, 2014, 06:01:44 PM »
UPDATE:  If I quit the com.avast.proxy process, the process restarts with a very small (expected) usage.  It then begins to creep up in usage over time.  After about 15 minutes or so, it is > 50% and the CPU fans start to spin up.  This appears to be repeatable.

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #2 on: October 22, 2014, 07:07:26 PM »
UPDATE:  Here is the information captured in the console;
10/22/14 9:49:05.844 AM com.avast.proxy[6441]: Starting daemon.
10/22/14 9:49:14.719 AM com.avast.proxy[6441]: swquery.apple.com:https: nodename nor servname provided, or not known
10/22/14 10:20:57.000 AM kernel[0]: process com.avast.proxy[6441] thread 252001 caught burning CPU! It used more than 50% CPU (Actual recent usage: 52%) over 180 seconds. thread lifetime cpu usage 90.015240 seconds, (17.339196 user, 72.676044 system) ledger info: balance: 90003328083 credit: 90003328083 debit: 0 limit: 90000000000 (50%) period: 180000000000 time since last refill (ns): 172814921722
10/22/14 10:21:03.522 AM spindump[6602]: Saved cpu_resource.spin report for com.avast.proxy version ??? (???) to /Library/Logs/DiagnosticReports/com.avast.proxy_2014-10-22-102103_AirGhizmo.cpu_resource.spin
10/22/14 10:33:31.532 AM com.avast.proxy[6441]: SIGTERM/SIGINT received. Exiting.


From /Library/Logs/DiagnosticReports/com.avast.proxy_2014-10-22-102103_AirGhizmo.cpu_resource.spin;
Date/Time:       2014-10-22 10:18:03 -0500
OS Version:      10.9.5 (Build 13F34)
Architecture:    x86_64
Report Version:  18

Command:         com.avast.proxy
Path:            /Library/Application Support/Avast/*/com.avast.proxy
Version:         ??? (???)
Parent:          launchd [1]

PID:             6441
Event:           cpu usage (microstackshots only)
Thread:          0x3d861 (52% cpu over 174 seconds)
Duration:        174.00s
Steps:           176

Hardware model:  MacBookAir6,2
Active cpus:     4
Fan speed:       5075 rpm


Powerstats for:  com.avast.proxy [6441] thread 0x3d861
Start time:      2014-10-22 10:18:09 -0500
End time:        2014-10-22 10:20:57 -0500
Parent:          launchd
Microstackshots: 109 samples (61%)
Primary state:   108 samples Non-Frontmost App, Non-Background Priority, Kernel mode
User Activity:   0 samples Idle, 109 samples Active
Power Source:    0 samples on Battery, 109 samples on AC
  109 thread_start + 13 (libsystem_pthread.dylib) [0x7fff88408fc9]
    109 _pthread_start + 137 (libsystem_pthread.dylib) [0x7fff8840472a]
      109 _pthread_body + 138 (libsystem_pthread.dylib) [0x7fff88404899]
        109 imap_handler + 3135 (com.avast.proxy) [0x10001495f]
          109 _platform_memmove$VARIANT$Unknown + 41 (libsystem_platform.dylib) [0x7fff84662b29]
            1   <User mode>

  Binary Images:
         0x100000000 -        0x10001bff7  com.avast.proxy <B978B5F9-335F-3F41-96BB-8DEA2F1978C8> /Library/Application Support/Avast/*/com.avast.proxy
      0x7fff8465f000 -     0x7fff84665ff7  libsystem_platform.dylib (24.90.1) <3C3D3DA8-32B9-3243-98EC-D89B9A1670B3> /usr/lib/system/libsystem_platform.dylib
      0x7fff88403000 -     0x7fff8840aff7  libsystem_pthread.dylib (53.1.4) <AB498556-B555-310E-9041-F67EC9E00E2C> /usr/lib/system/libsystem_pthread.dylib

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: High CPU usage for com.avast.proxy on Mac
« Reply #3 on: October 22, 2014, 07:16:32 PM »
What IMAP accounts do you use? Only the gmail hosted one for ghizmo.com?

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #4 on: October 22, 2014, 07:31:11 PM »
I have several.  ghizmo.com, globalthought.org, and allotime.com.  These are all gmail hosted.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: High CPU usage for com.avast.proxy on Mac
« Reply #5 on: October 22, 2014, 07:38:40 PM »
What email client (exact version) do you use?

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #6 on: October 22, 2014, 09:18:03 PM »
Hi Tumic,

Thank you for jumping in here.  I use gmail for the three IMAP accounts I mentioned a moment ago.

As it turns out, I have resolved the problem however, I have been unable to recreate it.  It seems that upon closing some tabs in Chrome, the com.avast.proxy process has settled down.  It is not uncommon for me to have 25 - 30 tabs open at a time.  I closed about 6 or 7 of them just because I did not need them any longer. None of the closed tabs were gmail.

I noticed that the problem went away so I reopened the tabs however the problem did not reoccur. 

I will keep watch and see if it happens again and will post an update.

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #7 on: October 23, 2014, 03:32:22 AM »
New information...

The problem of com.avast.proxy burning through CPU has not gone away.  I have tried replicating the problem and possible offending Chrome tab by shutting down tabs one-at-a-time and the process never dipped and stayed > 50%.

I really need Avast to help out here or I will be forced to remove the program.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: High CPU usage for com.avast.proxy on Mac
« Reply #8 on: October 23, 2014, 09:27:35 AM »
The problem is caused by a mailshield (IMAP) connection, so no wonder it has
not gone away after closing some HTTP connections. So the question remains
the same - what email client do you use and what email servers are you connecting
to?

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #9 on: October 23, 2014, 02:36:53 PM »
Hi Tumic,

I use gmail via Chrome (38.0.2125.104) for my email client.  I also have Outlook 2011 connecting to an Exchange account.  Does this answer the question?

Thanks!

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #10 on: October 23, 2014, 02:42:14 PM »
Tumic,

You are right on about the problem being related to Mail Shield.  I shut that one down and com.avast.proxy returns to minimal usage.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: High CPU usage for com.avast.proxy on Mac
« Reply #11 on: October 23, 2014, 02:47:50 PM »
Hi Tumic,

I use gmail via Chrome (38.0.2125.104) for my email client.  I also have Outlook 2011 connecting to an Exchange account.  Does this answer the question?

Thanks!

Now we have at least a part of the whole story - the IMAP client is Outlook 2011. The Exchange server
is some local company server that is not public, I guess?
« Last Edit: October 23, 2014, 02:50:38 PM by tumic »

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: High CPU usage for com.avast.proxy on Mac
« Reply #12 on: October 23, 2014, 02:49:08 PM »
Tumic,

You are right on about the problem being related to Mail Shield.  I shut that one down and com.avast.proxy returns to minimal usage.

I know, this is clear since you posted the diagnostic report. That's why I'm trying to get info about
IMAP accounts from you...

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #13 on: October 23, 2014, 02:50:02 PM »
Correct.  Outlook is used for access to corporate email.  Note: I have shutdown Outlook and that does not drop com.avast.proxy's usage.

Offline lane2

  • Newbie
  • *
  • Posts: 10
Re: High CPU usage for com.avast.proxy on Mac
« Reply #14 on: October 27, 2014, 05:15:07 PM »
Just wondering if Avast has a fix or diagnoses for com.avast.proxy mail shield taking up so much CPU?