Author Topic: Re-occurrence of UI issue with 2015 (10.0.2206)  (Read 3730 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Re-occurrence of UI issue with 2015 (10.0.2206)
« on: October 23, 2014, 05:35:09 AM »
Greetings, all:

Back in the days of the more recent releases of avast Free 2014 (9.0.2020 and later, if I recall correctly), I developed an annoying bug (at least I think its a bug) that resulted in the scan results window opening after any type of scheduled scan, regardless of whether or not the relevant setting in the program's main setting window was checked.  In another post on this topic, we seemed to reach the conclusion that this behavior was, in fact, a bug, and would be addressed at some point in the future.

Today, after an full uninstall of an earlier version of 9.0 which did not have the "bug" (including running avastclear after the Windows Add/Remove uninstall process) and a clean install of 2015 Free, the same behavior has returned. 

Whether I have the "Automatically open the scan results when scan is finished" setting checked or unchecked, at the completion of any scheduled scan, the main interface window opens and displays the scan tab (I closed it so quickly in frustration that I didn't notice if the message that no virus was found appeared on the panel).  The popup over the tray icon announces the completion of the scan with the "no virus found" message as well.

I don't know if I'm doing something wrong somewhere deep in the scan settings, of if this is intended behavior, but I still find it quite annoying to be working on something else (or to come back to the computer later if I am away at the time of the scan) and suddenly have to dismiss the avast main program window before proceeding with whatever else I was trying to do at the time.  I'd really like to be able to go back to the old behavior, in which only the tray icon popup appears at the conclusion of a scheduled scan, especially if no malware was detected.

Any help with, or thoughts on, this issue would be greatly appreciated.  For what it's worth, my OS is Windows 7 x64, fully patched through October's Patch Tuesday releases (excluding the buggy ones, of course!).

Regards,
Crashman
« Last Edit: October 24, 2014, 05:14:05 AM by Crashman »

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #1 on: October 24, 2014, 05:16:13 AM »
Update: 

Regular scheduled quick scan did this to me again on the next try - end of scan caused interface to open and show the scan section, with no message about scan results.  I'm just about out of patience with this now, so I guess its either back to an early 9.0 or on to something else entirely.

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #2 on: October 24, 2014, 05:45:15 AM »
Not being critical of your decisions, but it seems like kind of a small thing to abandon an entire antivirus program over.

Since I installed 2015 today I haven't had a scheduled scan yet.  I was having the same problem with 2014 prior to the update.  I'll know tomorrow morning.

-Noel

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #3 on: October 24, 2014, 06:41:12 AM »
NoelC,

Point taken.

I only have the computer on when I am actually doing something with it (which is typically the same time of day every day), so any scheduled scan will necessarily have to occur at a time when I am trying to get on with other things with the machine.  Having the main interface popup just strikes me as an unnecessary irritation.  (Maybe my nerves are just shot for other reasons, which is very possible!)

Strangely, if the scan is triggered automatically by the program on the schedule I specify in scan settings, the window that jumps up show no information suggesting that a scan has been done or what the results were -- it's just the standard "scan" screen with the type of scan selected and the hyperlink to access settings.  But if the scan is initiated manually, and the main program window is then closed while the scan is underway, when it finishes the "scan" screen jumps up anyway and reports the same result that appears on the pop-up over the tray icon.

It's kind of ironic that the voice notification feature for definition updates was, I understand, removed to minimize intrusions on the user, but at the same time I can't get the program to stop popping up in front of me to show me a scan window that at best duplicates information provided elsewhere on the screen, and not even that much if it was a scheduled scan.  Surely it must be a bug of some kind, which has survived several release versions of the older 9.0 and now the new 10.0.

My apologies for my tone - I really don't mean to come across as a jerk here.  It's just that, with every passing year, my patience drifts a little farther from my grasp, if you know what I mean, and this goofy thing is really testing my ability to reach far enough to grab it...

Regards,
Crashman

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #4 on: October 24, 2014, 07:51:10 AM »
Don't worry about it.  Everyone here understands frustration.

Just evaluate Win 10 for a little while to see where Microsoft is going, and perhaps Avast's little issues will drift to the distant reaches of your mind...   ::)

-Noel

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #5 on: October 24, 2014, 12:02:41 PM »
Still having this problem here as well, despite a number of previous admonitions that it would be fixed in 2015.  :(  -JW

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #6 on: October 24, 2014, 02:28:31 PM »
Don't worry about it.  Everyone here understands frustration.

Just evaluate Win 10 for a little while to see where Microsoft is going, and perhaps Avast's little issues will drift to the distant reaches of your mind...   ::)

-Noel

Noel,

Appreciate the remark.  That may well work, since these days my mind consists mostly of various distant reaches.;D  Don't even mention Win 10; I'll move to a mountaintop in Tibet before I am dragged kicking and screaming into any of MS's recent OS efforts.

JWJr, thanks for confirming that it's not something I'm doing.  Let's hope that now that the big release is out, they will get around to this after the other various issues with ng and so on are sorted. While we're waiting, I think I'll go with manual scans only.

-Crashman
« Last Edit: October 24, 2014, 02:30:08 PM by Crashman »

REDACTED

  • Guest
Re: Re-occurrence of UI issue with 2015 (10.0.2206)
« Reply #7 on: October 24, 2014, 03:21:44 PM »
For what it's worth, the UI was open on my system this morning after having completed the 6am scheduled scan.  It's configured not to open the UI, but it does so anyway.

If that's its worst behavior I'm happy.

-Noel