Author Topic: Why is Mail Shield in Avast Free for Mac blocking all mail from BT internet server  (Read 3582 times)

0 Members and 1 Guest are viewing this topic.

Offline anniemac

  • Newbie
  • *
  • Posts: 3
I installed Avast Free for Mac 2 days ago on my iMac, and since then all incoming emails to Outlook from my btinternet.com addresses have been blocked (error message 'Connection to the Server failed or was dropped' error code 17895.) As advised elsewhere on this forum, I have temporarily resolved the problem by 'excluding' the pop.btinternet.com server from Mail Shield (using 'advanced preferences'), but I guess this means I am effectively by-passing the Avast protection for email, which seems pointless.  Why can't Avast work alongside the BT server and Outlook?  Is there a better solution which will give the protection I'm looking for?  I am a fairly inexperienced Apple user and running OS X Mavericks version 10.9.5 (not yet ready to face Yosemite...)

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Are there any relevant messages from com.avast.proxy in the system log file (use e.g. the "Console"
tool to see the system log)?

Offline anniemac

  • Newbie
  • *
  • Posts: 3
Yes. loads of the same message since I installed Avast: these all say 'Defective POP3 response!' and then in a separate log underneath: 'PLAIN'. There are a few other logs: 'com.avast.proxy: Starting daemon'.  Also 'SIGHUP received. Reloading...' and 'swquery.apple.com:https: no dename nor servname provided, or not known' and at the end of yesterday's session: 'SIGTERM/SIGINT received. Exiting'.

Sadly, I thought I had worked around it when I posted my query last night, but today (even though the BT server is still showing as 'excluded' under Avast preferences) I am unable to receive any email via Outlook and there are endless 'Defective POP3 response' and 'PLAIN' reports as the computer keeps trying to access my mail.

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Can you please copy here the relevant log entries, most important all the messages around the "Defective POP3 response" entry.
(I would expect another message - "STLS connection detected!" there)

Regarding the non-working exclusion - what addres did you put into the exclusions list?

Offline anniemac

  • Newbie
  • *
  • Posts: 3
Hi, There are no other entries saying 'STLS connection detected'. It is all as I described yesterday.  But here are a few copied extracts from yesterday including messages above and below them in the log:

03/11/2014 13:32:57.107 Safari[1194]: CGContextSynchronize: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.
03/11/2014 13:36:39.394 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:36:39.394 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:36:39.395 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:36:39.395 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:36:41.342 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:36:41.342 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:36:41.344 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:36:41.344 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:37:35.644 com.apple.launchd[1]: (com.avast.update) Throttling respawn: Will start in 5401 seconds
03/11/2014 13:47:26.583 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:47:26.583 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:47:26.585 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:47:26.585 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:47:26.587 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:47:26.587 com.avast.proxy[1017]: PLAIN
.
03/11/2014 13:47:26.587 com.avast.proxy[1017]: Defective POP3 response!
03/11/2014 13:47:26.588 com.avast.proxy[1017]: PLAIN
03/11/2014 13:47:35.612 com.apple.launchd[1]: (com.avast.update) Throttling respawn: Will start in 4801 seconds
03/11/2014 13:50:19.626 launchservicesd[54]: Application App:"Avast Mac Security" asn:0x0-43043 pid:1751 refs=7 @ 0x7f993845d860 tried to be brought forward, but isn't in fPermittedFrontApps ( ( "LSApplication:0x0-0x45045 pid=1759 "SecurityAgent"")), so denying. : LASSession.cp #1481 SetFrontApplication() q=LSSession 100004/0x186a4 queue

I have since disabled Avast's Mail Shield so i can get round the problem - but obviously that wasn't my original intention!


 

Offline anniemac

  • Newbie
  • *
  • Posts: 3
Sorry sumac, I forgot to answer your other question: I typed 'pop.btinternet.com' into the exclusions list (as described by another forum user in earlier conversations) and it did work for one afternoon - time for me to post my original question - and then had stopped working the following day.