Author Topic: Avast 10.0.2208 prepares NG after every boot!!  (Read 5547 times)

0 Members and 1 Guest are viewing this topic.

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Avast 10.0.2208 prepares NG after every boot!!
« on: November 07, 2014, 11:18:11 PM »
Why  is that!!?? Second reboot after install and yet does this CPU consuming prepare.

I decided to remove the NG component for now. Maybe will try it again in future versions.
« Last Edit: November 07, 2014, 11:31:39 PM by avaster78 »
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #1 on: November 08, 2014, 05:59:41 AM »
Had the same problem here. Avast continuously tried to setup NG on each reboot, but kept failing. Performed clean uninstall/reinstall, and all is well now!

Update. This is still not fixed.

07.11.2014 20:35:52.799  4604 | error: TypeLib(Un)Register C:\Program Files\AVAST Software\Avast\ng\vbox\VBoxC.dll, error 0x8002801c
07.11.2014 20:35:52.857  4604 | Installing VirtualBox...
07.11.2014 20:35:57.412  4604 | Creating snapshot...
07.11.2014 20:37:03.354  4604 | Volume shadow set: {4834377f-66a3-4fcd-8a2b-32f76db2afb1}
07.11.2014 20:37:03.462  4604 | BCD volume: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy50
07.11.2014 20:37:03.540  4604 | Windows volume: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy51
07.11.2014 20:37:03.699  4604 | Creating new hive files...
07.11.2014 20:39:37.909  4604 | Cloning NTFS volumes...
07.11.2014 20:42:35.625  4604 | Creating a new VM machine...
07.11.2014 20:42:38.230  4604 | Starting VM machine to create initial snapshot, it can take a couple of minutes...
07.11.2014 20:50:52.665  4604 | error: PrepareNGSource/HgcmRpcExecuteVirtualProcess failed, error: 0x0000010b
07.11.2014 20:52:20.576  4604 | OK
07.11.2014 20:52:22.105  4604 | New Ng_f3b4e17a-9c57-474d-a3f1-18047d71efc9 machine has been created, uuid: 5f331b0a-6238-473e-8c26-375f0f1b8e0f
07.11.2014 20:52:39.811  4604 | New Ng_c6f2dcd7-da43-4c05-b36c-1c44857db3c2 machine has been created, uuid: a3467bbb-2f88-4213-a9a5-b631e41a9f10
07.11.2014 20:52:40.092  4604 | New Ng_c11906fb-d0bb-429a-a54d-fa2c009a4996 machine has been created, uuid: 0b4a6b80-0871-445a-bcfb-879e3e6b9904
07.11.2014 20:52:40.170  4604 | CmdAvastInstallWrapper done (result: 0x00000000)
07.11.2014 21:21:18.818  5668 | Installing VirtualBox...
07.11.2014 21:21:19.192  5668 | error: RegisterVBoxServices failed, error: 0x0000045b
07.11.2014 21:21:19.208  5668 | CmdAvastRepairWrapper done (result: 0x0000045b)
07.11.2014 21:24:33.962  2712 | Installing VirtualBox...
07.11.2014 21:24:37.113  2712 | Creating snapshot...
07.11.2014 21:25:24.771  2712 | Volume shadow set: {af391a9f-f5ce-49fe-bec1-b09e86cb093f}
07.11.2014 21:25:26.441  2712 | BCD volume: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy52
07.11.2014 21:25:26.441  2712 | Windows volume: \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy53
07.11.2014 21:25:26.441  2712 | Creating new hive files...
07.11.2014 21:29:17.670  2712 | Cloning NTFS volumes...
07.11.2014 21:35:47.871  2712 | Creating a new VM machine...
07.11.2014 21:35:51.397  2712 | Starting VM machine to create initial snapshot, it can take a couple of minutes...
07.11.2014 21:41:33.210  2712 | error: PrepareNGSource/HgcmRpcExecuteVirtualProcess failed, error: 0x0000010b
07.11.2014 21:42:56.176  2712 | OK
07.11.2014 21:42:56.410  2712 | New Ng_afe47e68-55d2-4f3f-832b-2ecd56f8a161 machine has been created, uuid: 2f08eb47-a0b0-4279-80bc-3eb2b61e0405
07.11.2014 21:42:56.660  2712 | New Ng_7662ecf8-cb3f-4e54-be02-2c99739cefbb machine has been created, uuid: 32f21cd9-e455-497a-86f8-eaeac034e11d
07.11.2014 21:43:24.459  2712 | New Ng_6e2ff836-3809-4c9c-a989-95b878107506 machine has been created, uuid: 493cb004-5568-41e5-9084-0bbee4c6d49a

Update. After several more reboots I'm only seeing normal activity from the NG and virtualbox processes.
« Last Edit: November 08, 2014, 07:19:31 AM by elnotcho »

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #2 on: November 08, 2014, 01:25:39 PM »
This NG seems to be a very problematic feature. Here with the first stable version of Avast 2015 there was no problem.
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

Offline petr.chytil

  • Quality Assurance Director
  • Avast team
  • Full Member
  • *
  • Posts: 124
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #3 on: November 08, 2014, 04:58:46 PM »
We are aware of this issue, it occurs only after an update from 10.0.2206 to 10.0.2208. A clean install of 10.0.2208 resolves it and it should not happen anymore. A fix for this problem will be released early next week and it is going to fix even the updated installations.

However, if the same problem occurred even after a clean installation of 10.0.2208, then please let me know! I would be very interested in more details and your system specifications.

Thanks.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #4 on: November 08, 2014, 05:47:57 PM »
Please excuse my ignorance but what is NG?

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #5 on: November 08, 2014, 06:18:38 PM »
NG is a new type of scanning system that was simular to deepscan. (a product that avast offers in the "cloud"), NG basically creates 3 copies of your windows computer and executes any code within the sandbox. NG will be used to tackle faster/evolving threats as Avast's current scanning engine is having less detections. NG will provide better, quicker and faster detections and push the information out to DeepScan users.

Overall NG uses a piece of technology called Oracle Virtualbox. (It's open source, feel free to take alook at it online!), Virtualbox creates virtual computer boxes that live on your computer.


Not sure if that's the best explaination.

Thanks
Oliver

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #6 on: November 08, 2014, 07:41:38 PM »
We are aware of this issue, it occurs only after an update from 10.0.2206 to 10.0.2208. A clean install of 10.0.2208 resolves it and it should not happen anymore. A fix for this problem will be released early next week and it is going to fix even the updated installations.

However, if the same problem occurred even after a clean installation of 10.0.2208, then please let me know! I would be very interested in more details and your system specifications.

Thanks.
I already clean installed avast 2208 without the NG. But i can add the NG and try how it goes now. Some system specs can be seen on my sig.

EDIT: Ok, it seems to be fine now.
« Last Edit: November 08, 2014, 08:06:16 PM by avaster78 »
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #7 on: November 08, 2014, 08:07:03 PM »
In my case the issue occurred after both an update over the top from .2206 to .2208 AND after a clean install. Only after running a repair of AVAST and rebooting several times did it not occur again. So far, so good today.

My specs:
Windows 7 Pro SP1
No other resident security programs installed
All previous AV's removed via official uninstall tools

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #8 on: November 08, 2014, 08:20:33 PM »
Ok, so i had problems NG built itself after EVERY boot, when i installed 2208 over 2206. I removed the NG and also disabled VM in BIOS. But i also had problems with disabling/enabling shields via right click menu. Sometimes after re-enabling active shields, it wasn't able to re-enable Webshield and computer also started to freeze. Because of that i decided to clean install Avast, but still without NG. Just while ago i added the NG component and everything seems to be fine now.

Not sure if this shields problems still exist, because it won't always happen, but so far no problem.

Edit: Theres still a problem with re-enabling shields!  It won't reactivite the Webshield and basicly only reboot solves this. This shield problem won't happen every time though.
« Last Edit: November 08, 2014, 09:59:05 PM by avaster78 »
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #9 on: November 09, 2014, 02:48:23 AM »
We are aware of this issue, it occurs only after an update from 10.0.2206 to 10.0.2208. A clean install of 10.0.2208 resolves it and it should not happen anymore. A fix for this problem will be released early next week and it is going to fix even the updated installations.

However, if the same problem occurred even after a clean installation of 10.0.2208, then please let me know! I would be very interested in more details and your system specifications.

Thanks.

Question...........does NG rebuild on each boot of PC ?

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #10 on: November 09, 2014, 01:25:14 PM »
Just booted my computer and quess what! It started to built the NG. :/  I now have to disable the NG component. So, even after clean install this problem this exist.
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #11 on: November 09, 2014, 02:27:45 PM »
Just booted my computer and quess what! It started to built the NG. :/  I now have to disable the NG component. So, even after clean install this problem this exist.

So you have VM disabled in BIOS & when you did clean install of Avast 2015 you unchecked NG in the TOOLS sections of the CUSTOM install option ? http://www.youtube.com/watch?v=1kTqm7P1KtU&feature=youtu.be

Offline avaster78

  • Jr. Member
  • **
  • Posts: 96
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #12 on: November 09, 2014, 05:21:54 PM »
Everything is done correctly, yet there's still a problem with Avast building NG on boot, even it's already done once.
Windows 7 Home Premium SP1 64-bit. Avast Free Latest. Opera (Chromium). SpywareBlaster 5.5. Windows 10 Firewall Control Free 64-bit (together w/ Windows Firewall). HW: HP G5139sc - Athlon II X2 220 2.8 GHz - 4 GB (Dual-channel). VDSL2 Modem Router w/ Firewall. Internet 50Mbs.

REDACTED

  • Guest
Re: Avast 10.0.2208 prepares NG after every boot!!
« Reply #13 on: November 26, 2014, 09:40:45 AM »
There's one simple solution, just remove the NG tool (until Avast has improved it, maybe):

Go to the Control panel > software > avast > (right click) change > remove the tick at the NG component

After restart your pc will run smoothy as before...  :D