Author Topic: Problems with MKS Toolkit  (Read 966 times)

0 Members and 1 Guest are viewing this topic.

Offline e_p_english

  • Newbie
  • *
  • Posts: 1
Problems with MKS Toolkit
« on: January 01, 2015, 05:34:17 PM »
I saw a similar issue but it was pretty old so I thought I would create a new one
I had a problem where I was using MKS Toolkit (6.2A) on XP for shell scripting various backup operations.
After I installed Avast, when I tried to run ksh I got the "Avast File System has blocked a threat"
I tried to "Add the file to the scan exclusion list" and
"Report file as a false positive"
but it seemed to ignore these.
This trashed my MKS installation.
I reinstalled MKS and was copying my install destination to have some place to get the files again if they got trashed again (to save installing again) when I got the same errors for the destination which then got trashed.
I tried Settings -> Exclusions and tried to add it but as I was drilling down to sh.exe Avast hung which also hung the PC. I needed to do a cold boot to restart.
After the reboot I directly went into Settings -> Exclusions and added the whole directories for MKS and didn't try to drill down to the exe. This seemed to stick in the exclusions and now I am back in business after recreating my shortcut.
This should not have been a problem if Avast honored the "Add the file to the scan Exclusion list" when the file was encountered but it didn't. When you click on the links there was no response. I assume it should have gone into the Settings -> Exclusion GUI but didn't.
Bottom line is that it was a bit of a pain but was fixable.