Author Topic: BSOD after Avast Update  (Read 3255 times)

0 Members and 1 Guest are viewing this topic.

marieke.vanbergen@hotmail.com

  • Guest
BSOD after Avast Update
« on: January 29, 2015, 11:29:04 PM »
Hello,

I have a problem with my laptop since I tried to update Avast Internet Security. I have Windows 7 and Avast 2014.9.0.2021 installed.
I got a Blue Screen and I tried to restore Windows. This did work after some tries, but when I restarted my laptop after that again, I got again a blue screen.
This went on and on and I read that more people were having trouble with this. So I tried their solutions, I uninstalled Avast, also with the clear tool, but that didn't work, I still got blue screens.
I really don't know what to do.

I used a program for windows to read the dump file, but I don't understand it.
It says:

------------------------------------------------------------------------------
Microsoft (R) Windows Debugger Version 6.3.9600.17298 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available


************* Symbol Path validation summary **************
Response                         Time (ms)     Location
Deferred                                       SRV*C:\Windows\symbol_cache*http://msdl.microsoft.com/download/symbols
Symbol search path is: SRV*C:\Windows\symbol_cache*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18409.x86fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0x82a10000 PsLoadedModuleList = 0x82b595b0
Debug session time: Fri Oct 10 17:13:55.502 2014 (UTC + 1:00)
System Uptime: 0 days 3:58:29.079
Loading Kernel Symbols
...............................................................
................................................................
....................................
Loading User Symbols

Loading unloaded module list
.......
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck D1, {4, 2, 0, 8b04b5fc}

Probably caused by : athr.sys ( athr!ieee80211_scan_detach+a1 )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arguments:
Arg1: 00000004, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: 8b04b5fc, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS:  00000004

CURRENT_IRQL:  2

FAULTING_IP:
ndis!NdisFreeTimerObject+18
8b04b5fc 8b4b04          mov     ecx,dword ptr [ebx+4]

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

BUGCHECK_STR:  0xD1

PROCESS_NAME:  System

ANALYSIS_VERSION: 6.3.9600.17298 (debuggers(dbg).141024-1500) x86fre

TRAP_FRAME:  c7c5bbac -- (.trap 0xffffffffc7c5bbac)
ErrCode = 00000000
eax=00000000 ebx=00000000 ecx=8b056b30 edx=87af7720 esi=86817028 edi=8b056b30
eip=8b04b5fc esp=c7c5bc20 ebp=c7c5bc2c iopl=0         nv up ei ng nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010286
ndis!NdisFreeTimerObject+0x18:
8b04b5fc 8b4b04          mov     ecx,dword ptr [ebx+4] ds:0023:00000004=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 8b04b5fc to 82a50b7f

STACK_TEXT: 
c7c5bbac 8b04b5fc badb0d00 87af7720 c7c5bbc8 nt!KiTrap0E+0x1b3
c7c5bc2c 924bf5c1 00000000 c7c5bc44 924a463f ndis!NdisFreeTimerObject+0x18
c7c5bc38 924a463f 87af78f0 c7c5bc50 924a9cac athr!ieee80211_scan_detach+0xa1
c7c5bc44 924a9cac 87af7720 c7c5bc68 924a9c5f athr!StaFreeScanContext+0x5f
c7c5bc50 924a9c5f 87af7720 c000009a 87af7720 athr!Sta11FreeStation+0x2c
c7c5bc68 9249c13e 868baa50 c7c5bc7c 00000001 athr!Sta11AllocateStation+0xef
c7c5bc88 9249569c 868baa50 00000001 c7c5bca0 athr!Port11AllocatePort+0x4e
c7c5bcc4 92495598 868baa50 8d19738c 868baa50 athr!MpCreateMacHandler+0x9c
c7c5bcdc 8b0152d6 868baa50 8685aca0 c7c5bd00 athr!MpOidRequestWorkItem+0x38
c7c5bcec 82c24629 86817028 8685aca0 85e214b0 ndis!ndisDispatchIoWorkItem+0xf
c7c5bd00 82a8d14b 862d1068 00000000 85e214b0 nt!IopProcessWorkItem+0x23
c7c5bd50 82c19141 80000000 e4001576 00000000 nt!ExpWorkerThread+0x10d
c7c5bd90 82ac0559 82a8d03e 80000000 00000000 nt!PspSystemThreadStartup+0x9e
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


STACK_COMMAND:  kb

FOLLOWUP_IP:
athr!ieee80211_scan_detach+a1
924bf5c1 5d              pop     ebp

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  athr!ieee80211_scan_detach+a1

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: athr

IMAGE_NAME:  athr.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4a2ea444

FAILURE_BUCKET_ID:  0xD1_athr!ieee80211_scan_detach+a1

BUCKET_ID:  0xD1_athr!ieee80211_scan_detach+a1

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:0xd1_athr!ieee80211_scan_detach+a1

FAILURE_ID_HASH:  {5a664c10-251e-50ef-1072-e5ddbadedccc}

Followup: MachineOwner
-------------------------------------------------------------------------------------

Can anybody help me?
I also uploaded the minidump file here:
https://www.dropbox.com/sh/whts2zfd2610nxa/AAACglRjtaeBBXy48D6R9MMUa?dl=0

Thanks in advance,


Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: BSOD after Avast Update
« Reply #1 on: January 29, 2015, 11:44:35 PM »
Check for newer drivers for your wifi and install them.
If there are no newer drivers, reinstall the current ones.
It may help.

Offline drake127

  • Avast team
  • Sr. Member
  • *
  • Posts: 324
Re: BSOD after Avast Update
« Reply #2 on: January 30, 2015, 01:12:28 PM »
Doesn't look like Avast's fault.  As Eddy suggests, try to get newer (or even older) drivers for your Atheros card.

marieke.vanbergen@hotmail.com

  • Guest
Re: BSOD after Avast Update
« Reply #3 on: February 02, 2015, 07:34:51 AM »
Thanks for the advice.
I thought it was due to Avast, since it happened twice after installing the update..
But I found the driver, however, I couldn't fix it.
After my laptop finally did a recovery and started again, it couldn't find an upgrade that was certified for that driver. So I wanted to just reinstall it, and I searched for the right software on the Microsoft and HP websites and also on the cd's I got with my laptop, but I couldn't find anything. I actually found something on another site (Driversmax), with the same code and date as my software, but that software said it wasn't suitable for my laptop.

So now I just disabled the device and my laptop is working fine again, I guess. Because I don't know what this driver does or what I am missing right now. But this doesn't seem like a permanent solution.

Could you may be help again? Cause I don't want to uninstall the driver and not be able to install it again..

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: BSOD after Avast Update
« Reply #4 on: February 02, 2015, 04:20:27 PM »
You can find the latest drivers here:
https://www.atheros.cz/atheros-wireless-drivers.html
Get the latest ones and install them.
If Widows/Microsoft say they are not certified, just ignore it.
It only means that Microsoft hasn't tested them (yet).
The manufacturer (Qualcomm) certainly has done so.

marieke.vanbergen@hotmail.com

  • Guest
Re: BSOD after Avast Update
« Reply #5 on: February 02, 2015, 06:05:56 PM »
Thank you, I will try that.
I only don't understand all the Atheros numbers. Do I need all the drivers on that page?
(at least, those for Win 7 32 bit?)

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: BSOD after Avast Update
« Reply #6 on: February 02, 2015, 06:08:50 PM »
No, just the one for your device.

Right click "my computer" > properties > hardware tab > device manager > network adapters
The device should be listed there (or at least somewhere in device manager)