Author Topic: Settings keep 'resetting' daily, and a few other bugs.  (Read 7675 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Settings keep 'resetting' daily, and a few other bugs.
« on: February 06, 2015, 12:15:07 AM »
On the General Tab, the settings for "Join Avast Community" and "Scan for Potentially Unwanted Programs" both keep UNCHECKING themselves on a daily basis. I've verified this happens over a few days. I will re-check them, and then a day later they will be unchecked. This also happens with heuristic settings, they always go back to default after a day.

One of my major complaints with this offering so far is that I do not feel the endpoints are as well integrated with the hosted as they could be. I don't have confidence that I can fully control the settings, or even know what the existing settings are. For example "General" settings are not a setting option in the portal, so I never really know what those are. Same with Heuristics. My suggestion is to make the clients thinner. I REALLY like what Trend does, the endpoint installs are basically a very thin client with no ability for the end user to do anything other than to run scans, and check reports. This is IDEAL in an SMB environment in my opinion (and we deploy thousands of Trend's at my work, clients love it).

Second bug. The password protection feature doesn't always work, or works very poorly. I set a password, waited for clients to update. Then went to a client and changed some settings - no password prompt!  I went to another client, changed some settings, no prompt.. I looked away for 3-4 minutes, looked back and the prompt appeared. Very odd behaviour in that respect, and as a business owner this would worry me a bit.

Here's all a Worry Free (Trend) Endpoint sees, and can do. Essentially nothing bug check reports, versions, and run scans. I do not feel the endpoints need to be able to do anything more than that, as the purpose of a hosted SMB solution is to NOT give control to individual users, and to contain that control within the portal for the administrator. If someone else needs control then they can be added to the portal as an Administrator.

http://i60.tinypic.com/skz4tl.png


REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #1 on: February 07, 2015, 01:28:37 PM »
I have been following Mayahana’s informative posts @ Wilders Security Forums with interest & thank our member for the content.

I would also like to thank the AVAST team for introducing a product that has excellent potential. I understand that the development of this is still on the nursery slopes as I am experiencing certain issues on my test network workstations too.

I was able to overcome most of the teething problems where the endpoints were not retaining certain settings by applying them in Template advanced mode through the web portal & assigning the template to each device in the Device Settings Template option rather than the original set at Parent. By doing this the superb Hardened Mode options, Passwords along with White-lists + corresponding file paths are correctly retained & published globally to the clients.

The Pups issue still remains along with another that I have not seen mentioned where the Business Console Client service,  bccavsvc.exe memory usage will grow from around 16MB to sometimes over 500MB and remain there until a reboot. I am experiencing this on all my Win 8.1 OS endpoints & another XP one that I put into the equation.

I agree with Mayahana that more configuration options should be available through the web portal templates & less on the client endpoints to make this a more practically manageable security solution.

My thanks again to the AVAST devs & I will continue to evaluate my test deployment. I eagerly wait to see what changes & enhancements will be available in future updates & all being well put this solution in place within our companies when the wrinkles are ironed out.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31210
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #2 on: February 07, 2015, 05:26:50 PM »
Indeed the cloud based solution is still in a test fase.
Detailed feedbacks like the two of you gave are sure appreciated by avast.
I am not connected to avast in any way other then just being a user of their software.
But I do say thanks to the both of you.

REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #3 on: February 11, 2015, 01:18:50 AM »
Hi Guys,

Currently the settings that are not present in the portal to control have "defaults" set for most settings other than scheduled scans. This is why if you change a setting on the local client and reboot or the next time it communicates with the portal it resets the settings made on the local client.
More settings on the portal side are in the works .
We appreciate all of your feed back , keep it coming!

Thanks!

Jeff

REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #4 on: February 11, 2015, 08:10:23 AM »
Sigmon's point is right, you need to transpose any exclusions back to the portal, so that it gets fed to the client.

I think that is the correct behaviour - and that's what I expected. i.e. control from the portal

But it's quite a challenge to transpose the relative paths from the workstation back to the server.

For me, I had to set - especially the deepscreen stuff - on the workstation and copy and paste it back, but once I had done that, it seems quite reliable.

REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #5 on: April 22, 2015, 02:08:11 PM »
>>Sigmon's point is right, you need to transpose any exclusions back to the portal, so that it gets fed to the client.

Please can you expand on how to do this?  I have set file exclusions on a template in the portal and I know the template is propagating tot he client (because other settings propagate) but the Exclusions do not seem to appear on the client even if I put exclusions in Windows Workstation on the portal's template.  I have rebooted, which for me is the quickest way to force the client to re-read the template, but the template's exclusions do not appear to be on the client.

REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #6 on: April 22, 2015, 04:30:49 PM »
Hi Paul,

Open the local client and click settings then under general select exclusions. You should see the exclusions made VIA the portal listed there.


Let me know if they are not populating to the client and we wil take a closer look.

Thanks!

Jeff

REDACTED

  • Guest
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #7 on: April 22, 2015, 04:33:32 PM »
Hi Jeff,

Very many thanks for the reply - it works perfectly.  I was looking under Settings > Active Protection > File System Shield > Customise > Exclusions

Under Settings > General > Exclusions they all appear perfectly.

Thank you so much.

Offline sirvalence

  • Newbie
  • *
  • Posts: 1
Re: Settings keep 'resetting' daily, and a few other bugs.
« Reply #8 on: April 30, 2015, 04:42:57 PM »
First, really liking this solution and this may quickly become my go-to!  Just wondering as it's been a few months, if there's any word on the settings (defaults) that aren't shown in the portal that keep getting reset on the client side... especially the PUP setting.  Again, thanks for this offer and keep up the excellent work!!