Author Topic: Install Failed ("access is denied")- "Install already in progress error" -SOLVED  (Read 5192 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
I am posting this in the hopes of helping someone else avoid a lot of time consuming troubleshooting. This is what worked for me to solve an error of "Install already in progress". It may of course be different for others.

I had been deploying the AVAST free educational software to clients and servers without trouble for several days. All of a sudden I started having problems installing to some clients and servers. The status of my job was "Failed ("access is denied"). Please check the Remote Install Log for details."

First off the remote install log is named "aswRInst.log" and was located under .\AVAST Software\Enterprise Administration\DATA\log (wherever you might have that installed).

in this log I found the following:
08/06/13 10:53:23:   rinstInstall begin
08/06/13 10:53:23:   Init 50 60 C:\Windows\TEMP\asw4D90.tmp D:\AVAST Software\Enterprise Administration\InstPkgs NULL  0
08/06/13 10:53:23:   Store
08/06/13 10:53:23:   Domains: education,
08/06/13 10:53:23:   Init EDUCATION\CLIENTNAME
08/06/13 10:53:23:   CLIENTNAME: install already in progress
08/06/13 10:53:23:   CLIENTNAME: Finished with error
08/06/13 10:53:23:   TerminateAll
08/06/13 10:53:24:   rinstInstall end 87

I tried all kinds of solutions - adjusting the firewall, turning off UAC, cleaning temp files, rebooting, etc. Nothing worked.

Finally, I realized that what had happened was that a temp file was "stuck" on the enterprise management server itself. This file was left over from an earlier aborted installation. That is the "C:\Windows\TEMP\asw4D90.tmp" that the log is referring to.

I found the file and deleted it. Problem solved - installation was successful. I now check the temp files more regularly than before to make sure there is nothing in the way there.


  • Guest
I've been looking for a solution to this issue for a few days now! Thank you for your post!